Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

errors php composer.phar install #2331

Closed
royepperson opened this issue Oct 15, 2013 · 3 comments
Closed

errors php composer.phar install #2331

royepperson opened this issue Oct 15, 2013 · 3 comments

Comments

@royepperson
Copy link

@royepperson royepperson commented Oct 15, 2013

I've been using composer with Doctrine 2 on Windows and now trying to use composer to install Doctrine 2 on a hosting service Unix php installation and their support staff isn't familiar with composer.

I downloaded composer.phar 1.0.0-alpha7 and placed it in the directory where I want to install Doctrine

My php version is:

roye@ptah:~/cnrepperson_com$ /usr/local/php53/bin/php -v
PHP 5.3.12 (cli) (built: May 6 2012 12:16:29)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies
with the ionCube PHP Loader v3.3.14, Copyright (c) 2002-2010, by ionCube Ltd.

When I try to execute composer, I get:

roye@ptah:~/cnrepperson_com$ /usr/local/php53/bin/php -c /home1/r/roye/conf/php.ini composer.phar install
PHP Warning: PHP Startup: memcache: Unable to initialize module
Module compiled with module API=20060613
PHP compiled with module API=20090626
These options need to match
in Unknown on line 0
PHP Deprecated: Directive 'register_globals' is deprecated in PHP 5.3 and greater in Unknown on line 0

Deprecated: Directive 'register_globals' is deprecated in PHP 5.3 and greater in Unknown on line 0
PHP Deprecated: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0

Deprecated: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
PHP Fatal error: require(): Failed opening required 'phar://composer.phar/bin/composer' (include_path='.:/usr/local/php5/lib/php') in /nfs/ank/home1/r/roye/cnrepperson_com/composer.phar on line 14

Fatal error: require(): Failed opening required 'phar://composer.phar/bin/composer' (include_path='.:/usr/local/php5/lib/php') in /nfs/ank/home1/r/roye/cnrepperson_com/composer.phar on line 14

I'm at a lost how to get this to work. Thanks in advance for any assistance!

Roy

@royepperson

This comment has been minimized.

Copy link
Author

@royepperson royepperson commented Oct 15, 2013

Looks like I was using the wrong php.ini file for php53. Will close if this is in fact the problem

@Seldaek

This comment has been minimized.

Copy link
Member

@Seldaek Seldaek commented Oct 16, 2013

I guess your other php.ini file had an auto_prepend_file or something that used register_globals and then registered invalid stuff and created problems. So yes let's close this.

@Seldaek Seldaek closed this Oct 16, 2013
@DAMskill

This comment has been minimized.

Copy link

@DAMskill DAMskill commented Feb 14, 2020

Ok so how doi fix this?

I'm encountering the same problem when trying to get "https://github.com/drupalcommerce/project-base" to work.

I'm a noob when it comes to these stuf. So sorry if the question seems funny.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants
You can’t perform that action at this time.