Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Switch to Symfony 3 #6552

Open
Seldaek opened this issue Jul 15, 2017 · 6 comments
Labels
Milestone

Comments

@Seldaek
Copy link
Member

@Seldaek Seldaek commented Jul 15, 2017

Just a list of things that would be good to have once we can switch to Symfony 3 (or 4..), as a reminder only.

@Seldaek Seldaek added this to the 2.0 milestone Jul 15, 2017
@alcohol alcohol added the Needs Work label Jul 31, 2017
@Webysther

This comment has been minimized.

Copy link

@Webysther Webysther commented Aug 17, 2017

Symfony 4 require PHP 7.1, it sounds huge drop of PHP support.

@staabm

This comment has been minimized.

Copy link
Contributor

@staabm staabm commented Aug 18, 2017

I would guess that you can still use composer 1.x for old php versions and composer 2.x for more modern ones.

@stof

This comment has been minimized.

Copy link
Contributor

@stof stof commented Aug 18, 2017

Another thing that will come: native color support on windows 10 for PHP 7.2+, as soon as symfony/console supports them (which is on my TODO-list for 3.4)

@derrabus

This comment has been minimized.

Copy link
Contributor

@derrabus derrabus commented Aug 18, 2017

Are there any plans on when to do a Composer 2 and what target environment it would have? I would volunteer to help with the migration, if help is needed. The migration could also be a source of tasks for the SymfonyCon hackday, maybe.

@stof

This comment has been minimized.

Copy link
Contributor

@stof stof commented Aug 18, 2017

@derrabus Composer is already compatible with Symfony 3 when using it as a library. What is impacted by this task is the phar, which requires being compatible with PHP 5.3 currently, and so cannot use Symfony 3 (which requires 5.5.9+)

@teohhanhui

This comment has been minimized.

Copy link

@teohhanhui teohhanhui commented Nov 8, 2019

I think Composer 2.0 could safely drop support for PHP < 5.6, at the very least. Since even WordPress has been nagging users to upgrade to at least PHP 5.6 for a while now: https://wordpress.org/news/2019/04/minimum-php-version-update/

@Seldaek Seldaek modified the milestones: 2.0, 3.0 Nov 8, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
7 participants
You can’t perform that action at this time.