Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

regression in 1.9.2 #8527

Closed
craigh opened this issue Jan 15, 2020 · 2 comments
Closed

regression in 1.9.2 #8527

craigh opened this issue Jan 15, 2020 · 2 comments

Comments

@craigh
Copy link

@craigh craigh commented Jan 15, 2020

I am experiencing a regression in composer 1.9.2. This worked find with 1.9.1. below are the relevant parts of the info

My composer.json:

    "require": {
        "php": ">=7.2.0",
        ...
        "symfony/requirements-checker": "dev-patch-1 as 1.*"
        ....
    },
    "repositories": [
        {
            "type": "git",
            "url": "https://github.com/craigh/requirements-checker"
        }
    ],

Output of composer diagnose:

craig% composer diagnose

                                                                                       
  [UnexpectedValueException]                                                           
  Could not parse version constraint dev-patch-1 as 1.*: Invalid version string "1.*"  
                                                                                       ```

When I run this command:

composer update

I get the following output:

craig% composer update

                                                                                       
  [UnexpectedValueException]                                                           
  Could not parse version constraint dev-patch-1 as 1.*: Invalid version string "1.*"  
                                                                                       ```

And I expected this to happen:
no errors.
@craigh

This comment has been minimized.

Copy link
Author

@craigh craigh commented Jan 15, 2020

I cannot rollback either...

craig% composer self-update --rollback

                                                                                       
  [UnexpectedValueException]                                                           
  Could not parse version constraint dev-patch-1 as 1.*: Invalid version string "1.*"  
@Seldaek

This comment has been minimized.

Copy link
Member

@Seldaek Seldaek commented Jan 15, 2020

This is actually a bugfix, this didn't make any sense before, and it is being validated now. Aliases should be specific versions, not ranges. dev-patch-1 as 1.99 for example.

@Seldaek Seldaek closed this Jan 15, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.