Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

can not update or install - error in substack/node-charm.git #8592

Open
pcalafatich opened this issue Feb 10, 2020 · 4 comments
Open

can not update or install - error in substack/node-charm.git #8592

pcalafatich opened this issue Feb 10, 2020 · 4 comments
Labels

Comments

@pcalafatich
Copy link

@pcalafatich pcalafatich commented Feb 10, 2020

My composer.json:

{
  "name": "yii2-starter-kit/yii2-starter-kit",
  "description": "Yii2 Starter Kit Application Template",
  "keywords": [
    "yii2",
    "framework",
    "start",
    "cms",
    "application template",
    "yii2 advanced"
  ],
  "authors": [
    {
      "name": "Eugene Terentev",
      "email": "eugene@terentev.net",
      "homepage": "http://terentev.net"
    }
  ],
  "type": "project",
  "license": "BSD-3-Clause",
  "support": {
    "issues": "https://github.com/yii2-starter-kit/yii2-starter-kit/issues?state=open",
    "source": "https://github.com/yii2-starter-kit/yii2-starter-kit"
  },
  "require": {
    "php": ">=7.1.0",
    "ext-intl": "*",
    "yiisoft/yii2": "^2.0.13",
    "yiisoft/yii2-bootstrap": "^2.0.0",
    "yiisoft/yii2-swiftmailer": "^2.0.0",
    "yiisoft/yii2-authclient": "^2.0.0",
    "yiisoft/yii2-jui": "^2.0.0",
    "yii2-starter-kit/yii2-file-kit": "^2.0.0",
    "dhtmlx/connector-php": "dev-modern",
    "trntv/yii2-aceeditor": "^2.0",
    "trntv/probe": "^1.0",
    "trntv/yii2-glide": "^1.2",

    "trntv/yii2-command-bus": "^3.0",
    "intervention/image": "^2.1",
    "vlucas/phpdotenv": "^2.0",
    "npm-asset/admin-lte": "^2.0",
    "npm-asset/font-awesome": "^4.0",
    "npm-asset/html5shiv": "^3.0",
    "npm-asset/jquery-slimscroll": "^1.3",
    "npm-asset/flot": "^0.8@alpha",
    "symfony/process": "^4.0",
    "guzzlehttp/guzzle": "^6.0",
    "alexantr/yii2-elfinder": "^1.3",
    "trntv/sitemaped": "^0.1",
    "yii2mod/yii2-swagger": "^1.1"
  },
  "require-dev": {
    "yiisoft/yii2-debug": "^2.0.0",
    "yiisoft/yii2-gii": "^2.0.0",
    "yiisoft/yii2-faker": "^2.0.0",
    "codeception/codeception": "2.4.0",
    "codeception/verify": "^0.3.1"
  },
  "autoload-dev": {
    "psr-4": {
      "tests\\": "tests/"
    }
  },
  "suggest": {
    "trntv/yii2-debug-xhprof": "dev-master@dev"
  },
  "config": {
    "process-timeout": 1800,
    "optimize-autoloader": true
  },
  "repositories": [ 
    { "type": "composer", 
      "url": "https://asset-packagist.org" } 
    ],
  "archive": {
    "exclude": ["docs"]
  },
  "scripts": {
    "build:env": [
      "cp .env.dist .env"
    ],
    "build:app": [
      "@composer install",
      "echo 'waiting for mysql' && sleep 10",
      "console/yii app/setup --interactive=0"
    ],
    "docker:build": [
      "@build:env",
      "@docker:start",
      "docker-compose exec -T app composer run-script build:app",
      "docker-compose run -T --rm webpacker npm i npm@latest -g",
      "docker-compose run -T --rm webpacker npm install",
      "docker-compose run -T --rm webpacker npm run build",
      "echo \"All ok!\""
    ],
    "docker:start": [
      "docker-compose up --force-recreate -d"
    ],
    "docker:cleanup": [
      "docker-compose rm -fsv"
    ]
  }
}

Output of composer diagnose:

Checking composer.json: OK
Checking platform settings: OK
Checking git settings: OK
Checking http connectivity to packagist: OK
Checking https connectivity to packagist: OK
Checking github.com oauth access: OK
Checking disk free space: OK
Checking pubkeys:
Tags Public Key Fingerprint: 57815BA2 7E54DC31 7ECC7CC5 573090D0  87719BA6 8F3BB
723 4E5D42D0 84A14642
Dev Public Key Fingerprint: 4AC45767 E5EC2265 2F0C1167 CBBB8A2B  0C708369 153E32
8C AD90147D AFE50952
OK
Checking composer version: OK
Composer version: 1.9.3
PHP version: 7.1.9
PHP binary path: C:\wamp64\bin\php\php7.1.9\php.exe

When I run this command:

composer update or composer require **** 

I get the following output:

Installation failed, reverting ./composer.json to its original content.


  [RuntimeException]
  Failed to execute git clone --mirror "git+ssh://git@github.com/substack/nod
  e-charm.git" "C:/Users/Usuario/AppData/Local/Composer/vcs/git-ssh---git-git
  hub.com-substack-node-charm.git/"

  Cloning into bare repository 'C:/Users/Usuario/AppData/Local/Composer/vcs/g
  it-ssh---git-github.com-substack-node-charm.git'...
  Host key verification failed.
  fatal: Could not read from remote repository.

  Please make sure you have the correct access rights
  and the repository exists.
@Seldaek Seldaek added the Support label Feb 10, 2020
@rubyqorn

This comment has been minimized.

Copy link

@rubyqorn rubyqorn commented Mar 9, 2020

I think the problem is that the substack/nodde-charm doesnt exists in packagist. I tried to find it at packagist.org and I didnt find it.

@canomogollon

This comment has been minimized.

Copy link

@canomogollon canomogollon commented Mar 19, 2020

i have same problem ... some idea how fix ?

@ShaporevNik

This comment has been minimized.

Copy link

@ShaporevNik ShaporevNik commented Mar 26, 2020

I have same problem ...already spent one week and still can't fix it -_-

@overals

This comment has been minimized.

Copy link

@overals overals commented Mar 31, 2020

any update?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
6 participants
You can’t perform that action at this time.