Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

fixing bug with multiple nested build-requires #5689

Merged

Conversation

@memsharded
Copy link
Member

@memsharded memsharded commented Aug 29, 2019

Changelog: Bugfix: Fixed assertion when using nested build_requires that depend on packages that are also used in the main dependency graph
Docs: omit

Close #5612
Close #5685
Close #5622 (included in this one)

@tags: slow

@lasote lasote added this to the 1.18.2 milestone Aug 29, 2019
@lasote lasote merged commit af81cbc into conan-io:release/1.18.2 Aug 30, 2019
2 checks passed
Loading
@memsharded memsharded deleted the hotfix/build_requires_nested_bug branch Aug 30, 2019
AKhranovskiy pushed a commit to AKhranovskiy/conan that referenced this issue Sep 2, 2019
* fixing bug with multiple nested build-requires

* add comments
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

2 participants