Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

"RuntimeError: Bundler error: `ruby_21` is not a valid platform" when starting Concerto #872

Closed
augustf opened this Issue · 7 comments

3 participants

@augustf
Owner

RuntimeError: Bundler error: ruby_21 is not a valid platform. The available options are: [:ruby, :ruby_18,
:ruby_19, :ruby_20, :mri, :mri_18, :mri_19, :mri_20, :rbx, :jruby, :mswin,
:mingw, :mingw_18, :mingw_19, :mingw_20]

/private/var/www/concerto/config/boot.rb:48:in <top (required)>'
/opt/local/lib/ruby2.0/2.0.0/rubygems/core_ext/kernel_require.rb:53:in
require'
/opt/local/lib/ruby2.0/2.0.0/rubygems/core_ext/kernel_require.rb:53:in require'
/private/var/www/concerto/config/application.rb:1:in
'
/opt/local/lib/ruby2.0/2.0.0/rubygems/core_ext/kernel_require.rb:53:in require'
/opt/local/lib/ruby2.0/2.0.0/rubygems/core_ext/kernel_require.rb:53:in
require' /private/var/www/concerto/config/environment.rb:2:in <top (required)>' /opt/local/lib/ruby2.0/2.0.0/rubygems/core_ext/kernel_require.rb:53:inrequire' /opt/local/lib/ruby2.0/2.0.0/rubygems/core_ext/kernel_require.rb:53:in require' /private/var/www/concerto/config.ru:3:inblock in ' ~/Library/Application Support/Pow/Versions/0.4.0/node_modules/nack/lib/nack/builder.rb:4:in instance_eval' ~/Library/Application Support/Pow/Versions/0.4.0/node_modules/nack/lib/nack/builder.rb:4:ininitialize' /private/var/www/concerto/config.ru:1:in new' /private/var/www/concerto/config.ru:1:in' ~/Library/Application Support/Pow/Versions/0.4.0/node_modules/nack/lib/nack/server.rb:50:in eval' ~/Library/Application Support/Pow/Versions/0.4.0/node_modules/nack/lib/nack/server.rb:50:inload_config' ~/Library/Application Support/Pow/Versions/0.4.0/node_modules/nack/lib/nack/server.rb:43:in initialize' ~/Library/Application Support/Pow/Versions/0.4.0/node_modules/nack/lib/nack/server.rb:13:innew' ~/Library/Application Support/Pow/Versions/0.4.0/node_modules/nack/lib/nack/server.rb:13:in run' ~/Library/Application Support/Pow/Versions/0.4.0/node_modules/nack/bin/nack_worker:4:in'

@mfrederickson
Collaborator

Works on my machine.... and on Travis....

@mfrederickson
Collaborator

Are you running bundler 1.5.2?

@augustf
Owner

Updating my system Bundler gem from 1.3.5 to 1.5.2 fixed this. I'm not sure when the ruby_21 symbol came in...

@augustf
Owner

If we're going to test on 2.1, we may want to include a specific Bundler version dependency in the Gemfile.

@augustf
Owner

Actually, for the public_activity line, can be do something like platforms > 1.8.x?

@zr2d2
Collaborator

I believe you can only specify certain :platforms http://bundler.io/v1.5/man/gemfile.5.html

@zr2d2
Collaborator

closed via 3fec33b

@zr2d2 zr2d2 closed this
@mikldt mikldt referenced this issue from a commit
@mikldt mikldt Don't support platforms bundler doesn't know about
This is an alternate solution to #872 that should prevent folks from
running into #876.
088f6b9
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.