Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

When I use #conda install acellerate, it fails:Error: post-link failed for: openssl-1.0.1k-1 #1344

Closed
RidgeSTD opened this issue May 23, 2015 · 4 comments

Comments

@RidgeSTD
Copy link

@RidgeSTD RidgeSTD commented May 23, 2015

When I use this command:

#conda install acellerate

After downloading, it fails with:Error: post-link failed for: openssl-1.0.1k-1. Just like #1260 ,failed at [Linking Packages...]

Same things happens when I tried conda update conda. Does anyone knows why this keeps happening and help me out? Thanks!

Meanwhile, while downloading, it failed several times with MD5 mismatch. I tried to fix it by wget url and download all files needed(at least i think).

What's odd is, after it failed with ''Error: post-link failed for: openssl-1.0.1k-1'', my ~/miniconda/bin/python2.7 is gone. I have to re-setup conda again and again.

Here is the screen-shot:

image

before i run #conda install acellerate i have these in my /miniconda/bin:
image

afterwards, these are left:
image

then i can't execute conda anymore for -bash: /home/ubuntu/miniconda/bin/conda: /home/ubuntu/miniconda/bin/python: bad interpreter: No such file or directory

@psanghavi2410

This comment has been minimized.

Copy link

@psanghavi2410 psanghavi2410 commented Jun 2, 2015

I was wondering, if you would solve this error. Kindly let me know if you found a way out.

@RidgeSTD

This comment has been minimized.

Copy link
Author

@RidgeSTD RidgeSTD commented Jun 2, 2015

@psanghavi2410 Haven't yet. I suspect it's maybe that model accelerate support ARM badly since i changed my environment to intel-based-ubuntu then the problem disappeared. That's just what the error info says: post-link failed. Your idea?

@psanghavi2410

This comment has been minimized.

Copy link

@psanghavi2410 psanghavi2410 commented Jun 2, 2015

I am trying to install it on raspberry2. I get this error every time I try to install or update any package!! I thought conda-build would help. However it fails showing the same error.

@soapy1

This comment has been minimized.

Copy link
Contributor

@soapy1 soapy1 commented Oct 23, 2016

@winlandiano is this still an issue for you?

@soapy1 soapy1 closed this Nov 18, 2016
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.