Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

macOS 10.14 Mojave : "Operation not permitted" when executing "conda update --all" #8440

Open
zhiyuanzhai opened this Issue Mar 23, 2019 · 19 comments

Comments

Projects
None yet
@zhiyuanzhai
Copy link

commented Mar 23, 2019

Current Behavior

Steps to Reproduce

conda update --all
Collecting package metadata: done
Solving environment: done

## Package Plan ##

  environment location: /anaconda3


The following NEW packages will be INSTALLED:

  _license           anaconda/pkgs/free/osx-64::_license-1.1-py36_1
  libopenblas        pkgs/main/osx-64::libopenblas-0.3.3-hdc02c5d_3

The following packages will be UPDATED:

  atomicwrites       pkgs/main/noarch::atomicwrites-1.3.0-~ --> pkgs/main/osx-64::atomicwrites-1.3.0-py36_1
  blas                              pkgs/main::blas-1.0-mkl --> anaconda/pkgs/free::blas-1.0-openblas
  dask-core          pkgs/main/noarch::dask-core-1.1.4-py_0 --> pkgs/main/osx-64::dask-core-1.1.4-py36_1
  intel-openmp                                   2019.1-144 --> 2019.3-199
  libcxx                                   4.0.1-h579ed51_0 --> 4.0.1-hcfea43d_1
  libcxxabi                                4.0.1-hebd6815_0 --> 4.0.1-hcfea43d_1
  spyder-kernels                               0.4.2-py36_0 --> 1.3.2-py36_0
  xlwt                 pkgs/main::xlwt-1.2.0-py36h5ad1178_0 --> anaconda/pkgs/free::xlwt-1.3.0-py36_0
  zipp                    pkgs/main/noarch::zipp-0.3.3-py_0 --> pkgs/main/osx-64::zipp-0.3.3-py36_1

The following packages will be SUPERSEDED by a higher-priority channel:

  alabaster              pkgs/main::alabaster-0.7.12-py36_0 --> anaconda/pkgs/free::alabaster-0.7.10-py36_0
  anaconda-clean     pkgs/main::anaconda-clean-1.1.0-py36_1 --> anaconda/pkgs/free::anaconda-clean-1.1.0-py36_0
  anaconda-client    pkgs/main::anaconda-client-1.7.2-py36~ --> anaconda/pkgs/free::anaconda-client-1.6.3-py36_0
  anaconda-navigator pkgs/main::anaconda-navigator-1.9.6-p~ --> anaconda/pkgs/free::anaconda-navigator-1.6.4-py36_0
  anaconda-project   pkgs/main::anaconda-project-0.8.2-py3~ --> anaconda/pkgs/free::anaconda-project-0.6.0-py36_0
  anyqt                      pkgs/main::anyqt-0.0.10-py36_0 --> anaconda/pkgs/free::anyqt-0.0.8-py36_0
  appnope            pkgs/main::appnope-0.1.0-py36hf537a9a~ --> anaconda/pkgs/free::appnope-0.1.0-py36_0
  appscript          pkgs/main::appscript-1.1.0-py36h1de35~ --> anaconda/pkgs/free::appscript-1.0.1-py36_0
  asn1crypto            pkgs/main::asn1crypto-0.24.0-py36_0 --> anaconda/pkgs/free::asn1crypto-0.22.0-py36_0
  astroid                   pkgs/main::astroid-2.2.5-py36_0 --> anaconda/pkgs/free::astroid-1.5.3-py36_0
  astropy            pkgs/main::astropy-3.1.2-py36h1de35cc~ --> anaconda/pkgs/free::astropy-2.0.2-py36h4654939_4
  attrs                 pkgs/main/noarch::attrs-19.1.0-py_0 --> anaconda/pkgs/free/osx-64::attrs-15.2.0-py36_0
  automat                   pkgs/main::automat-0.7.0-py36_0 --> anaconda/pkgs/free::automat-0.5.0-py36_0
  babel                       pkgs/main::babel-2.6.0-py36_0 --> anaconda/pkgs/free::babel-2.5.0-py36_0
  backports          pkgs/main::backports-1.0-py36ha3c1827~ --> anaconda/pkgs/free::backports-1.0-py36_0
  beautifulsoup4     pkgs/main::beautifulsoup4-4.7.1-py36_1 --> anaconda/pkgs/free::beautifulsoup4-4.6.0-py36_0
  bitarray           pkgs/main::bitarray-0.8.3-py36h1de35c~ --> anaconda/pkgs/free::bitarray-0.8.1-py36_0
  bkcharts           pkgs/main::bkcharts-0.2-py36h073222e_0 --> anaconda/pkgs/free::bkcharts-0.2-py36_0
  blaze              pkgs/main::blaze-0.11.3-py36h02e7a37_0 --> anaconda/pkgs/free::blaze-0.10.1-py36_0
  bleach                     pkgs/main::bleach-3.1.0-py36_0 --> anaconda/pkgs/free::bleach-1.5.0-py36_0
  blosc                  pkgs/main::blosc-1.15.0-hd9629dc_0 --> anaconda/pkgs/free::blosc-1.2.3-0
  bokeh                       pkgs/main::bokeh-1.0.4-py36_0 --> anaconda/pkgs/free::bokeh-0.12.7-py36_0
  boto                        pkgs/main::boto-2.49.0-py36_0 --> anaconda/pkgs/free::boto-2.48.0-py36_0
  bottleneck         pkgs/main::bottleneck-1.2.1-py36h1d22~ --> anaconda/pkgs/free::bottleneck-1.2.1-np111py36_0
  bzip2                   pkgs/main::bzip2-1.0.6-hd86a083_4 --> anaconda/pkgs/free::bzip2-1.0.6-3
  cffi                pkgs/main::cffi-1.12.2-py36hb5b8e2f_1 --> anaconda/pkgs/free::cffi-1.10.0-py36_0
  chardet            pkgs/main::chardet-3.0.4-py36h96c241c~ --> anaconda/pkgs/free::chardet-3.0.4-py36_0
  click                         pkgs/main::click-7.0-py36_0 --> anaconda/pkgs/free::click-6.7-py36_0
  cloudpickle           pkgs/main::cloudpickle-0.8.0-py36_0 --> anaconda/pkgs/free::cloudpickle-0.4.0-py36_0
  clyent             pkgs/main::clyent-1.2.2-py36hae3ad88_0 --> anaconda/pkgs/free::clyent-1.2.2-py36_0
  colorama                 pkgs/main::colorama-0.4.1-py36_0 --> anaconda/pkgs/free::colorama-0.3.9-py36_0
  conda-build          pkgs/main::conda-build-3.17.8-py36_0 --> anaconda/pkgs/free::conda-build-3.0.19-py36h997aa4c_0
  conda-env           pkgs/main::conda-env-2.6.0-h36134e3_0 --> anaconda/pkgs/free::conda-env-2.6.0-0
  conda-verify         pkgs/main::conda-verify-3.1.1-py36_0 --> anaconda/pkgs/free::conda-verify-2.0.0-py36_0
  constantly         pkgs/main::constantly-15.1.0-py36h28b~ --> anaconda/pkgs/free::constantly-15.1.0-py36_0
  contextlib2        pkgs/main::contextlib2-0.5.5-py36hd66~ --> anaconda/pkgs/free::contextlib2-0.5.5-py36_0
  cryptography       pkgs/main::cryptography-2.6.1-py36ha1~ --> anaconda/pkgs/free::cryptography-1.8.1-py36_0
  curl                    pkgs/main::curl-7.64.0-ha441bb4_2 --> anaconda/pkgs/free::curl-7.52.1-0
  cycler             pkgs/main::cycler-0.10.0-py36hfc81398~ --> anaconda/pkgs/free::cycler-0.10.0-py36_0
  cython             pkgs/main::cython-0.29.6-py36h0a44026~ --> anaconda/pkgs/free::cython-0.26-py36_0
  cytoolz            pkgs/main::cytoolz-0.9.0.1-py36h1de35~ --> anaconda/pkgs/free::cytoolz-0.8.2-py36_0
  dask                    pkgs/main/noarch::dask-1.1.4-py_0 --> anaconda/pkgs/free/osx-64::dask-0.15.2-py36_0
  datashape          pkgs/main::datashape-0.5.4-py36hfb22d~ --> anaconda/pkgs/free::datashape-0.5.4-py36_0
  decorator          pkgs/main/noarch::decorator-4.4.0-py_0 --> anaconda/pkgs/free/osx-64::decorator-4.1.2-py36_0
  dill                         pkgs/main::dill-0.2.9-py36_0 --> anaconda/pkgs/free::dill-0.2.6-py36_0
  distributed          pkgs/main::distributed-1.26.0-py36_1 --> anaconda/pkgs/free::distributed-1.18.1-py36_0
  docutils           pkgs/main::docutils-0.14-py36hbfde631~ --> anaconda/pkgs/free::docutils-0.14-py36_0
  entrypoints             pkgs/main::entrypoints-0.3-py36_0 --> anaconda/pkgs/free::entrypoints-0.2.3-py36_0
  et_xmlfile         pkgs/main::et_xmlfile-1.0.1-py36h1315~ --> anaconda/pkgs/free::et_xmlfile-1.0.1-py36_0
  fastcache          pkgs/main::fastcache-1.0.2-py36h1de35~ --> anaconda/pkgs/free::fastcache-1.0.2-py36_1
  filelock                pkgs/main::filelock-3.0.10-py36_0 --> anaconda/pkgs/free::filelock-2.0.7-py36_0
  flask                       pkgs/main::flask-1.0.2-py36_1 --> anaconda/pkgs/free::flask-0.12.2-py36_0
  flask-cors             pkgs/main::flask-cors-3.0.7-py36_0 --> anaconda/pkgs/free::flask-cors-3.0.3-py36_0
  freetype             pkgs/main::freetype-2.9.1-hb4e5f40_0 --> anaconda/pkgs/free::freetype-2.5.5-2
  future                    pkgs/main::future-0.17.1-py36_0 --> anaconda/pkgs/free::future-0.16.0-py36_1
  get_terminal_size  pkgs/main::get_terminal_size-1.0.0-h7~ --> anaconda/pkgs/free::get_terminal_size-1.0.0-py36_0
  gettext            pkgs/main::gettext-0.19.8.1-h15daf44_3 --> anaconda/pkgs/free::gettext-0.19.8-1
  gevent             pkgs/main::gevent-1.4.0-py36h1de35cc_0 --> anaconda/pkgs/free::gevent-1.2.2-py36_0
  glob2                 pkgs/main::glob2-0.6-py36h94c9186_0 --> anaconda/pkgs/free::glob2-0.5-py36_0
  glue-core              pkgs/main::glue-core-0.14.1-py36_0 --> anaconda/pkgs/free::glue-core-0.10.4-py36_0
  glue-vispy-viewers pkgs/main/noarch::glue-vispy-viewers-~ --> anaconda/pkgs/free/osx-64::glue-vispy-viewers-0.7.2-py36_0
  glueviz                       pkgs/main::glueviz-0.13.3-0 --> anaconda/pkgs/free::glueviz-0.10.4-py36_0
  gmp                       pkgs/main::gmp-6.1.2-hb37e062_1 --> anaconda/pkgs/free::gmp-6.1.0-0
  greenlet           pkgs/main::greenlet-0.4.15-py36h1de35~ --> anaconda/pkgs/free::greenlet-0.4.12-py36_0
  h5py                 pkgs/main::h5py-2.9.0-py36h3134771_0 --> anaconda/pkgs/free::h5py-2.7.0-np111py36_0
  hdf5                    pkgs/main::hdf5-1.10.4-hfa1e0ec_0 --> anaconda/pkgs/free::hdf5-1.8.17-2
  heapdict                 pkgs/main::heapdict-1.0.0-py36_2 --> anaconda/pkgs/free::heapdict-1.0.0-py36_1
  html5lib           pkgs/main::html5lib-1.0.1-py36h2f9c1c~ --> anaconda/pkgs/free::html5lib-0.999-py36_0
  hyperlink              pkgs/main::hyperlink-18.0.0-py36_0 --> anaconda/pkgs/free::hyperlink-17.1.1-py36_0
  icu                        pkgs/main::icu-58.2-h4b95b61_1 --> anaconda/pkgs/free::icu-54.1-0
  idna                           pkgs/main::idna-2.8-py36_0 --> anaconda/pkgs/free::idna-2.6-py36_0
  imagesize               pkgs/main::imagesize-1.1.0-py36_0 --> anaconda/pkgs/free::imagesize-0.7.1-py36_0
  incremental          pkgs/main::incremental-17.5.0-py36_0 --> anaconda/pkgs/free::incremental-16.10.1-py36_0
  ipykernel          pkgs/main::ipykernel-5.1.0-py36h39e3c~ --> anaconda/pkgs/free::ipykernel-4.6.1-py36_0
  ipython            pkgs/main::ipython-7.3.0-py36h39e3cac~ --> anaconda/pkgs/free::ipython-6.1.0-py36_0
  ipython_genutils   pkgs/main::ipython_genutils-0.2.0-py3~ --> anaconda/pkgs/free::ipython_genutils-0.2.0-py36_0
  ipywidgets             pkgs/main::ipywidgets-7.4.2-py36_0 --> anaconda/pkgs/free::ipywidgets-6.0.0-py36_0
  isort                      pkgs/main::isort-4.3.15-py36_0 --> anaconda/pkgs/free::isort-4.2.15-py36_0
  itsdangerous         pkgs/main::itsdangerous-1.1.0-py36_0 --> anaconda/pkgs/free::itsdangerous-0.24-py36_0
  jbig                       pkgs/main::jbig-2.1-h4d881f8_0 --> anaconda/pkgs/free::jbig-2.1-0
  jdcal                         pkgs/main::jdcal-1.4-py36_0 --> anaconda/pkgs/free::jdcal-1.3-py36_0
  jedi                        pkgs/main::jedi-0.13.3-py36_0 --> anaconda/pkgs/free::jedi-0.10.2-py36_2
  jinja2              pkgs/main::jinja2-2.10-py36hd36f9c5_0 --> anaconda/pkgs/free::jinja2-2.9.6-py36_0
  joblib                    pkgs/main::joblib-0.13.2-py36_0 --> anaconda/pkgs/free::joblib-0.11-py36_0
  jpeg                        pkgs/main::jpeg-9b-he5867d9_2 --> anaconda/pkgs/free::jpeg-9b-0
  jsonschema             pkgs/main::jsonschema-3.0.1-py36_0 --> anaconda/pkgs/free::jsonschema-2.6.0-py36_0
  jupyter                   pkgs/main::jupyter-1.0.0-py36_4 --> anaconda/pkgs/free::jupyter-1.0.0-py36_3
  jupyter_client     pkgs/main::jupyter_client-5.2.4-py36_0 --> anaconda/pkgs/free::jupyter_client-5.1.0-py36_0
  jupyter_console    pkgs/main::jupyter_console-6.0.0-py36~ --> anaconda/pkgs/free::jupyter_console-5.2.0-py36_0
  jupyter_core       pkgs/main::jupyter_core-4.4.0-py36h79~ --> anaconda/pkgs/free::jupyter_core-4.3.0-py36_0
  keyring                  pkgs/main::keyring-18.0.0-py36_0 --> anaconda/pkgs/free::keyring-9.3.1-py36_0
  krb5                    pkgs/main::krb5-1.16.1-hddcf347_7 --> anaconda/pkgs/free::krb5-1.13.2-0
  lazy-object-proxy  pkgs/main::lazy-object-proxy-1.3.1-py~ --> anaconda/pkgs/free::lazy-object-proxy-1.3.1-py36_0
  libffi                 pkgs/main::libffi-3.2.1-h475c297_4 --> anaconda/pkgs/free::libffi-3.2.1-1
  libpng                pkgs/main::libpng-1.6.36-ha441bb4_0 --> anaconda/pkgs/free::libpng-1.6.30-1
  libsodium          pkgs/main::libsodium-1.0.16-h3efe00b_0 --> anaconda/pkgs/free::libsodium-1.0.3-0
  libssh2               pkgs/main::libssh2-1.8.0-ha12b0ac_4 --> anaconda/pkgs/free::libssh2-1.8.0-0
  libtiff              pkgs/main::libtiff-4.0.10-hcb84e12_2 --> anaconda/pkgs/free::libtiff-4.0.6-3
  libxml2               pkgs/main::libxml2-2.9.9-hab757c2_0 --> anaconda/pkgs/free::libxml2-2.9.4-0
  libxslt              pkgs/main::libxslt-1.1.33-h33a18ac_0 --> anaconda/pkgs/free::libxslt-1.1.29-0
  locket             pkgs/main::locket-0.2.0-py36hca03003_1 --> anaconda/pkgs/free::locket-0.2.0-py36_1
  lxml                 pkgs/main::lxml-4.3.2-py36hef8c89e_0 --> anaconda/pkgs/free::lxml-3.8.0-py36_0
  lzo                        pkgs/main::lzo-2.10-h362108e_2 --> anaconda/pkgs/free::lzo-2.06-0
  markupsafe         pkgs/main::markupsafe-1.1.1-py36h1de3~ --> anaconda/pkgs/free::markupsafe-1.0-py36_0
  matplotlib         pkgs/main::matplotlib-3.0.3-py36h54f8~ --> anaconda/pkgs/free::matplotlib-2.0.2-np111py36_0
  mccabe             pkgs/main::mccabe-0.6.1-py36hdaeb55d_0 --> anaconda/pkgs/free::mccabe-0.6.1-py36_0
  mistune            pkgs/main::mistune-0.8.4-py36h1de35cc~ --> anaconda/pkgs/free::mistune-0.7.4-py36_0
  mkl                             pkgs/main::mkl-2019.1-144 --> anaconda/pkgs/free::mkl-2017.0.3-0
  mkl-service        pkgs/main::mkl-service-1.1.2-py36hfbe~ --> anaconda/pkgs/free::mkl-service-1.1.2-py36_3
  more-itertools     pkgs/main::more-itertools-6.0.0-py36_0 --> anaconda/pkgs/free::more-itertools-3.2.0-py36_0
  mpc                       pkgs/main::mpc-1.1.0-h6ef4df4_1 --> anaconda/pkgs/free::mpc-1.0.3-0
  mpfr                     pkgs/main::mpfr-4.0.1-h3018a27_3 --> anaconda/pkgs/free::mpfr-3.1.5-0
  mpmath                     pkgs/main::mpmath-1.1.0-py36_0 --> anaconda/pkgs/free::mpmath-0.19-py36_1
  msgpack-python     pkgs/main::msgpack-python-0.6.1-py36h~ --> anaconda/pkgs/free::msgpack-python-0.4.8-py36_0
  multipledispatch   pkgs/main::multipledispatch-0.6.0-py3~ --> anaconda/pkgs/free::multipledispatch-0.4.9-py36_0
  navigator-updater  pkgs/main::navigator-updater-0.2.1-py~ --> anaconda/pkgs/free::navigator-updater-0.1.0-py36_0
  nbconvert          pkgs/main/noarch::nbconvert-5.4.1-py_2 --> anaconda/pkgs/free/osx-64::nbconvert-5.2.1-py36_0
  nbformat           pkgs/main::nbformat-4.4.0-py36h827af2~ --> anaconda/pkgs/free::nbformat-4.4.0-py36_0
  networkx                   pkgs/main::networkx-2.2-py36_1 --> anaconda/pkgs/free::networkx-1.11-py36_0
  nltk                           pkgs/main::nltk-3.4-py36_1 --> anaconda/pkgs/free::nltk-3.2.4-py36_0
  nose                 pkgs/main::nose-1.3.7-py36h73fae2b_2 --> anaconda/pkgs/free::nose-1.3.7-py36_1
  notebook                 pkgs/main::notebook-5.7.6-py36_0 --> anaconda/pkgs/free::notebook-5.0.0-py36_0
  numexpr            pkgs/main::numexpr-2.6.9-py36h7413580~ --> anaconda/pkgs/free::numexpr-2.6.2-np111py36_nomkl_0
  numpydoc                 pkgs/main::numpydoc-0.8.0-py36_0 --> anaconda/pkgs/free::numpydoc-0.7.0-py36_0
  odo                   pkgs/main::odo-0.5.1-py36hc1af34a_0 --> anaconda/pkgs/free::odo-0.5.1-py36_0
  olefile                    pkgs/main::olefile-0.46-py36_0 --> anaconda/pkgs/free::olefile-0.44-py36_0
  openpyxl            pkgs/main/noarch::openpyxl-2.6.1-py_0 --> anaconda/pkgs/free/osx-64::openpyxl-2.4.8-py36_0
  orange3            pkgs/main::orange3-3.19.0-py36h0a4402~ --> anaconda/pkgs/free::orange3-3.4.1-py36_0
  packaging                pkgs/main::packaging-19.0-py36_0 --> anaconda/pkgs/free::packaging-16.8-py36_0
  pandas             pkgs/main::pandas-0.24.2-py36h0a44026~ --> anaconda/pkgs/free::pandas-0.20.1-np111py36_0
  pandoc                        pkgs/main::pandoc-2.2.3.2-0 --> anaconda/pkgs/free::pandoc-1.19.2.1-0
  pandocfilters      pkgs/main::pandocfilters-1.4.2-py36h3~ --> anaconda/pkgs/free::pandocfilters-1.4.2-py36_0
  partd                 pkgs/main/noarch::partd-0.3.10-py_0 --> anaconda/pkgs/free/osx-64::partd-0.3.8-py36_0
  path.py                  pkgs/main::path.py-11.5.0-py36_0 --> anaconda/pkgs/free::path.py-10.3.1-py36_0
  pathlib2                 pkgs/main::pathlib2-2.3.3-py36_0 --> anaconda/pkgs/free::pathlib2-2.3.0-py36_0
  patsy                       pkgs/main::patsy-0.5.1-py36_0 --> anaconda/pkgs/free::patsy-0.4.1-py36_0
  pcre                      pkgs/main::pcre-8.43-h0a44026_0 --> anaconda/pkgs/free::pcre-8.39-1
  pep8                         pkgs/main::pep8-1.7.1-py36_0 --> anaconda/pkgs/free::pep8-1.7.0-py36_0
  pexpect                   pkgs/main::pexpect-4.6.0-py36_0 --> anaconda/pkgs/free::pexpect-4.2.1-py36_0
  pickleshare           pkgs/main::pickleshare-0.7.5-py36_0 --> anaconda/pkgs/free::pickleshare-0.7.4-py36_0
  pillow             pkgs/main::pillow-5.4.1-py36hb68e598_0 --> anaconda/pkgs/free::pillow-4.2.1-py36_0
  pip                          pkgs/main::pip-19.0.3-py36_0 --> anaconda/pkgs/free::pip-9.0.1-py36_1
  pkginfo                 pkgs/main::pkginfo-1.5.0.1-py36_0 --> anaconda/pkgs/free::pkginfo-1.4.1-py36_0
  plotly                pkgs/main/noarch::plotly-3.7.0-py_0 --> anaconda/pkgs/free/osx-64::plotly-2.0.11-py36_0
  ply                            pkgs/main::ply-3.11-py36_0 --> anaconda/pkgs/free::ply-3.10-py36_0
  prompt_toolkit     pkgs/main::prompt_toolkit-2.0.9-py36_0 --> anaconda/pkgs/free::prompt_toolkit-1.0.15-py36_0
  psutil             pkgs/main::psutil-5.6.1-py36h1de35cc_0 --> anaconda/pkgs/free::psutil-5.2.2-py36_0
  ptyprocess             pkgs/main::ptyprocess-0.6.0-py36_0 --> anaconda/pkgs/free::ptyprocess-0.5.2-py36_0
  py                             pkgs/main::py-1.8.0-py36_0 --> anaconda/pkgs/free::py-1.4.34-py36_0
  pycodestyle           pkgs/main::pycodestyle-2.5.0-py36_0 --> anaconda/pkgs/free::pycodestyle-2.3.1-py36_0
  pycparser                pkgs/main::pycparser-2.19-py36_0 --> anaconda/pkgs/free::pycparser-2.18-py36_0
  pycrypto           pkgs/main::pycrypto-2.6.1-py36h1de35c~ --> anaconda/pkgs/free::pycrypto-2.6.1-py36_6
  pycurl             pkgs/main::pycurl-7.43.0.2-py36ha12b0~ --> anaconda/pkgs/free::pycurl-7.43.0-py36_2
  pyflakes                 pkgs/main::pyflakes-2.1.1-py36_0 --> anaconda/pkgs/free::pyflakes-1.6.0-py36_0
  pygments                 pkgs/main::pygments-2.3.1-py36_0 --> anaconda/pkgs/free::pygments-2.2.0-py36_0
  pylint                     pkgs/main::pylint-2.3.1-py36_0 --> anaconda/pkgs/free::pylint-1.7.2-py36_0
  pyodbc             pkgs/main::pyodbc-4.0.26-py36h0a44026~ --> anaconda/pkgs/free::pyodbc-4.0.17-py36_0
  pyopengl               pkgs/main::pyopengl-3.1.1a1-py36_0 --> anaconda/pkgs/free::pyopengl-3.1.1a1-np111py36_0
  pyopenssl              pkgs/main::pyopenssl-19.0.0-py36_0 --> anaconda/pkgs/free::pyopenssl-17.0.0-py36_0
  pyparsing               pkgs/main::pyparsing-2.3.1-py36_0 --> anaconda/pkgs/free::pyparsing-2.2.0-py36_0
  pyqt                 pkgs/main::pyqt-5.9.2-py36h655552a_2 --> anaconda/pkgs/free::pyqt-5.6.0-py36_2
  pyqtgraph          pkgs/main::pyqtgraph-0.10.0-py36h28b3~ --> anaconda/pkgs/free::pyqtgraph-0.10.0-py36_0
  pysocks                   pkgs/main::pysocks-1.6.8-py36_0 --> anaconda/pkgs/free::pysocks-1.6.6-py36_0
  pytables           pkgs/main::pytables-3.5.1-py36h5bccee~ --> anaconda/pkgs/free::pytables-3.3.0-np111py36_0
  pytest                     pkgs/main::pytest-4.3.1-py36_0 --> anaconda/pkgs/free::pytest-3.2.1-py36_0
  python                 pkgs/main::python-3.6.8-haf84260_0 --> anaconda/pkgs/free::python-3.6.2-0
  python-dateutil    pkgs/main::python-dateutil-2.8.0-py36~ --> anaconda/pkgs/free::python-dateutil-2.6.1-py36_0
  python.app         pkgs/main::python.app-2-py36h54569d5_7 --> anaconda/pkgs/free::python.app-1.2-py36_4
  pytz                        pkgs/main::pytz-2018.9-py36_0 --> anaconda/pkgs/free::pytz-2017.2-py36_0
  pywavelets         pkgs/main::pywavelets-1.0.2-py36h1d22~ --> anaconda/pkgs/free::pywavelets-0.5.2-np111py36_0
  pyyaml               pkgs/main::pyyaml-5.1-py36h1de35cc_0 --> anaconda/pkgs/free::pyyaml-3.12-py36_0
  pyzmq              pkgs/main::pyzmq-18.0.0-py36h0a44026_0 --> anaconda/pkgs/free::pyzmq-16.0.2-py36_0
  qt                         pkgs/main::qt-5.9.7-h468cd18_1 --> anaconda/pkgs/free::qt-5.6.2-2
  qtawesome          pkgs/main/noarch::qtawesome-0.5.7-py_0 --> anaconda/pkgs/free/osx-64::qtawesome-0.4.4-py36_0
  qtconsole               pkgs/main::qtconsole-4.4.3-py36_0 --> anaconda/pkgs/free::qtconsole-4.3.1-py36_0
  qtpy                    pkgs/main/noarch::qtpy-1.7.0-py_0 --> anaconda/pkgs/free/osx-64::qtpy-1.3.1-py36_0
  readline               pkgs/main::readline-7.0-hc1231fa_4 --> anaconda/pkgs/free::readline-6.2-2
  rope                        pkgs/main::rope-0.12.0-py36_0 --> anaconda/pkgs/free::rope-0.9.4-py36_1
  ruamel_yaml        pkgs/main::ruamel_yaml-0.15.46-py36h1~ --> anaconda/pkgs/free::ruamel_yaml-0.11.14-py36_1
  scikit-image       pkgs/main::scikit-image-0.14.2-py36h0~ --> anaconda/pkgs/free::scikit-image-0.13.0-np111py36_0
  scipy               pkgs/main::scipy-1.2.1-py36h1410ff5_0 --> anaconda/pkgs/free::scipy-0.19.0-np111py36_nomkl_0
  seaborn                   pkgs/main::seaborn-0.9.0-py36_0 --> anaconda/pkgs/free::seaborn-0.8-py36_0
  setuptools            pkgs/main::setuptools-40.8.0-py36_0 --> anaconda/pkgs/free::setuptools-36.4.0-py36_1
  simplegeneric       pkgs/main::simplegeneric-0.8.1-py36_2 --> anaconda/pkgs/free::simplegeneric-0.8.1-py36_1
  singledispatch     pkgs/main::singledispatch-3.4.0.3-py3~ --> anaconda/pkgs/free::singledispatch-3.4.0.3-py36_0
  sip                  pkgs/main::sip-4.19.8-py36h0a44026_0 --> anaconda/pkgs/free::sip-4.18-py36_0
  six                          pkgs/main::six-1.12.0-py36_0 --> anaconda/pkgs/free::six-1.10.0-py36_0
  snappy                 pkgs/main::snappy-1.1.7-he62c110_3 --> anaconda/pkgs/free::snappy-1.1.6-0
  snowballstemmer    pkgs/main::snowballstemmer-1.2.1-py36~ --> anaconda/pkgs/free::snowballstemmer-1.2.1-py36_0
  sortedcollections  pkgs/main::sortedcollections-1.1.2-py~ --> anaconda/pkgs/free::sortedcollections-0.5.3-py36_0
  sortedcontainers   pkgs/main::sortedcontainers-2.1.0-py3~ --> anaconda/pkgs/free::sortedcontainers-1.5.7-py36_0
  sphinx                     pkgs/main::sphinx-1.8.5-py36_0 --> anaconda/pkgs/free::sphinx-1.6.3-py36_0
  sphinxcontrib      pkgs/main::sphinxcontrib-1.0-py36h936~ --> anaconda/pkgs/free::sphinxcontrib-1.0-py36_0
  sphinxcontrib-web~ pkgs/main::sphinxcontrib-websupport-1~ --> anaconda/pkgs/free::sphinxcontrib-websupport-1.0.1-py36_0
  spyder                     pkgs/main::spyder-3.3.3-py36_0 --> anaconda/pkgs/free::spyder-3.2.3-py36_0
  sqlalchemy         pkgs/main::sqlalchemy-1.3.1-py36h1de3~ --> anaconda/pkgs/free::sqlalchemy-1.1.13-py36_0
  sqlite                pkgs/main::sqlite-3.27.2-ha441bb4_0 --> anaconda/pkgs/free::sqlite-3.13.0-0
  statsmodels        pkgs/main::statsmodels-0.9.0-py36h1d2~ --> anaconda/pkgs/free::statsmodels-0.8.0-np111py36_0
  sympy                         pkgs/main::sympy-1.3-py36_0 --> anaconda/pkgs/free::sympy-1.1.1-py36_0
  tblib               pkgs/main::tblib-1.3.2-py36hda67792_0 --> anaconda/pkgs/free::tblib-1.3.2-py36_0
  terminado               pkgs/main::terminado-0.8.1-py36_1 --> anaconda/pkgs/free::terminado-0.6-py36_0
  testpath                 pkgs/main::testpath-0.4.2-py36_0 --> anaconda/pkgs/free::testpath-0.3.1-py36_0
  tk                         pkgs/main::tk-8.6.8-ha441bb4_0 --> anaconda/pkgs/free::tk-8.5.18-0
  toolz                       pkgs/main::toolz-0.9.0-py36_0 --> anaconda/pkgs/free::toolz-0.8.2-py36_0
  tornado            pkgs/main::tornado-6.0.1-py36h1de35cc~ --> anaconda/pkgs/free::tornado-4.5.2-py36_0
  tqdm                   pkgs/main/noarch::tqdm-4.31.1-py_0 --> anaconda/pkgs/free/osx-64::tqdm-4.15.0-py36_0
  traitlets          pkgs/main::traitlets-4.3.2-py36h65bd3~ --> anaconda/pkgs/free::traitlets-4.3.2-py36_0
  twisted                                         pkgs/free --> anaconda/pkgs/free
  typing                     pkgs/main::typing-3.6.4-py36_0 --> anaconda/pkgs/free::typing-3.6.2-py36_0
  unicodecsv         pkgs/main::unicodecsv-0.14.1-py36he53~ --> anaconda/pkgs/free::unicodecsv-0.14.1-py36_0
  unixodbc             pkgs/main::unixodbc-2.3.7-h1de35cc_0 --> anaconda/pkgs/free::unixodbc-2.3.4-0
  urllib3                  pkgs/main::urllib3-1.24.1-py36_0 --> anaconda/pkgs/free::urllib3-1.21.1-py36_0
  wcwidth            pkgs/main::wcwidth-0.1.7-py36h8c6ec74~ --> anaconda/pkgs/free::wcwidth-0.1.7-py36_0
  werkzeug                pkgs/main::werkzeug-0.14.1-py36_0 --> anaconda/pkgs/free::werkzeug-0.12.2-py36_0
  wheel                      pkgs/main::wheel-0.33.1-py36_0 --> anaconda/pkgs/free::wheel-0.29.0-py36_0
  widgetsnbextension pkgs/main::widgetsnbextension-3.4.2-p~ --> anaconda/pkgs/free::widgetsnbextension-3.0.2-py36_0
  wrapt              pkgs/main::wrapt-1.11.1-py36h1de35cc_0 --> anaconda/pkgs/free::wrapt-1.10.11-py36_0
  xlrd                         pkgs/main::xlrd-1.2.0-py36_0 --> anaconda/pkgs/free::xlrd-1.1.0-py36_0
  xlsxwriter             pkgs/main::xlsxwriter-1.1.5-py36_0 --> anaconda/pkgs/free::xlsxwriter-0.9.8-py36_0
  xlwings                  pkgs/main::xlwings-0.15.4-py36_0 --> anaconda/pkgs/free::xlwings-0.11.4-py36_0
  xz                         pkgs/main::xz-5.2.4-h1de35cc_4 --> anaconda/pkgs/free::xz-5.2.3-0
  yaml                     pkgs/main::yaml-0.1.7-hc338f04_2 --> anaconda/pkgs/free::yaml-0.1.6-0
  zeromq                 pkgs/main::zeromq-4.3.1-h0a44026_3 --> anaconda/pkgs/free::zeromq-4.1.3-0
  zict                         pkgs/main::zict-0.1.4-py36_0 --> anaconda/pkgs/free::zict-0.1.2-py36_0
  zlib                    pkgs/main::zlib-1.2.11-hf3cbc9b_2 --> anaconda/pkgs/free::zlib-1.2.11-0
  zope                           pkgs/main::zope-1.0-py36_1 --> anaconda/pkgs/free::zope-1.0-py36_0
  zope.interface     pkgs/main::zope.interface-4.6.0-py36h~ --> anaconda/pkgs/free::zope.interface-4.4.2-py36_0

The following packages will be DOWNGRADED:

  _ipyw_jlab_nb_ext~                   0.1.0-py36h2fc01ae_0 --> 0.1.0-py36_0
  backports.shutil_~                   1.0.0-py36hd7a2ee4_2 --> 1.0.0-py36_2
  dbus                                    1.13.6-h90a0687_0 --> 1.13.2-h5243cc1_0
  glib                                    2.56.2-hd9629dc_0 --> 2.53.6-h33f6a65_2
  gmpy2                                2.0.8-py36h6ef4df4_2 --> 2.0.8-py36h7ef02cb_1
  libarchive                               3.3.3-h786848e_5 --> 3.3.2-h8d97200_0
  libcurl                                 7.64.0-h051b688_2 --> 7.61.1-hf30b1f0_0
  mkl_fft                             1.0.10-py36h5e564d8_0 --> 1.0.1-py36h917ab60_0
  mkl_random                           1.0.2-py36h27c97d8_0 --> 1.0.1-py36h78cc56f_0
  numpy                               1.16.2-py36hacdab7b_0 --> 1.11.3-py36h926163e_12
  numpy-base                          1.16.2-py36h6575580_0 --> 1.11.3-py36ha711998_12
  openssl                                 1.1.1b-h1de35cc_1 --> 1.0.2r-h1de35cc_0
  pycosat                              0.6.3-py36hee92d8f_0 --> 0.6.3-py36h1de35cc_0
  scikit-learn                        0.20.3-py36h27c97d8_0 --> 0.20.3-py36hebd9d1a_0
  webencodings                         0.5.1-py36h3b9701d_1 --> 0.5.1-py36_1
  zstd                                     1.3.7-h5bba6e5_0 --> 1.3.3-h2a6be3a_0


Proceed ([y]/n)? y

Preparing transaction: done
Verifying transaction: done
Executing transaction: failed
ERROR conda.core.link:_execute(568): An error occurred while uninstalling package 'defaults::qt-5.9.7-h468cd18_1'.
PermissionError(1, 'Operation not permitted')
Attempting to roll back.

Rolling back transaction: done

[Errno 1] Operation not permitted: '/anaconda3/bin/Assistant.app/Contents/PkgInfo' -> '/anaconda3/bin/Assistant.app/Contents/PkgInfo.c~'

Expected Behavior

When I update my python packages with conda, the operation is denied, which is not expected to happen.

Environment Information

`conda info`

     active environment : None
       user config file : /Users/xuzhiyuan/.condarc
 populated config files : /Users/xuzhiyuan/.condarc
          conda version : 4.6.8
    conda-build version : 3.17.8
         python version : 3.6.8.final.0
       base environment : /anaconda3  (writable)
           channel URLs : https://mirrors.tuna.tsinghua.edu.cn/anaconda/pkgs/free/osx-64
                          https://mirrors.tuna.tsinghua.edu.cn/anaconda/pkgs/free/noarch
                          https://repo.anaconda.com/pkgs/main/osx-64
                          https://repo.anaconda.com/pkgs/main/noarch
                          https://repo.anaconda.com/pkgs/free/osx-64
                          https://repo.anaconda.com/pkgs/free/noarch
                          https://repo.anaconda.com/pkgs/r/osx-64
                          https://repo.anaconda.com/pkgs/r/noarch
          package cache : /anaconda3/pkgs
                          /Users/xuzhiyuan/.conda/pkgs
       envs directories : /anaconda3/envs
                          /Users/xuzhiyuan/.conda/envs
               platform : osx-64
             user-agent : conda/4.6.8 requests/2.21.0 CPython/3.6.8 Darwin/18.5.0 OSX/10.14.4
                UID:GID : 501:20
             netrc file : None
           offline mode : False

`conda config --show-sources`

==> /Users/xuzhiyuan/.condarc <==
ssl_verify: True
channels:
  - https://mirrors.tuna.tsinghua.edu.cn/anaconda/pkgs/free/
  - defaults

`conda list --show-channel-urls`

# packages in environment at /anaconda3:
#
# Name                    Version                   Build  Channel
_ipyw_jlab_nb_ext_conf    0.1.0            py36h2fc01ae_0    defaults
alabaster                 0.7.12                   py36_0    defaults
anaconda-clean            1.1.0                    py36_1    defaults
anaconda-client           1.7.2                    py36_0    defaults
anaconda-navigator        1.9.6                    py36_0    defaults
anaconda-project          0.8.2            py36h9ee5d53_0    defaults
anyqt                     0.0.10                   py36_0    defaults
appnope                   0.1.0            py36hf537a9a_0    defaults
appscript                 1.1.0            py36h1de35cc_0    defaults
asn1crypto                0.24.0                   py36_0    defaults
astroid                   2.2.5                    py36_0    defaults
astropy                   3.1.2            py36h1de35cc_0    defaults
atomicwrites              1.3.0                      py_0    defaults
attrs                     19.1.0                     py_0    defaults
automat                   0.7.0                    py36_0    defaults
babel                     2.6.0                    py36_0    defaults
backcall                  0.1.0                    py36_0    defaults
backports                 1.0              py36ha3c1827_1    defaults
backports.os              0.1.1                    py36_0    defaults
backports.shutil_get_terminal_size 1.0.0            py36hd7a2ee4_2    defaults
beautifulsoup4            4.7.1                    py36_1    defaults
bitarray                  0.8.3            py36h1de35cc_0    defaults
bkcharts                  0.2              py36h073222e_0    defaults
blas                      1.0                         mkl    defaults
blaze                     0.11.3           py36h02e7a37_0    defaults
bleach                    3.1.0                    py36_0    defaults
blosc                     1.15.0               hd9629dc_0    defaults
bokeh                     1.0.4                    py36_0    defaults
boto                      2.49.0                   py36_0    defaults
bottleneck                1.2.1            py36h1d22016_1    defaults
bzip2                     1.0.6                hd86a083_4    defaults
ca-certificates           2019.1.23                     0    defaults
certifi                   2019.3.9                 py36_0    defaults
cffi                      1.12.2           py36hb5b8e2f_1    defaults
chardet                   3.0.4            py36h96c241c_1    defaults
click                     7.0                      py36_0    defaults
cloudpickle               0.8.0                    py36_0    defaults
clyent                    1.2.2            py36hae3ad88_0    defaults
colorama                  0.4.1                    py36_0    defaults
conda                     4.6.8                    py36_0    defaults
conda-build               3.17.8                   py36_0    defaults
conda-env                 2.6.0                h36134e3_0    defaults
conda-verify              3.1.1                    py36_0    defaults
constantly                15.1.0           py36h28b3542_0    defaults
contextlib2               0.5.5            py36hd66e5e7_0    defaults
cryptography              2.6.1            py36ha12b0ac_0    defaults
curl                      7.64.0               ha441bb4_2    defaults
cycler                    0.10.0           py36hfc81398_0    defaults
cython                    0.29.6           py36h0a44026_0    defaults
cytoolz                   0.9.0.1          py36h1de35cc_1    defaults
dask                      1.1.4                      py_0    defaults
dask-core                 1.1.4                      py_0    defaults
datashape                 0.5.4            py36hfb22df8_0    defaults
dbus                      1.13.6               h90a0687_0    defaults
decorator                 4.4.0                      py_0    defaults
defusedxml                0.5.0                    py36_1    defaults
dill                      0.2.9                    py36_0    defaults
distributed               1.26.0                   py36_1    defaults
docutils                  0.14             py36hbfde631_0    defaults
entrypoints               0.3                      py36_0    defaults
et_xmlfile                1.0.1            py36h1315bdc_0    defaults
expat                     2.2.6                h0a44026_0    defaults
fast-histogram            0.7             py36h1d22016_1000    defaults
fastcache                 1.0.2            py36h1de35cc_2    defaults
fasttsne                  0.2.13           py36h1d22016_1    defaults
filelock                  3.0.10                   py36_0    defaults
flask                     1.0.2                    py36_1    defaults
flask-cors                3.0.7                    py36_0    defaults
freetype                  2.9.1                hb4e5f40_0    defaults
future                    0.17.1                   py36_0    defaults
get_terminal_size         1.0.0                h7520d66_0    defaults
gettext                   0.19.8.1             h15daf44_3    defaults
gevent                    1.4.0            py36h1de35cc_0    defaults
glib                      2.56.2               hd9629dc_0    defaults
glob2                     0.6              py36h94c9186_0    defaults
glue-core                 0.14.1                   py36_0    defaults
glue-vispy-viewers        0.11                       py_0    defaults
glueviz                   0.13.3                        0    defaults
gmp                       6.1.2                hb37e062_1    defaults
gmpy2                     2.0.8            py36h6ef4df4_2    defaults
greenlet                  0.4.15           py36h1de35cc_0    defaults
h5py                      2.9.0            py36h3134771_0    defaults
hdf5                      1.10.4               hfa1e0ec_0    defaults
heapdict                  1.0.0                    py36_2    defaults
html5lib                  1.0.1            py36h2f9c1c0_0    defaults
hyperlink                 18.0.0                   py36_0    defaults
icu                       58.2                 h4b95b61_1    defaults
idna                      2.8                      py36_0    defaults
imageio                   2.5.0                    py36_0    defaults
imagesize                 1.1.0                    py36_0    defaults
importlib_metadata        0.8                      py36_0    defaults
incremental               17.5.0                   py36_0    defaults
intel-openmp              2019.1                      144    defaults
ipykernel                 5.1.0            py36h39e3cac_0    defaults
ipython                   7.3.0            py36h39e3cac_0    defaults
ipython_genutils          0.2.0            py36h241746c_0    defaults
ipywidgets                7.4.2                    py36_0    defaults
isort                     4.3.15                   py36_0    defaults
itsdangerous              1.1.0                    py36_0    defaults
jbig                      2.1                  h4d881f8_0    defaults
jdcal                     1.4                      py36_0    defaults
jedi                      0.13.3                   py36_0    defaults
jinja2                    2.10             py36hd36f9c5_0    defaults
joblib                    0.13.2                   py36_0    defaults
jpeg                      9b                   he5867d9_2    defaults
jsonschema                3.0.1                    py36_0    defaults
jupyter                   1.0.0                    py36_4    defaults
jupyter-c-kernel          1.2.2                    pypi_0    pypi
jupyter_client            5.2.4                    py36_0    defaults
jupyter_console           6.0.0                    py36_0    defaults
jupyter_core              4.4.0            py36h79cf704_0    defaults
jupyterlab                0.35.4           py36hf63ae98_0    defaults
jupyterlab_launcher       0.13.1                   py36_0    defaults
jupyterlab_server         0.2.0                    py36_0    defaults
keyring                   18.0.0                   py36_0    defaults
keyrings.alt              3.1.1                    py36_0    defaults
kiwisolver                1.0.1            py36h0a44026_0    defaults
krb5                      1.16.1               hddcf347_7    defaults
lazy-object-proxy         1.3.1            py36h2fbbe47_0    defaults
libarchive                3.3.3                h786848e_5    defaults
libcurl                   7.64.0               h051b688_2    defaults
libcxx                    4.0.1                h579ed51_0    defaults
libcxxabi                 4.0.1                hebd6815_0    defaults
libedit                   3.1.20181209         hb402a30_0    defaults
libffi                    3.2.1                h475c297_4    defaults
libgfortran               3.0.1                h93005f0_2    defaults
libiconv                  1.15                 hdd342a3_7    defaults
liblief                   0.9.0                h2a1bed3_2    defaults
libpng                    1.6.36               ha441bb4_0    defaults
libsodium                 1.0.16               h3efe00b_0    defaults
libssh2                   1.8.0                ha12b0ac_4    defaults
libtiff                   4.0.10               hcb84e12_2    defaults
libxml2                   2.9.9                hab757c2_0    defaults
libxslt                   1.1.33               h33a18ac_0    defaults
llvmlite                  0.27.0           py36h8c7ce04_0    defaults
locket                    0.2.0            py36hca03003_1    defaults
lxml                      4.3.2            py36hef8c89e_0    defaults
lz4-c                     1.8.1.2              h1de35cc_0    defaults
lzo                       2.10                 h362108e_2    defaults
markupsafe                1.1.1            py36h1de35cc_0    defaults
matplotlib                3.0.3            py36h54f8f79_0    defaults
mccabe                    0.6.1            py36hdaeb55d_0    defaults
mistune                   0.8.4            py36h1de35cc_0    defaults
mkl                       2019.1                      144    defaults
mkl-service               1.1.2            py36hfbe908c_5    defaults
mkl_fft                   1.0.10           py36h5e564d8_0    defaults
mkl_random                1.0.2            py36h27c97d8_0    defaults
more-itertools            6.0.0                    py36_0    defaults
mpc                       1.1.0                h6ef4df4_1    defaults
mpfr                      4.0.1                h3018a27_3    defaults
mpl-scatter-density       0.5                        py_0    defaults
mpmath                    1.1.0                    py36_0    defaults
msgpack-python            0.6.1            py36h04f5b5a_1    defaults
multipledispatch          0.6.0                    py36_0    defaults
navigator-updater         0.2.1                    py36_0    defaults
nbconvert                 5.4.1                      py_2    defaults
nbformat                  4.4.0            py36h827af21_0    defaults
ncurses                   6.1                  h0a44026_1    defaults
networkx                  2.2                      py36_1    defaults
nltk                      3.4                      py36_1    defaults
nose                      1.3.7            py36h73fae2b_2    defaults
notebook                  5.7.6                    py36_0    defaults
numba                     0.42.0           py36h6440ff4_0    defaults
numexpr                   2.6.9            py36h7413580_0    defaults
numpy                     1.16.2           py36hacdab7b_0    defaults
numpy-base                1.16.2           py36h6575580_0    defaults
numpydoc                  0.8.0                    py36_0    defaults
odo                       0.5.1            py36hc1af34a_0    defaults
olefile                   0.46                     py36_0    defaults
openpyxl                  2.6.1                      py_0    defaults
openssl                   1.1.1b               h1de35cc_1    defaults
orange3                   3.19.0           py36h0a44026_0    defaults
packaging                 19.0                     py36_0    defaults
pandas                    0.24.2           py36h0a44026_0    defaults
pandoc                    2.2.3.2                       0    defaults
pandocfilters             1.4.2            py36h3b0b094_1    defaults
parso                     0.3.4                    py36_0    defaults
partd                     0.3.10                     py_0    defaults
path.py                   11.5.0                   py36_0    defaults
pathlib2                  2.3.3                    py36_0    defaults
patsy                     0.5.1                    py36_0    defaults
pcre                      8.43                 h0a44026_0    defaults
pep8                      1.7.1                    py36_0    defaults
pexpect                   4.6.0                    py36_0    defaults
pickleshare               0.7.5                    py36_0    defaults
pillow                    5.4.1            py36hb68e598_0    defaults
pip                       19.0.3                   pypi_0    pypi
pkginfo                   1.5.0.1                  py36_0    defaults
plotly                    3.7.0                      py_0    defaults
pluggy                    0.9.0                    py36_0    defaults
ply                       3.11                     py36_0    defaults
prometheus_client         0.6.0                    py36_0    defaults
prompt_toolkit            2.0.9                    py36_0    defaults
psutil                    5.6.1            py36h1de35cc_0    defaults
ptyprocess                0.6.0                    py36_0    defaults
py                        1.8.0                    py36_0    defaults
py-lief                   0.9.0            py36h1413db1_2    defaults
pycodestyle               2.5.0                    py36_0    defaults
pycosat                   0.6.3            py36hee92d8f_0    defaults
pycparser                 2.19                     py36_0    defaults
pycrypto                  2.6.1            py36h1de35cc_7    defaults
pycurl                    7.43.0.2         py36ha12b0ac_0    defaults
pyflakes                  2.1.1                    py36_0    defaults
pygments                  2.3.1                    py36_0    defaults
pylint                    2.3.1                    py36_0    defaults
pyodbc                    4.0.26           py36h0a44026_0    defaults
pyopengl                  3.1.1a1                  py36_0    defaults
pyopenssl                 19.0.0                   py36_0    defaults
pyparsing                 2.3.1                    py36_0    defaults
pyqt                      5.9.2            py36h655552a_2    defaults
pyqtgraph                 0.10.0           py36h28b3542_3    defaults
pyrsistent                0.14.11          py36h1de35cc_0    defaults
pysocks                   1.6.8                    py36_0    defaults
pytables                  3.5.1            py36h5bccee9_0    defaults
pytest                    4.3.1                    py36_0    defaults
pytest-arraydiff          0.3              py36h39e3cac_0    defaults
pytest-astropy            0.5.0                    py36_0    defaults
pytest-doctestplus        0.3.0                    py36_0    defaults
pytest-openfiles          0.3.2                    py36_0    defaults
pytest-remotedata         0.3.1                    py36_0    defaults
python                    3.6.8                haf84260_0    defaults
python-dateutil           2.8.0                    py36_0    defaults
python-libarchive-c       2.8                      py36_6    defaults
python-louvain            0.13                       py_0    defaults
python.app                2                py36h54569d5_7    defaults
pytz                      2018.9                   py36_0    defaults
pywavelets                1.0.2            py36h1d22016_0    defaults
pyyaml                    5.1              py36h1de35cc_0    defaults
pyzmq                     18.0.0           py36h0a44026_0    defaults
qt                        5.9.7                h468cd18_1    defaults
qtawesome                 0.5.7                      py_0    defaults
qtconsole                 4.4.3                    py36_0    defaults
qtpy                      1.7.0                      py_0    defaults
readline                  7.0                  hc1231fa_4    defaults
requests                  2.21.0                   py36_0    defaults
retrying                  1.3.3                    py36_2    defaults
rope                      0.12.0                   py36_0    defaults
ruamel_yaml               0.15.46          py36h1de35cc_0    defaults
scikit-image              0.14.2           py36h0a44026_0    defaults
scikit-learn              0.20.3           py36h27c97d8_0    defaults
scipy                     1.2.1            py36h1410ff5_0    defaults
seaborn                   0.9.0                    py36_0    defaults
send2trash                1.5.0                    py36_0    defaults
serverfiles               0.3.0                    py36_0    defaults
setuptools                40.8.0                   py36_0    defaults
shadowsocks               2.8.2                    pypi_0    pypi
simplegeneric             0.8.1                    py36_2    defaults
singledispatch            3.4.0.3          py36hf20db9d_0    defaults
sip                       4.19.8           py36h0a44026_0    defaults
six                       1.12.0                   py36_0    defaults
snappy                    1.1.7                he62c110_3    defaults
snowballstemmer           1.2.1            py36h6c7b616_0    defaults
sortedcollections         1.1.2                    py36_0    defaults
sortedcontainers          2.1.0                    py36_0    defaults
soupsieve                 1.8                      py36_0    defaults
sphinx                    1.8.5                    py36_0    defaults
sphinxcontrib             1.0              py36h9364dc8_1    defaults
sphinxcontrib-websupport  1.1.0                    py36_1    defaults
spyder                    3.3.3                    py36_0    defaults
spyder-kernels            0.4.2                    py36_0    defaults
sqlalchemy                1.3.1            py36h1de35cc_0    defaults
sqlite                    3.27.2               ha441bb4_0    defaults
statsmodels               0.9.0            py36h1d22016_0    defaults
sympy                     1.3                      py36_0    defaults
tblib                     1.3.2            py36hda67792_0    defaults
terminado                 0.8.1                    py36_1    defaults
testpath                  0.4.2                    py36_0    defaults
tk                        8.6.8                ha441bb4_0    defaults
toolz                     0.9.0                    py36_0    defaults
tornado                   6.0.1            py36h1de35cc_0    defaults
tqdm                      4.31.1                     py_0    defaults
traitlets                 4.3.2            py36h65bd3ce_0    defaults
twisted                   17.5.0                   py36_0    defaults
typed-ast                 1.3.1            py36h1de35cc_0    defaults
typing                    3.6.4                    py36_0    defaults
unicodecsv                0.14.1           py36he531d66_0    defaults
unixodbc                  2.3.7                h1de35cc_0    defaults
urllib3                   1.24.1                   py36_0    defaults
wcwidth                   0.1.7            py36h8c6ec74_0    defaults
webencodings              0.5.1            py36h3b9701d_1    defaults
werkzeug                  0.14.1                   py36_0    defaults
wheel                     0.33.1                   py36_0    defaults
widgetsnbextension        3.4.2                    py36_0    defaults
wrapt                     1.11.1           py36h1de35cc_0    defaults
wurlitzer                 1.0.2                    py36_0    defaults
xlrd                      1.2.0                    py36_0    defaults
xlsxwriter                1.1.5                    py36_0    defaults
xlwings                   0.15.4                   py36_0    defaults
xlwt                      1.2.0            py36h5ad1178_0    defaults
xz                        5.2.4                h1de35cc_4    defaults
yaml                      0.1.7                hc338f04_2    defaults
zeromq                    4.3.1                h0a44026_3    defaults
zict                      0.1.4                    py36_0    defaults
zipp                      0.3.3                      py_0    defaults
zlib                      1.2.11               hf3cbc9b_2    defaults
zope                      1.0                      py36_1    defaults
zope.interface            4.6.0            py36h1de35cc_0    defaults
zstd                      1.3.7                h5bba6e5_0    defaults

@lynxcom

This comment has been minimized.

Copy link

commented Mar 28, 2019

Hey~
I got the same problem as yours.
After I updated my macOS to 10.14, this problem occurred.
If you find out a way, please leave it.

@goldengrape

This comment has been minimized.

Copy link

commented Mar 30, 2019

with
sudo conda update --all
also failed

ERROR conda.core.link:_execute(568): An error occurred while uninstalling package 'defaults::qt-5.9.6-h74ce4d9_0'.
PermissionError(1, 'Operation not permitted')
Attempting to roll back.

Rolling back transaction: done

[Errno 1] Operation not permitted: 
'~/anaconda3/bin/Assistant.app/Contents/PkgInfo' -> '~/anaconda3/bin/Assistant.app/Contents/PkgInfo.c~'
@goldengrape

This comment has been minimized.

Copy link

commented Mar 30, 2019

conda update qt
failed
maybe this is the key package

@goldengrape

This comment has been minimized.

Copy link

commented Mar 30, 2019

conda uninstall qt
failed
all above get same error message

@gschivley

This comment has been minimized.

Copy link

commented Apr 2, 2019

I'm also getting an error when I try to remove an environment with qt. Upgraded to Mojave 10.14.4 just a couple days ago.

Preparing transaction: done
Verifying transaction: done
Executing transaction: failed
ERROR conda.core.link:_execute(568): An error occurred while uninstalling package 'defaults::qt-5.9.7-h468cd18_1'.
PermissionError(1, 'Operation not permitted')
Attempting to roll back.

Rolling back transaction: done

[Errno 1] Operation not permitted: '/Users/greg/miniconda3/envs/pudl-test/bin/Assistant.app/Contents/PkgInfo' -> '/Users/greg/miniconda3/envs/pudl-test/bin/Assistant.app/Contents/PkgInfo.c~'
@kumarict

This comment has been minimized.

Copy link

commented Apr 2, 2019

I am using Mojave 10.14.4 and am experiencing the same issue when attempting to install pygame.

Preparing transaction: done
Verifying transaction: done
Executing transaction: failed
ERROR conda.core.link:_execute(568): An error occurred while uninstalling package 'defaults::python.app-2-py37_9'.
PermissionError(1, 'Operation not permitted')
Attempting to roll back.

Rolling back transaction: done

[Errno 1] Operation not permitted: '/Users/kumar/anaconda3/python.app/Contents/PkgInfo' -> '/Users/kumar/anaconda3/python.app/Contents/PkgInfo.c~'
@gschivley

This comment has been minimized.

Copy link

commented Apr 3, 2019

Adding output from conda info.

     active environment : base
    active env location : /Users/greg/miniconda3
            shell level : 1
       user config file : /Users/greg/.condarc
 populated config files : 
          conda version : 4.6.9
    conda-build version : not installed
         python version : 3.6.7.final.0
       base environment : /Users/greg/miniconda3  (writable)
           channel URLs : https://repo.anaconda.com/pkgs/main/osx-64
                          https://repo.anaconda.com/pkgs/main/noarch
                          https://repo.anaconda.com/pkgs/free/osx-64
                          https://repo.anaconda.com/pkgs/free/noarch
                          https://repo.anaconda.com/pkgs/r/osx-64
                          https://repo.anaconda.com/pkgs/r/noarch
          package cache : /Users/greg/miniconda3/pkgs
                          /Users/greg/.conda/pkgs
       envs directories : /Users/greg/miniconda3/envs
                          /Users/greg/.conda/envs
               platform : osx-64
             user-agent : conda/4.6.9 requests/2.18.4 CPython/3.6.7 Darwin/18.5.0 OSX/10.14.4
                UID:GID : 502:20
             netrc file : None
           offline mode : False
@msarahan

This comment has been minimized.

Copy link
Contributor

commented Apr 3, 2019

These look like permission errors. You should make sure that conda can write to the package cache. It looks like it can, currently, but maybe particular folders may not be writable. If you remove all the package files and folders in your package cache (~/miniconda3/pkgs), it might go away.

@mgulcin

This comment has been minimized.

Copy link

commented Apr 4, 2019

I was trying to uninstall my environment and had the same problem. As a solution I deleted all *.app files in the "~/anaconda3/bin" folder. This works fine with uninstall, but I'm not sure if it will work for an update.

@mefryar

This comment has been minimized.

Copy link

commented Apr 4, 2019

I'm getting a similar error when running conda update conda and conda install anaconda-clean.

Preparing transaction: done
Verifying transaction: done
Executing transaction: failed
ERROR conda.core.link:_execute(543): An error occurred while uninstalling package 'defaults::python.app-2-py37_9'.
PermissionError(1, 'Operation not permitted')
Attempting to roll back.

Rolling back transaction: done

[Errno 1] Operation not permitted: '/Users/mefryar/anaconda3/python.app/Contents/PkgInfo' -> '/Users/mefryar/anaconda3/python.app/Contents/PkgInfo.c~'

Here's my conda info

     active environment : None
       user config file : /Users/mefryar/.condarc
 populated config files : 
          conda version : 4.6.7
    conda-build version : 3.17.8
         python version : 3.7.2.final.0
       base environment : /Users/mefryar/anaconda3  (writable)
           channel URLs : https://repo.anaconda.com/pkgs/main/osx-64
                          https://repo.anaconda.com/pkgs/main/noarch
                          https://repo.anaconda.com/pkgs/free/osx-64
                          https://repo.anaconda.com/pkgs/free/noarch
                          https://repo.anaconda.com/pkgs/r/osx-64
                          https://repo.anaconda.com/pkgs/r/noarch
          package cache : /Users/mefryar/anaconda3/pkgs
                          /Users/mefryar/.conda/pkgs
       envs directories : /Users/mefryar/anaconda3/envs
                          /Users/mefryar/.conda/envs
               platform : osx-64
             user-agent : conda/4.6.7 requests/2.21.0 CPython/3.7.2 Darwin/18.5.0 OSX/10.14.4
                UID:GID : 502:20
             netrc file : None
           offline mode : False
@RSully

This comment has been minimized.

Copy link

commented Apr 4, 2019

Same issue here from a conda update --all:

Preparing transaction: done
Verifying transaction: done
Executing transaction: failed
ERROR conda.core.link:_execute(568): An error occurred while uninstalling package 'defaults::qt-5.6.3-h1d42b2f_0'.
PermissionError(1, 'Operation not permitted')
Attempting to roll back.

Rolling back transaction: done

[Errno 1] Operation not permitted: '/opt/miniconda3/envs/some-env/bin/Assistant.app/Contents/PkgInfo' -> '/opt/miniconda3/envs/some-env/bin/Assistant.app/Contents/PkgInfo.c~'
@GeneralDuke9

This comment has been minimized.

Copy link

commented Apr 5, 2019

I'm experiencing the same problem on macOS 10.14.4. I first reinstalled anaconda, conda update --all worked well, as well as conda install xarray cartopy, but then it failed when I tried conda install -c conda-forge utm.

These look like permission errors. You should make sure that conda can write to the package cache. It looks like it can, currently, but maybe particular folders may not be writable. If you remove all the package files and folders in your package cache (~/miniconda3/pkgs), it might go away.

This worked for me!

@mefryar

This comment has been minimized.

Copy link

commented Apr 6, 2019

If you remove all the package files and folders in your package cache (~/miniconda3/pkgs), it might go away.

Inspired by this, I deleted /Users/mefryar/anaconda3/python.app since my error was:

[Errno 1] Operation not permitted: '/Users/mefryar/anaconda3/python.app/Contents/PkgInfo' -> '/Users/mefryar/anaconda3/python.app/Contents/PkgInfo.c~'

I was then able to execute conda install anaconda-clean.

@goldengrape

This comment has been minimized.

Copy link

commented Apr 9, 2019

This worked for me! I delete all *.app in the bin

for base:

cd ~/anaconda3/bin
ls *.app
rm -rf *.app
conda update --all --yes

for some_env:

cd ~/anaconda3/envs/some_env/bin
ls *.app
rm -rf *.app
conda update -n some_env --all --yes

! CAREFUL about rm -rf

@goldengrape

This comment has been minimized.

Copy link

commented Apr 9, 2019

I was trying to uninstall my environment and had the same problem. As a solution I deleted all *.app files in the "~/anaconda3/bin" folder. This works fine with uninstall, but I'm not sure if it will work for an update.

conda update --all will reinstall all *.app files

@schlepuetz

This comment has been minimized.

Copy link

commented Apr 11, 2019

Deleting the above mentioned files did not help for me. But I found the following thread dealing with the "Operation not Permitted" issue in more general terms:
http://osxdaily.com/2018/10/09/fix-operation-not-permitted-terminal-error-macos/

What worked for me in the end was to make sure that the conda application had the necessary access rights as follows:

  • Open "System Preferences > Security & Privacy > Privacy"
  • Grant "Full Disk Access" for the conda application (e.g.: ~/anaconda3/bin/conda)

I'm not conviced that this is a good solution in the long term, but it did solve the immediate problem at hand and let me update and install conda packages.

@aishwaryathondapu

This comment has been minimized.

Copy link

commented Apr 13, 2019

Facing the same issue. Able to install some packages without problem but i faced the issue while uninstalling the qt. And while installing packages like opencv and pyinstaller in MacOS Mojave. I tried removing the cache using conda clean -all but no use. Is there solution apart from changing the permissions

@RSully

This comment has been minimized.

Copy link

commented Apr 22, 2019

Grant "Full Disk Access" for the conda application

This isn't working for me. I tried adding both miniconda3/bin/conda and miniconda3/condabin/conda.

@stephaniemdavis

This comment has been minimized.

Copy link

commented Apr 23, 2019

@goldengrape - your base solution worked for me; thank you.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.