Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Conda 4.7.5 fails to solve environment that Conda 4.6.11 solves #8844

Closed
amarkpayne opened this issue Jun 28, 2019 · 18 comments

Comments

Projects
None yet
8 participants
@amarkpayne
Copy link

commented Jun 28, 2019

Current Behavior

Trying to build a conda environment from an environment file with conda env create -f environment_linux.yml with conda 4.7.5 fails to solve the environment with ResolvePackageNotFound. However, doing the exact same thing on the same environment file works without any errors using conda 4.6.11.

Interestingly though, if we explicitly list the packages in the environment file that ResolvePackageNotFound complains about, then conda 4.7.5 builds the environment just fine.

Steps to Reproduce

Run the following command conda env create -f environment_linux.yml on the following environment file:

name: rmg_env
channels:
  - defaults
  - rmg
  - rdkit
  - cantera
dependencies:
  - cairo
  - cairocffi
  - cantera >=2.3.0
  - coolprop
  - coverage
  - cython >=0.25.2
  - dde
  - ffmpeg
  - gprof2dot
  - graphviz
  - jinja2
  - jupyter
  - lpsolve55
  - markupsafe
  - matplotlib >=1.5
  - mock
  - mopac
  - mpmath
  - muq
  - networkx
  - nose
  - numpy >=1.10.0
  - openbabel
  - psutil
  - pydas >=1.0.1
  - pydot ==1.2.2
  - pydqed >=1.0.0
  - pymongo
  - pyparsing
  - pyrdl
  - python >=2.7
  - pyyaml
  - quantities
  - rdkit >=2018
  - scikit-learn
  - scipy
  - symmetry
  - textgenrnn
  - xlwt

Doing this with conda 4.6.11 runs just fine, but doing this with conda 4.7.5 yields the following error message:

Solving environment: failed

ResolvePackageNotFound: 
  - textgenrnn -> theano=0.9.0 -> pygpu[version='>=0.6.5,<0.7']
  - dde -> pydot-ng
  - dde -> theano=0.9.0 -> pygpu[version='>=0.6.5,<0.7']

See also a Pull Request where this issue is discussed on RMG-Py here

Again, note that adding pydot-ng and pygpu to the environment file fixes this issue in 4.7.5, but this was not necessary for conda 4.6.11

Expected Behavior

Conda 4.7.5 should be able to solve the exact same environment file as conda 4.6.11

Environment Information

`conda info`

     active environment : None
       user config file : /home/ampayne/.condarc
 populated config files : 
          conda version : 4.7.5
    conda-build version : 3.17.8
         python version : 2.7.16.final.0
       virtual packages : 
       base environment : /home/ampayne/anaconda2  (writable)
           channel URLs : https://repo.anaconda.com/pkgs/main/linux-64
                          https://repo.anaconda.com/pkgs/main/noarch
                          https://repo.anaconda.com/pkgs/r/linux-64
                          https://repo.anaconda.com/pkgs/r/noarch
          package cache : /home/ampayne/anaconda2/pkgs
                          /home/ampayne/.conda/pkgs
       envs directories : /home/ampayne/anaconda2/envs
                          /home/ampayne/.conda/envs
               platform : linux-64
             user-agent : conda/4.7.5 requests/2.21.0 CPython/2.7.16 Linux/4.4.0-122-generic ubuntu/16.04.5 glibc/2.23
                UID:GID : 1002:1002
             netrc file : None
           offline mode : False

`conda config --show-sources`


`conda list --show-channel-urls`

# packages in environment at /home/ampayne/anaconda2:
#
# Name                    Version                   Build  Channel
_ipyw_jlab_nb_ext_conf    0.1.0                    py27_0    defaults
alabaster                 0.7.12                   py27_0    defaults
anaconda                  2019.03                  py27_0    defaults
anaconda-client           1.7.2                    py27_0    defaults
anaconda-navigator        1.9.7                    py27_0    defaults
anaconda-project          0.8.2                    py27_0    defaults
asn1crypto                0.24.0                   py27_0    defaults
astroid                   1.6.5                    py27_0    defaults
astropy                   2.0.9            py27hdd07704_0    defaults
atomicwrites              1.3.0                    py27_1    defaults
attrs                     19.1.0                   py27_1    defaults
babel                     2.6.0                    py27_0    defaults
backports                 1.0                      py27_1    defaults
backports.functools_lru_cache 1.5                      py27_1    defaults
backports.os              0.1.1                    py27_0    defaults
backports.shutil_get_terminal_size 1.0.0                    py27_2    defaults
backports_abc             0.5              py27h7b3c97b_0    defaults
beautifulsoup4            4.7.1                    py27_1    defaults
bitarray                  0.8.3            py27h14c3975_0    defaults
bkcharts                  0.2              py27h241ae91_0    defaults
blas                      1.0                         mkl    defaults
bleach                    3.1.0                    py27_0    defaults
blosc                     1.15.0               hd408876_0    defaults
bokeh                     1.0.4                    py27_0    defaults
boto                      2.49.0                   py27_0    defaults
bottleneck                1.2.1            py27h035aef0_1    defaults
bzip2                     1.0.6                h14c3975_5    defaults
ca-certificates           2019.1.23                     0    anaconda
cairo                     1.14.12              h8948797_3    defaults
cdecimal                  2.3              py27h14c3975_3    defaults
certifi                   2019.3.9                 py27_0    anaconda
cffi                      1.12.2           py27h2e261b9_1    defaults
chardet                   3.0.4                    py27_1    defaults
click                     7.0                      py27_0    defaults
cloudpickle               0.8.0                    py27_0    defaults
clyent                    1.2.2                    py27_1    defaults
colorama                  0.4.1                    py27_0    defaults
conda                     4.7.5                    py27_0    anaconda
conda-build               3.17.8                   py27_0    defaults
conda-env                 2.6.0                         1    defaults
conda-package-handling    1.3.10                   py27_0    anaconda
conda-verify              3.1.1                    py27_0    defaults
configparser              3.7.3                    py27_1    defaults
contextlib2               0.5.5            py27hbf4c468_0    defaults
cryptography              2.6.1            py27h1ba5d50_0    defaults
curl                      7.64.0               hbc83047_2    defaults
cycler                    0.10.0           py27hc7354d3_0    defaults
cython                    0.29.6           py27he6710b0_0    defaults
cytoolz                   0.9.0.1          py27h14c3975_1    defaults
dask                      1.1.4                    py27_1    defaults
dask-core                 1.1.4                    py27_1    defaults
dbus                      1.13.6               h746ee38_0    defaults
decorator                 4.4.0                    py27_1    defaults
defusedxml                0.5.0                    py27_1    defaults
distributed               1.26.0                   py27_1    defaults
docutils                  0.14             py27hae222c1_0    defaults
entrypoints               0.3                      py27_0    defaults
enum34                    1.1.6                    py27_1    defaults
et_xmlfile                1.0.1            py27h75840f5_0    defaults
expat                     2.2.6                he6710b0_0    defaults
fastcache                 1.0.2            py27h14c3975_2    defaults
filelock                  3.0.10                   py27_0    defaults
flask                     1.0.2                    py27_1    defaults
fontconfig                2.13.0               h9420a91_0    defaults
freetype                  2.9.1                h8a8886c_1    defaults
fribidi                   1.0.5                h7b6447c_0    defaults
funcsigs                  1.0.2            py27h83f16ab_0    defaults
functools32               3.2.3.2                  py27_1    defaults
future                    0.17.1                   py27_0    defaults
futures                   3.2.0                    py27_0    defaults
get_terminal_size         1.0.0                haa9412d_0    defaults
gevent                    1.4.0            py27h7b6447c_0    defaults
glib                      2.56.2               hd408876_0    defaults
glob2                     0.6                      py27_1    defaults
gmp                       6.1.2                h6c8ec71_1    defaults
gmpy2                     2.0.8            py27h10f8cd9_2    defaults
graphite2                 1.3.13               h23475e2_0    defaults
greenlet                  0.4.15           py27h7b6447c_0    defaults
grin                      1.2.1                    py27_4    defaults
gst-plugins-base          1.14.0               hbbd80ab_1    defaults
gstreamer                 1.14.0               hb453b48_1    defaults
h5py                      2.9.0            py27h7918eee_0    defaults
harfbuzz                  1.8.8                hffaf4a1_0    defaults
hdf5                      1.10.4               hb1b8bf9_0    defaults
heapdict                  1.0.0                    py27_2    defaults
html5lib                  1.0.1                    py27_0    defaults
icu                       58.2                 h9c2bf20_1    defaults
idna                      2.8                      py27_0    defaults
imageio                   2.5.0                    py27_0    defaults
imagesize                 1.1.0                    py27_0    defaults
importlib_metadata        0.8                      py27_0    defaults
intel-openmp              2019.3                      199    defaults
ipaddress                 1.0.22                   py27_0    defaults
ipykernel                 4.10.0                   py27_0    defaults
ipython                   5.8.0                    py27_0    defaults
ipython_genutils          0.2.0            py27h89fb69b_0    defaults
ipywidgets                7.4.2                    py27_0    defaults
isort                     4.3.16                   py27_0    defaults
itsdangerous              1.1.0                    py27_0    defaults
jbig                      2.1                  hdba287a_0    defaults
jdcal                     1.4                      py27_0    defaults
jedi                      0.13.3                   py27_0    defaults
jinja2                    2.10                     py27_0    defaults
jpeg                      9b                   h024ee3a_2    defaults
jsonschema                3.0.1                    py27_0    defaults
jupyter                   1.0.0                    py27_7    defaults
jupyter_client            5.2.4                    py27_0    defaults
jupyter_console           5.2.0                    py27_1    defaults
jupyter_core              4.4.0                    py27_0    defaults
jupyterlab                0.33.11                  py27_0    defaults
jupyterlab_launcher       0.11.2           py27h28b3542_0    defaults
kiwisolver                1.0.1            py27hf484d3e_0    defaults
krb5                      1.16.1               h173b8e3_7    defaults
lazy-object-proxy         1.3.1            py27h14c3975_2    defaults
libarchive                3.3.3                h5d8350f_5    defaults
libcurl                   7.64.0               h20c2e04_2    defaults
libedit                   3.1.20181209         hc058e9b_0    defaults
libffi                    3.2.1                hd88cf55_4    defaults
libgcc-ng                 8.2.0                hdf63c60_1    defaults
libgfortran-ng            7.3.0                hdf63c60_0    defaults
liblief                   0.9.0                h7725739_2    defaults
libpng                    1.6.36               hbc83047_0    defaults
libsodium                 1.0.16               h1bed415_0    defaults
libssh2                   1.8.0                h1ba5d50_4    defaults
libstdcxx-ng              8.2.0                hdf63c60_1    defaults
libtiff                   4.0.10               h2733197_2    defaults
libtool                   2.4.6                h7b6447c_5    defaults
libuuid                   1.0.3                h1bed415_2    defaults
libxcb                    1.13                 h1bed415_1    defaults
libxml2                   2.9.9                he19cac6_0    defaults
libxslt                   1.1.33               h7d1a2b0_0    defaults
linecache2                1.0.0                    py27_0    defaults
llvmlite                  0.28.0           py27hd408876_0    defaults
locket                    0.2.0            py27h73929a2_1    defaults
lxml                      4.3.2            py27hefd8a0e_0    defaults
lz4-c                     1.8.1.2              h14c3975_0    defaults
lzo                       2.10                 h49e0be7_2    defaults
markupsafe                1.1.1            py27h7b6447c_0    defaults
matplotlib                2.2.3            py27hb69df0a_0    defaults
mccabe                    0.6.1                    py27_1    defaults
mistune                   0.8.4            py27h7b6447c_0    defaults
mkl                       2019.3                      199    defaults
mkl-service               1.1.2            py27he904b0f_5    defaults
mkl_fft                   1.0.10           py27ha843d7b_0    defaults
mkl_random                1.0.2            py27hd81dba3_0    defaults
more-itertools            5.0.0                    py27_0    defaults
mpc                       1.1.0                h10f8cd9_1    defaults
mpfr                      4.0.1                hdf1c602_3    defaults
mpmath                    1.1.0                    py27_0    defaults
msgpack-python            0.6.1            py27hfd86e86_1    defaults
multipledispatch          0.6.0                    py27_0    defaults
navigator-updater         0.2.1                    py27_0    defaults
nbconvert                 5.4.1                    py27_3    defaults
nbformat                  4.4.0            py27hed7f2b2_0    defaults
ncurses                   6.1                  he6710b0_1    defaults
networkx                  2.2                      py27_1    defaults
nltk                      3.4                      py27_1    defaults
nose                      1.3.7                    py27_2    defaults
notebook                  5.7.8                    py27_0    defaults
numba                     0.43.1           py27h962f231_0    defaults
numexpr                   2.6.9            py27h9e4a6bb_0    defaults
numpy                     1.16.2           py27h7e9f1db_0    defaults
numpy-base                1.16.2           py27hde5b4d6_0    defaults
numpydoc                  0.8.0                    py27_0    defaults
olefile                   0.46                     py27_0    defaults
openpyxl                  2.6.1                    py27_1    defaults
openssl                   1.1.1b               h7b6447c_1    anaconda
packaging                 19.0                     py27_0    defaults
pandas                    0.24.2           py27he6710b0_0    defaults
pandoc                    2.2.3.2                       0    defaults
pandocfilters             1.4.2                    py27_1    defaults
pango                     1.42.4               h049681c_0    defaults
parso                     0.3.4                    py27_0    defaults
partd                     0.3.10                   py27_1    defaults
patchelf                  0.9                  he6710b0_3    defaults
path.py                   11.5.0                   py27_0    defaults
pathlib2                  2.3.3                    py27_0    defaults
patsy                     0.5.1                    py27_0    defaults
pcre                      8.43                 he6710b0_0    defaults
pep8                      1.7.1                    py27_0    defaults
pexpect                   4.6.0                    py27_0    defaults
pickleshare               0.7.5                    py27_0    defaults
pillow                    5.4.1            py27h34e0f95_0    defaults
pip                       19.0.3                   py27_0    defaults
pixman                    0.38.0               h7b6447c_0    defaults
pkginfo                   1.5.0.1                  py27_0    defaults
pluggy                    0.9.0                    py27_0    defaults
ply                       3.11                     py27_0    defaults
prometheus_client         0.6.0                    py27_0    defaults
prompt_toolkit            1.0.15           py27h1b593e1_0    defaults
psutil                    5.6.1            py27h7b6447c_0    defaults
ptyprocess                0.6.0                    py27_0    defaults
py                        1.8.0                    py27_0    defaults
py-lief                   0.9.0            py27h7725739_2    defaults
pycairo                   1.18.0           py27h2a1e443_0    defaults
pycodestyle               2.5.0                    py27_0    defaults
pycosat                   0.6.3            py27h14c3975_0    defaults
pycparser                 2.19                     py27_0    defaults
pycrypto                  2.6.1            py27h14c3975_9    defaults
pycurl                    7.43.0.2         py27h1ba5d50_0    defaults
pyflakes                  2.1.1                    py27_0    defaults
pygments                  2.3.1                    py27_0    defaults
pylint                    1.9.2                    py27_0    defaults
pyodbc                    4.0.26           py27he6710b0_0    defaults
pyopenssl                 19.0.0                   py27_0    defaults
pyparsing                 2.3.1                    py27_0    defaults
pyqt                      5.9.2            py27h05f1152_2    defaults
pyrsistent                0.14.11          py27h7b6447c_0    defaults
pysocks                   1.6.8                    py27_0    defaults
pytables                  3.5.1            py27h71ec239_0    defaults
pytest                    4.3.1                    py27_0    defaults
python                    2.7.16               h9bab390_0    defaults
python-dateutil           2.8.0                    py27_0    defaults
python-libarchive-c       2.8                      py27_6    defaults
pytz                      2018.9                   py27_0    defaults
pywavelets                1.0.2            py27hdd07704_0    defaults
pyyaml                    5.1              py27h7b6447c_0    defaults
pyzmq                     18.0.0           py27he6710b0_0    defaults
qt                        5.9.7                h5867ecd_1    defaults
qtawesome                 0.5.7                    py27_1    defaults
qtconsole                 4.4.3                    py27_0    defaults
qtpy                      1.7.0                    py27_1    defaults
readline                  7.0                  h7b6447c_5    defaults
requests                  2.21.0                   py27_0    defaults
rope                      0.12.0                   py27_0    defaults
ruamel_yaml               0.15.46          py27h14c3975_0    defaults
scandir                   1.10.0           py27h7b6447c_0    defaults
scikit-image              0.14.2           py27he6710b0_0    defaults
scikit-learn              0.20.3           py27hd81dba3_0    defaults
scipy                     1.2.1            py27h7c811a0_0    defaults
seaborn                   0.9.0                    py27_0    defaults
send2trash                1.5.0                    py27_0    defaults
setuptools                40.8.0                   py27_0    defaults
simplegeneric             0.8.1                    py27_2    defaults
singledispatch            3.4.0.3          py27h9bcb476_0    defaults
sip                       4.19.8           py27hf484d3e_0    defaults
six                       1.12.0                   py27_0    defaults
snappy                    1.1.7                hbae5bb6_3    defaults
snowballstemmer           1.2.1            py27h44e2768_0    defaults
sortedcollections         1.1.2                    py27_0    defaults
sortedcontainers          2.1.0                    py27_0    defaults
soupsieve                 1.8                      py27_0    defaults
sphinx                    1.8.5                    py27_0    defaults
sphinxcontrib             1.0                      py27_1    defaults
sphinxcontrib-websupport  1.1.0                    py27_1    defaults
spyder                    3.3.3                    py27_0    defaults
spyder-kernels            0.4.2                    py27_0    defaults
sqlalchemy                1.3.1            py27h7b6447c_0    defaults
sqlite                    3.27.2               h7b6447c_0    defaults
ssl_match_hostname        3.7.0.1                  py27_0    defaults
statsmodels               0.9.0            py27h035aef0_0    defaults
subprocess32              3.5.3            py27h7b6447c_0    defaults
sympy                     1.3                      py27_0    defaults
tblib                     1.3.2            py27h51fe5ba_0    defaults
terminado                 0.8.1                    py27_1    defaults
testpath                  0.4.2                    py27_0    defaults
tk                        8.6.8                hbc83047_0    defaults
toolz                     0.9.0                    py27_0    defaults
tornado                   5.1.1            py27h7b6447c_0    defaults
tqdm                      4.31.1                   py27_1    defaults
traceback2                1.4.0                    py27_0    defaults
traitlets                 4.3.2            py27hd6ce930_0    defaults
typing                    3.6.6                    py27_0    defaults
unicodecsv                0.14.1           py27h5062da9_0    defaults
unittest2                 1.1.0                    py27_0    defaults
unixodbc                  2.3.7                h14c3975_0    defaults
urllib3                   1.24.1                   py27_0    defaults
wcwidth                   0.1.7            py27h9e3e1ab_0    defaults
webencodings              0.5.1                    py27_1    defaults
werkzeug                  0.14.1                   py27_0    defaults
wheel                     0.33.1                   py27_0    defaults
widgetsnbextension        3.4.2                    py27_0    defaults
wrapt                     1.11.1           py27h7b6447c_0    defaults
wurlitzer                 1.0.2                    py27_0    defaults
xlrd                      1.2.0                    py27_0    defaults
xlsxwriter                1.1.5                    py27_0    defaults
xlwt                      1.3.0            py27h3d85d97_0    defaults
xz                        5.2.4                h14c3975_4    defaults
yaml                      0.1.7                had09818_2    defaults
zeromq                    4.3.1                he6710b0_3    defaults
zict                      0.1.4                    py27_0    defaults
zipp                      0.3.3                    py27_1    defaults
zlib                      1.2.11               h7b6447c_3    defaults
zstd                      1.3.7                h0b5b093_0    defaults

@msarahan

This comment has been minimized.

Copy link
Contributor

commented Jun 29, 2019

Here's a hint generated by the latest master branch:

UnsatisfiableError: The following specifications were found to be incompatible with each other:

  - cairo -> *[track_features=nox]
  - cairocffi -> cairo[version='1.14.*,1.14.*,>=1.14.12,<2.0a0']
  - cantera[version='>=2.3.0'] -> mkl
  - coolprop -> matplotlib
  - coverage -> libgcc-ng[version='>=4.9,>=7.2.0,>=7.3.0']
  - cython[version='>=0.25.2'] -> setuptools
  - dde -> theano=0.9.0
  - ffmpeg -> lame[version='>=3.100,<3.101.0a0']
  - gprof2dot -> python[version='2.7.*,3.4.*']
  - graphviz -> libtool
  - jinja2 -> setuptools
  - jupyter -> nbconvert
  - lpsolve55 -> libgcc-ng[version='>=4.9,>=7.3.0']
  - markupsafe -> libgcc-ng[version='>=4.9,>=7.2.0,>=7.3.0']
  - matplotlib[version='>=1.5'] -> python-dateutil
  - mock -> funcsigs
  - mpmath -> gmpy2
  - muq -> flann
  - networkx -> setuptools
  - nose -> setuptools
  - numpy[version='>=1.10.0'] -> libblas[version='>=3.8.0,<4.0a0']
  - openbabel -> libgcc
  - psutil -> libgcc-ng[version='>=4.9,>=7.2.0,>=7.3.0']
  - pydas[version='>=1.0.1'] -> libgcc
  - pydot==1.2.2 -> pyparsing[version='>=2.1.4']
  - pydqed[version='>=1.0.0'] -> libgcc
  - pymongo -> libgcc-ng[version='>=4.9,>=7.2.0,>=7.3.0']
  - pyparsing -> python[version='2.7.*,3.4.*,3.5.*,3.6.*,>=2.7,<2.8.0a0,>=3.5,<3.6.0a0,>=3.6,<3.7.0a0,>=3.7,<3.8.0a0']
  - pyrdl -> python=2.7
  - python[version='>=2.7'] -> libffi[version='3.2.*,>=3.2.1,<3.3.0a0,>=3.2.1,<4.0a0']
  - pyyaml -> libgcc-ng[version='>=4.9,>=7.2.0,>=7.3.0']
  - quantities -> numpy=1.9
  - rdkit[version='>=2018'] -> pandas
  - scikit-learn -> mkl-service[version='>=2,<3.0a0']
  - scipy -> libblas[version='>=3.8.0,<4.0a0']
  - textgenrnn -> theano=0.9.0
  - xlwt -> python[version='2.7.*,3.5.*,3.6.*,>=2.7,<2.8.0a0,>=3.5,<3.6.0a0,>=3.6,<3.7.0a0,>=3.7,<3.8.0a0']

I don't fully understand it yet. There's a lot of noise. One thing that stands out to me is that there's a mix of stuff that uses libgcc and libgcc-ng. Those two should never be installed together. They overlap filenames and will break one another.

I think the fundamental reason for the breakage is that conda 4.7.x drops the "free" channel. Indeed, adding that back in fixes things:

CONDA_RESTORE_FREE_CHANNEL=1 conda env create -f env.yml

Those things that depend on libgcc really, really need to be rebuilt.

@mcg1969

This comment has been minimized.

Copy link
Contributor

commented Jun 29, 2019

re: libgcc and libgcc-ng — if they shouldn't be installed together it sounds like we need them to depend on a mutex package... I've seen this in other environments too and wondered if that was going to get me into trouble...

@HQDragon

This comment has been minimized.

Copy link

commented Jul 1, 2019

conda update conda 4.7.5
conda failed to solve enviroment, can't update package and install new package

@amarkpayne

This comment has been minimized.

Copy link
Author

commented Jul 1, 2019

Thanks for the help with this, @msarahan

I just wanted to additionally confirm that your solution of CONDA_RESTORE_FREE_CHANNEL=1 conda env create -f env.yml works on our end as well. We will also look into re-building our packages that depend on libgcc instead of libgcc-ng.

@kiretd

This comment has been minimized.

Copy link

commented Jul 13, 2019

I'm having a similar issue after updating to conda 4.7.5, but it's even worse. I can't downgrade conda, I can't update/install/uninstall any package (get similar UnsatisfiableError, but with a different list of packages), and I cannot revert back using conda install -revision. It feels like updating essentially broke my build.

What can I post to help debug my case? (I've never posted to boards like these before, so I'm not sure what is the proper way to do this. Apologies in advance.)

@msarahan

This comment has been minimized.

Copy link
Contributor

commented Jul 13, 2019

Sorry, it is especially frustrating to feel stuck. Some users have reported success reverting to an earlier revision. The commands to do this look like:

conda install --revision <rev>

This website talks about it more:

http://blog.rtwilson.com/conda-revisions-letting-you-rollback-to-a-previous-version-of-your-environment/

Since you can't run conda list --revisions, you probably need to look at the history manually. It is in a file at the root of your anaconda/miniconda install, in the conda-meta folder. The file is "history" and it's just a plain text file.

We have fixed a lot of the issues, and you can also try to update conda. Given your current state, it's probably best to download the latest conda release manually from https://anaconda.org/conda-canary/conda/files - choose the file for your OS and python version.

Try to install that with conda install path/to/your/downloaded/conda-4.7.7-pyXY_0.tar.bz2

If that doesn't work, extract that file manually into your anaconda/miniconda installation, overwriting the existing conda files there.

@kiretd

This comment has been minimized.

Copy link

commented Jul 13, 2019

Thanks for the response! Yes, I have already tried both of those options, except for extracting it manually. I will try that and let you know.

@kiretd

This comment has been minimized.

Copy link

commented Jul 13, 2019

Edit 2: Okay, the installation worked, but I made the mistake of trying conda install anaconda, which led to this:
Executing transaction: / DEBUG menuinst_win32:init(199): Menu: name: 'Anaconda${PY_VER} ${PLATFORM}', prefix: 'C:\Users\Kiret\Anaconda3', env_name: 'None', mode: 'user', used_mode: 'user'
DEBUG menuinst_win32:create(323): Shortcut cmd is C:\Users\Kiret\Anaconda3\pythonw.exe, args are ['C:\Users\Kiret\Anaconda3\cwp.py', 'C:\Users\Kiret\Anaconda3', 'C:\Users\Kiret\Anaconda3\pythonw.exe', 'C:\Users\Kiret\Anaconda3\Scripts\spyder-script.py']

  • DEBUG menuinst_win32:create(323): Shortcut cmd is C:\Users\Kiret\Anaconda3\python.exe, args are ['C:\Users\Kiret\Anaconda3\cwp.py', 'C:\Users\Kiret\Anaconda3', 'C:\Users\Kiret\Anaconda3\python.exe', 'C:\Users\Kiret\Anaconda3\Scripts\spyder-script.py', '--reset']
    | DEBUG menuinst_win32:init(199): Menu: name: 'Anaconda${PY_VER} ${PLATFORM}', prefix: 'C:\Users\Kiret\Anaconda3', env_name: 'None', mode: 'user', used_mode: 'user'
    DEBUG menuinst_win32:create(323): Shortcut cmd is C:\Users\Kiret\Anaconda3\python.exe, args are ['C:\Users\Kiret\Anaconda3\cwp.py', 'C:\Users\Kiret\Anaconda3', 'C:\Users\Kiret\Anaconda3\python.exe', 'C:\Users\Kiret\Anaconda3\Scripts\jupyter-notebook-script.py', '"%USERPROFILE%/"']
    done
    Rolling back transaction: done

Now I get this when running conda list:

Error processing line 1 of C:\Users\Kiret\Anaconda3\lib\site-packages\protobuf-3.4.1-py3.6-nspkg.pth:

Traceback (most recent call last):
File "C:\Users\Kiret\Anaconda3\lib\site.py", line 168, in addpackage
exec(line)
File "", line 1, in
File "", line 568, in module_from_spec
AttributeError: 'NoneType' object has no attribute 'loader'

Remainder of file ignored
Traceback (most recent call last):
File "C:\Users\Kiret\Anaconda3\lib\site-packages\conda\exceptions.py", line 1049, in call
return func(*args, **kwargs)
File "C:\Users\Kiret\Anaconda3\lib\site-packages\conda\cli\main.py", line 74, in _main
from ..base.context import context
File "C:\Users\Kiret\Anaconda3\lib\site-packages\conda\base\context.py", line 28, in
from ..common.configuration import (Configuration, ConfigurationLoadError, MapParameter,
File "C:\Users\Kiret\Anaconda3\lib\site-packages\conda\common\configuration.py", line 40, in
from .serialize import yaml_load
File "C:\Users\Kiret\Anaconda3\lib\site-packages\conda\common\serialize.py", line 45, in
yaml.representer.RoundTripRepresenter.add_representer(odict, represent_ordereddict)
AttributeError: module 'ruamel_yaml' has no attribute 'representer'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "C:\Users\Kiret\Anaconda3\Scripts\conda-script.py", line 12, in
sys.exit(main())
File "C:\Users\Kiret\Anaconda3\lib\site-packages\conda\cli\main.py", line 150, in main
return conda_exception_handler(_main, *args, **kwargs)
File "C:\Users\Kiret\Anaconda3\lib\site-packages\conda\exceptions.py", line 1341, in conda_exception_handler
return_value = exception_handler(func, *args, **kwargs)
File "C:\Users\Kiret\Anaconda3\lib\site-packages\conda\exceptions.py", line 1052, in call
return self.handle_exception(exc_val, exc_tb)
File "C:\Users\Kiret\Anaconda3\lib\site-packages\conda\exceptions.py", line 1096, in handle_exception
return self.handle_unexpected_exception(exc_val, exc_tb)
File "C:\Users\Kiret\Anaconda3\lib\site-packages\conda\exceptions.py", line 1107, in handle_unexpected_exception
self.print_unexpected_error_report(error_report)
File "C:\Users\Kiret\Anaconda3\lib\site-packages\conda\exceptions.py", line 1162, in print_unexpected_error_report
from .base.context import context
File "C:\Users\Kiret\Anaconda3\lib\site-packages\conda\base\context.py", line 28, in
from ..common.configuration import (Configuration, ConfigurationLoadError, MapParameter,
File "C:\Users\Kiret\Anaconda3\lib\site-packages\conda\common\configuration.py", line 40, in
from .serialize import yaml_load
File "C:\Users\Kiret\Anaconda3\lib\site-packages\conda\common\serialize.py", line 45, in
yaml.representer.RoundTripRepresenter.add_representer(odict, represent_ordereddict)
AttributeError: module 'ruamel_yaml' has no attribute 'representer'

Edit: Sorry, dumb mistake by forgetting to switch back to base before install. Let me try it again and update you. Leaving the original below in case it helps anyone (e.g., by allowing them to say, "well, at least I'm not as nooby as that guy").

Okay, I was able to install 4.7.7 manually. That led to 'ImportError: No module named ruamel.yaml.comments' on conda list (or any conda command i tried). I tried manually installing ruamel_yaml, which the error asked me to do. That gives me this next error:

from conda_package_handling.api import InvalidArchiveError
ModuleNotFoundError: No module named 'conda_package_handling'

Would you suggest this should be pretty easy to fix from here? Or is this unexpected behaviour?

@kiretd

This comment has been minimized.

Copy link

commented Jul 13, 2019

After that install, I can no longer open Anaconda Prompt or Anaconda Navigator. Time for a fresh install...?

@joeborrello

This comment has been minimized.

Copy link

commented Jul 15, 2019

Sorry, it is especially frustrating to feel stuck. Some users have reported success reverting to an earlier revision. The commands to do this look like:

conda install --revision <rev>

I also suddenly started having trouble with my Anaconda version 4.7.5 and it sounds like a similar issue to what @kiretd is facing. I tried going back to a previous revision that was working and got the following error:

root@joecloud:~# conda install --revision ##

>>>>>>>>>>>>>>>>>>>>>> ERROR REPORT <<<<<<<<<<<<<<<<<<<<<<

Traceback (most recent call last):
  File "/root/anaconda3/lib/python3.7/site-packages/conda/cli/install.py", line 266, in install
    index)
  File "/root/anaconda3/lib/python3.7/site-packages/conda/plan.py", line 307, in revert_actions
    raise PackagesNotFoundError(not_found_in_index_specs)
conda.exceptions.PackagesNotFoundError: The following packages are missing from the target environment:
  - defaults::_license==1.1=py35_1
  - defaults::libdynd==0.7.2=0
  - defaults::dynd-python==0.7.2=py35_0
  - defaults::nb_conda_kernels==2.1.0=py35_0
  - defaults::libgfortran==3.0.0=1
  - defaults::_nb_ext_conf==0.4.0=py35_1
  - defaults::nb_anacondacloud==1.4.0=py35_0


During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/root/anaconda3/lib/python3.7/site-packages/conda/exceptions.py", line 1043, in __call__
    return func(*args, **kwargs)
  File "/root/anaconda3/lib/python3.7/site-packages/conda/cli/main.py", line 84, in _main
    exit_code = do_call(args, p)
  File "/root/anaconda3/lib/python3.7/site-packages/conda/cli/conda_argparse.py", line 82, in do_call
    exit_code = getattr(module, func_name)(args, parser)
  File "/root/anaconda3/lib/python3.7/site-packages/conda/cli/main_install.py", line 20, in execute
    install(args, parser, 'install')
  File "/root/anaconda3/lib/python3.7/site-packages/conda/cli/install.py", line 295, in install
    raise PackagesNotFoundError(e._formatted_chains, channels_urls)
AttributeError: 'PackagesNotFoundError' object has no attribute '_formatted_chains'

$ /root/anaconda3/bin/conda install --revision ##

environment variables:
CIO_TEST=
CONDA_ROOT=/root/anaconda3
PATH=/root/anaconda3/bin:/home/joe/anaconda3/bin:/usr/local/sbin:/usr/local
/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/b
in
REQUESTS_CA_BUNDLE=
SSL_CERT_FILE=

 active environment : None
   user config file : /root/.condarc

populated config files :
conda version : 4.7.5
conda-build version : not installed
python version : 3.7.3.final.0
virtual packages :
base environment : /root/anaconda3 (writable)
channel URLs : https://repo.anaconda.com/pkgs/main/linux-64
https://repo.anaconda.com/pkgs/main/noarch
https://repo.anaconda.com/pkgs/r/linux-64
https://repo.anaconda.com/pkgs/r/noarch
package cache : /root/anaconda3/pkgs
/root/.conda/pkgs
envs directories : /root/anaconda3/envs
/root/.conda/envs
platform : linux-64
user-agent : conda/4.7.5 requests/2.22.0 CPython/3.7.3 Linux/4.4.0-154-generic ubuntu/16.04.3 glibc/2.23
UID:GID : 0:0
netrc file : None
offline mode : False

@imk1

This comment has been minimized.

Copy link

commented Jul 17, 2019

I am having a similar problem. I have not been able to do anything with conda since updating to version 4.7.5, and some of the packages I previously installed are no longer working.

When I tried installing a revision before conda was updated from 4.6.14 to 4.75, I got the following error:

>>>>>>>>>>>>>>>>>>>>>> ERROR REPORT <<<<<<<<<<<<<<<<<<<<<<

Traceback (most recent call last):
  File "/home/ikaplow/anaconda2/lib/python2.7/site-packages/conda/exceptions.py", line 1043, in __call__
    return func(*args, **kwargs)
  File "/home/ikaplow/anaconda2/lib/python2.7/site-packages/conda/cli/main.py", line 84, in _main
    exit_code = do_call(args, p)
  File "/home/ikaplow/anaconda2/lib/python2.7/site-packages/conda/cli/conda_argparse.py", line 82, in do_call
    exit_code = getattr(module, func_name)(args, parser)
  File "/home/ikaplow/anaconda2/lib/python2.7/site-packages/conda/cli/main_install.py", line 20, in execute
    install(args, parser, 'install')
  File "/home/ikaplow/anaconda2/lib/python2.7/site-packages/conda/cli/install.py", line 295, in install
    raise PackagesNotFoundError(e._formatted_chains, channels_urls)
AttributeError: 'PackagesNotFoundError' object has no attribute '_formatted_chains'

$ /home/ikaplow/anaconda2/bin/conda install --revision 358

environment variables:
CIO_TEST=
CONDA_BACKUP_F90=/home/ikaplow/anaconda2/bin/x86_64-conda_cos6-linux-gnu-gfortran
CONDA_BACKUP_HOST=x86_64-conda_cos6-linux-gnu
CONDA_BACKUP_JAVA_HOME=/usr/java/latest
CONDA_BACKUP_JAVA_LD_LIBRARY_PATH=
CONDA_DEFAULT_ENV=base
CONDA_EXE=/home/ikaplow/anaconda2/bin/conda
CONDA_PREFIX=/home/ikaplow/anaconda2
CONDA_PROMPT_MODIFIER=(base)
CONDA_PYTHON_EXE=/home/ikaplow/anaconda2/bin/python
CONDA_ROOT=/home/ikaplow/anaconda2
CONDA_SHLVL=1
JAVA_LD_LIBRARY_PATH=/home/ikaplow/anaconda2/jre/lib/amd64/server
LD_LIBRARY_PATH=/home/ikaplow/anaconda2/pkgs/zlib-1.2.11-0/lib/:/home/ikaplow/anaconda
2/pkgs/zlib-1.2.11-0/lib/:/opt/openmpi/lib
MANPATH=/opt/torque/man:/usr/share/man
MODULEPATH=/usr/share/Modules/modulefiles:/etc/modulefiles
PATH=/home/ikaplow/anaconda2/bin:/home/ikaplow/anaconda2/bin:/home/ikaplow/
miniconda3/bin:/home/ikaplow/meme/bin:/home/ikaplow/anaconda2/bin:/hom
e/ikaplow/anaconda2/condabin:/home/ikaplow/anaconda2/bin:/home/ikaplow
/miniconda3/bin:/home/ikaplow/meme/bin:/opt/openmpi/bin:/usr/lib64/qt-
3.3/bin:/opt/maui/bin:/opt/torque/bin:/opt/torque/sbin:/usr/local/bin:
/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/opt/bio/ncbi/bin:/opt/b
io/mpiblast/bin:/opt/bio/EMBOSS/bin:/opt/bio/clustalw/bin:/opt/bio/tco
ffee/bin:/opt/bio/hmmer/bin:/opt/bio/phylip/exe:/opt/bio/mrbayes:/opt/
bio/fasta:/opt/bio/glimmer/bin:/opt/bio/glimmer/scripts:/opt/bio/groma
cs/bin:/opt/bio/gmap/bin:/opt/bio/tigr/bin:/opt/bio/autodocksuite/bin:
/opt/bio/wgs/bin:/opt/ganglia/bin:/opt/ganglia/sbin:/usr/java/latest/b
in:/opt/pdsh/bin:/opt/rocks/bin:/opt/rocks/sbin:/home/ikaplow/.bds:/ho
me/ikaplow/bin:/home/ikaplow/.bds
REQUESTS_CA_BUNDLE=
SSL_CERT_FILE=

 active environment : base
active env location : /home/ikaplow/anaconda2
        shell level : 1
   user config file : /home/ikaplow/.condarc

populated config files : /home/ikaplow/.condarc
conda version : 4.7.5
conda-build version : not installed
python version : 2.7.16.final.0
virtual packages : __cuda=9.1
base environment : /home/ikaplow/anaconda2 (writable)
channel URLs : https://conda.anaconda.org/bioconda/linux-64
https://conda.anaconda.org/bioconda/noarch
https://repo.anaconda.com/pkgs/main/linux-64
https://repo.anaconda.com/pkgs/main/noarch
https://repo.anaconda.com/pkgs/r/linux-64
https://repo.anaconda.com/pkgs/r/noarch
package cache : /home/ikaplow/anaconda2/pkgs
/home/ikaplow/.conda/pkgs
envs directories : /home/ikaplow/anaconda2/envs
/home/ikaplow/.conda/envs
platform : linux-64
user-agent : conda/4.7.5 requests/2.21.0 CPython/2.7.16 Linux/2.6.32-696.20.1.el6.x86_64 centos/6.9 glibc/2.12
UID:GID : 19107:19107
netrc file : None
offline mode : False

An unexpected error has occurred. Conda has prepared the above report.

I also get an error when I try to downgrade conda. Please let me know what I can do to fix this. Thanks so much!

@jeget

This comment has been minimized.

Copy link

commented Jul 17, 2019

@msarahan I also got an error after conda install --revision 10:

>>>>>>>>>>>>>>>>>>>>>> ERROR REPORT <<<<<<<<<<<<<<<<<<<<<<

Traceback (most recent call last):
  File "/home/bulat/anaconda3/lib/python3.6/site-packages/conda/cli/install.py", line 266, in install
    index)
  File "/home/bulat/anaconda3/lib/python3.6/site-packages/conda/plan.py", line 307, in revert_actions
    raise PackagesNotFoundError(not_found_in_index_specs)
conda.exceptions.PackagesNotFoundError: The following packages are missing from the target environment:
  - defaults::fontconfig==2.11.1=5
  - defaults::pyasn1==0.1.9=py35_0
  - defaults::dill==0.2.4=py35_0
  - defaults::jinja2==2.8=py35_0
  - defaults::libxslt==1.1.28=0
  - defaults::sphinx_rtd_theme==0.1.9=py35_0
  - defaults::cffi==1.5.2=py35_0
  - defaults::libtiff==4.0.6=2
  - defaults::itsdangerous==0.24=py35_0
  - defaults::simplegeneric==0.8.1=py35_0
  - defaults::sqlite==3.13.0=0
  - defaults::py==1.4.31=py35_0
  - defaults::tk==8.5.18=0
  - defaults::matplotlib==1.5.1=np111py35_0
  - defaults::argcomplete==1.0.0=py35_1
  - defaults::multipledispatch==0.4.8=py35_0
  - defaults::util-linux==2.21=0
  - defaults::sphinx==1.3.5=py35_0
  - defaults::libxml2==2.9.2=0
  - defaults::beautifulsoup4==4.4.1=py35_0
  - defaults::unicodecsv==0.14.1=py35_0
  - defaults::libffi==3.0.13=0
  - defaults::jupyter_console==4.1.1=py35_0
  - defaults::h5py==2.6.0=np111py35_1
  - defaults::curl==7.45.0=0
  - defaults::libsodium==1.0.3=0
  - defaults::chest==0.2.3=py35_0
  - defaults::cython==0.23.4=py35_0
  - defaults::pycrypto==2.6.1=py35_0
  - defaults::libdynd==0.7.2=0
  - defaults::mkl-service==1.1.2=py35_1
  - defaults::pyyaml==3.11=py35_1
  - defaults::fastcache==1.0.2=py35_0
  - defaults::sockjs-tornado==1.0.1=py35_0
  - defaults::heapdict==1.0.0=py35_0
  - defaults::qt==4.8.7=1
  - defaults::pexpect==4.0.1=py35_0
  - defaults::blaze==0.9.1=py35_0
  - defaults::psutil==4.1.0=py35_0
  - defaults::path.py==8.1.2=py35_1
  - defaults::locket==0.2.0=py35_0
  - defaults::jupyter_client==4.2.2=py35_0
  - defaults::werkzeug==0.11.4=py35_0
  - defaults::pyzmq==15.2.0=py35_0
  - defaults::traitlets==4.2.1=py35_0
  - defaults::ply==3.8=py35_0
  - defaults::patsy==0.4.1=py35_0
  - defaults::wheel==0.29.0=py35_0
  - defaults::jedi==0.9.0=py35_0
  - defaults::sip==4.16.9=py35_0
  - defaults::pygments==2.1.1=py35_0
  - defaults::alabaster==0.7.7=py35_0
  - defaults::anaconda==custom=py35_0
  - defaults::nbformat==4.0.1=py35_0
  - defaults::mistune==0.7.2=py35_0
  - defaults::singledispatch==3.4.0.3=py35_0
  - defaults::lxml==3.6.0=py35_0
  - defaults::scikit-image==0.12.3=np111py35_0
  - defaults::ruamel_yaml==0.11.14=py35_0
  - defaults::llvmlite==0.11.0=py35_0
  - defaults::numexpr==2.5.2=np111py35_1
  - defaults::idna==2.0=py35_0
  - defaults::terminado==0.5=py35_1
  - defaults::pycurl==7.19.5.3=py35_0
  - defaults::scikit-learn==0.17.1=np111py35_1
  - defaults::ipython_genutils==0.1.0=py35_0
  - defaults::cycler==0.10.0=py35_0
  - defaults::boto==2.39.0=py35_0
  - defaults::python==3.5.2=0
  - defaults::pyflakes==1.1.0=py35_0
  - defaults::xz==5.2.2=0
  - defaults::libpng==1.6.17=0
  - defaults::astropy==1.3.3=np111py35_0
  - defaults::ptyprocess==0.5=py35_0
  - defaults::pillow==3.1.1=py35_0
  - defaults::jupyter==1.0.0=py35_2
  - defaults::networkx==1.11=py35_0
  - defaults::pyqt==4.11.4=py35_1
  - defaults::jbig==2.1=0
  - defaults::bitarray==0.8.1=py35_0
  - defaults::configobj==5.0.6=py35_0
  - defaults::et_xmlfile==1.0.1=py35_0
  - defaults::numba==0.26.0=np111py35_0
  - defaults::dynd-python==0.7.2=py35_0
  - defaults::bottleneck==1.0.0=np111py35_0
  - defaults::python-dateutil==2.5.1=py35_0
  - defaults::tornado==4.3=py35_0
  - defaults::hdf5==1.8.16=0
  - defaults::markupsafe==0.23=py35_0
  - defaults::libgfortran==3.0.0=1
  - defaults::odo==0.4.2=py35_0
  - defaults::nltk==3.2=py35_0
  - defaults::pytz==2016.2=py35_0
  - defaults::flask-cors==2.1.2=py35_0
  - defaults::nose==1.3.7=py35_0
  - defaults::jdcal==1.2=py35_0
  - defaults::xlsxwriter==0.8.4=py35_0
  - defaults::pyparsing==2.0.3=py35_0
  - defaults::conda-manager==0.3.1=py35_0
  - defaults::pytest==2.8.5=py35_0
  - defaults::jpeg==8d=0
  - defaults::greenlet==0.4.9=py35_0
  - defaults::pickleshare==0.5=py35_0
  - defaults::yaml==0.1.6=0
  - defaults::jupyter_core==4.1.0=py35_0
  - defaults::mkl==11.3.3=0
  - defaults::conda-build==1.20.0=py35_0
  - defaults::pep8==1.7.0=py35_0
  - defaults::ipywidgets==4.1.1=py35_0
  - defaults::pycparser==2.14=py35_0
  - defaults::decorator==4.0.9=py35_0
  - defaults::sqlalchemy==1.0.12=py35_0
  - defaults::ipykernel==4.3.1=py35_0
  - defaults::freetype==2.5.5=0
  - defaults::colorama==0.3.7=py35_0
  - defaults::docutils==0.12=py35_0
  - defaults::notebook==4.1.0=py35_1
  - defaults::pytables==3.2.2=np111py35_3
  - defaults::jsonschema==2.4.0=py35_0
  - defaults::redis-py==2.10.3=py35_0
  - defaults::cloudpickle==0.1.1=py35_0
  - defaults::xlrd==0.9.4=py35_0
  - defaults::requests==2.14.2=py35_0
  - defaults::ipython==4.1.2=py35_1
  - defaults::openpyxl==2.3.2=py35_0
  - defaults::partd==0.3.2=py35_1
  - defaults::anaconda-navigator==1.1.0=py35_0
  - defaults::zeromq==4.1.3=0
  - defaults::six==1.10.0=py35_0
  - defaults::redis==2.6.9=0
  - defaults::datashape==0.5.1=py35_0
  - defaults::clyent==1.2.1=py35_0
  - defaults::flask==0.10.1=py35_1
  - defaults::readline==6.2=2
  - defaults::pyopenssl==17.0.0=py35_0
  - defaults::mpmath==0.19=py35_0
  - defaults::bokeh==0.11.1=py35_0
  - defaults::dask==0.8.1=py35_0
  - defaults::sympy==1.0=py35_0
  - defaults::patchelf==0.8=0
  - defaults::zlib==1.2.8=0
  - defaults::nbconvert==4.1.0=py35_0
  - defaults::babel==2.2.0=py35_0
  - defaults::qtconsole==4.2.0=py35_0
  - defaults::anaconda-client==1.4.0=py35_0
  - defaults::pandas==0.18.0=np111py35_0
  - defaults::snowballstemmer==1.2.1=py35_0
  - defaults::gevent==1.1.0=py35_0
  - defaults::xlwt==1.0.0=py35_0
  - defaults::scipy==0.18.1=np111py35_0
  - defaults::statsmodels==0.6.1=np111py35_0
  - defaults::rope==0.9.4=py35_1
  - defaults::pip==8.1.1=py35_1
  - defaults::cryptography==1.7.1=py35_0


During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/home/bulat/anaconda3/lib/python3.6/site-packages/conda/exceptions.py", line 1043, in __call__
    return func(*args, **kwargs)
  File "/home/bulat/anaconda3/lib/python3.6/site-packages/conda/cli/main.py", line 84, in _main
    exit_code = do_call(args, p)
  File "/home/bulat/anaconda3/lib/python3.6/site-packages/conda/cli/conda_argparse.py", line 82, in do_call
    exit_code = getattr(module, func_name)(args, parser)
  File "/home/bulat/anaconda3/lib/python3.6/site-packages/conda/cli/main_install.py", line 20, in execute
    install(args, parser, 'install')
  File "/home/bulat/anaconda3/lib/python3.6/site-packages/conda/cli/install.py", line 295, in install
    raise PackagesNotFoundError(e._formatted_chains, channels_urls)
AttributeError: 'PackagesNotFoundError' object has no attribute '_formatted_chains'

$ /home/bulat/anaconda3/bin/conda install --revision 10

environment variables:
CIO_TEST=
CONDA_ROOT=/home/bulat/anaconda3
DEFAULTS_PATH=/usr/share/gconf/ubuntu.default.path
LD_LIBRARY_PATH=/home/bulat/ScienceTools-v10r0p5/x86_64-unknown-linux-gnu-
libc2.19-0/lib
MANDATORY_PATH=/usr/share/gconf/ubuntu.mandatory.path
PATH=/home/bulat/ScienceTools-v10r0p5/x86_64-unknown-linux-gnu-libc2.19-0/b
in:/home/bulat/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/
sbin:/bin:/usr/games:/usr/local/games:/snap/bin:/usr/lib/jvm/java-8-or
acle/bin:/usr/lib/jvm/java-8-oracle/db/bin:/usr/lib/jvm/java-8-oracle/
jre/bin:/home/bulat/anaconda3/bin:/home/bulat/spice/cspice/exe:/home/b
ulat/ds9:/home/bulat/fv5.4
PYTHONPATH=/home/bulat/ScienceTools-v10r0p5/x86_64-unknown-linux-gnu-
libc2.19-0/lib/python:/home/bulat/ScienceTools-v10r0p5/x86_64-unknown-
linux-gnu-libc2.19-0/lib:
REQUESTS_CA_BUNDLE=
SSL_CERT_FILE=
XDG_SEAT_PATH=/org/freedesktop/DisplayManager/Seat0
XDG_SESSION_PATH=/org/freedesktop/DisplayManager/Session0

 active environment : None
   user config file : /home/bulat/.condarc

populated config files : /home/bulat/.condarc
conda version : 4.7.5
conda-build version : not installed
python version : 3.6.2.final.0
virtual packages :
base environment : /home/bulat/anaconda3 (writable)
channel URLs : https://repo.anaconda.com/pkgs/main/linux-64
https://repo.anaconda.com/pkgs/main/noarch
https://repo.anaconda.com/pkgs/r/linux-64
https://repo.anaconda.com/pkgs/r/noarch
https://conda.anaconda.org/conda-forge/linux-64
https://conda.anaconda.org/conda-forge/noarch
package cache : /home/bulat/anaconda3/pkgs
/home/bulat/.conda/pkgs
envs directories : /home/bulat/anaconda3/envs
/home/bulat/.conda/envs
platform : linux-64
user-agent : conda/4.7.5 requests/2.22.0 CPython/3.6.2 Linux/4.4.0-154-generic ubuntu/16.04.6 glibc/2.23
UID:GID : 1000:1000
netrc file : None
offline mode : False

An unexpected error has occurred. Conda has prepared the above report.

I tried downloading conda-4.7.7-pyXY_0.tar.bz2 as you suggested. After doing conda install conda-4.7.7-py37_0.tar.bz2 the corresponding files in the anaconda directory have changed. However I still can't update packages and even run them. E.g.

$ spyder
Traceback (most recent call last):
  File "/home/bulat/anaconda3/bin/spyder", line 7, in <module>
    from spyder.app.start import main
ModuleNotFoundError: No module named 'spyder'

Please help!

@joeborrello

This comment has been minimized.

Copy link

commented Jul 17, 2019

I'd just like to provide an update for the issues I was having. I managed to fix all of my issues by getting rid of my anaconda/miniconda directories (rm -rf) and re-installing from the Anaconda bash script installation. It did remove some special configs I had, but I was able to replace them pretty quickly.

@imk1

This comment has been minimized.

Copy link

commented Jul 17, 2019

I am not using miniconda, so I do not think that will work for me. I also installed a lot of packages with anaconda, so I would prefer not to have to reinstall everything from scratch.

I tried installing conda 4.7.7, and I have no idea if that worked. I have been waiting for over an hour to solve the environment to install a new package (I used to wait 3-5 minutes), so I have no idea when I will find out if it works.

@jeget

This comment has been minimized.

Copy link

commented Jul 17, 2019

Thank you @joeborrello I did the same with Anaconda.

@imk1

This comment has been minimized.

Copy link

commented Jul 17, 2019

After a lot of trial and error, I finally got anaconda and almost all of the packages I had previously installed to work again. I did it by downloading conda 4.6.14 from https://anaconda.org/conda-canary/conda/files?page=2 and then running conda install /home/ikaplow/conda-4.6.14-py27_0.tar.bz2, which got me back to conda version 4.6.14 (everything was working with that before I upgraded to conda 4.7.5).

@amarkpayne

This comment has been minimized.

Copy link
Author

commented Jul 22, 2019

Update on issue with 4.7.5 (main issue):

After doing some further digging, we finally found that two of our dependencies (dde, theano) explicitly required the following packages between the two of them:

  • pydot-ng
  • pygpu
  • libgpuarray

Looking at the environment that 4.6.11 built, these packages were still downloaded, but conda was able to find these packages from the Free channel. Once the Free channel was removed as a default in 4.7, conda was no longer able to find these packages unless we restored the free channel or added the Anaconda channel where these packages can also be found (this was our first solution to the problem).

We also updated all of our packages so that nothing depends on libgcc anymore and instead depends on libgcc-ng. While this likely helped us avoid issues for the future, this alone would not fix our issue, as conda still needs to be able to find the three packages listed above.

Given all of this, the solution to all of this is simply to read the documentation on the free channel listed here. I'll go ahead and close this issue as everything seems to be solved now.

@amarkpayne amarkpayne closed this Jul 22, 2019

@imk1

This comment has been minimized.

Copy link

commented Jul 22, 2019

Thanks for the information! I have been using theano, so this might explain why conda 4.7.5 was not working for me.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.