New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Doesn't register on Windows through FIDOboosterUno #40

Closed
scateu opened this Issue Dec 1, 2016 · 13 comments

Comments

Projects
None yet
5 participants
@scateu
Contributor

scateu commented Dec 1, 2016

http://www.vancosys.com/fidobooster/

When I try to register it through "FIDOboosterUno for Windows 10 64bit",U2F-Zero does give an indication for me to press the button. But FIDOboosterUno doesn't continue after I pressed it.
(The U2F-Zero device still keep the indication lights on)

While it works well for my Yubikey Neo.

Plus, what can I do if I want to debug this issue?

Thanks.

FIDOboosterUno Download links

Windows 10

Windows 7/8

@darconeous

This comment has been minimized.

Show comment
Hide comment
@darconeous

darconeous Dec 1, 2016

Have you confirmed that your token works for other sites, like Google? I wonder if the button on yours might be broke.

darconeous commented Dec 1, 2016

Have you confirmed that your token works for other sites, like Google? I wonder if the button on yours might be broke.

@scateu

This comment has been minimized.

Show comment
Hide comment
@scateu

scateu Dec 2, 2016

Contributor

It works for google, dropbox, fastmail, even for pam.d(linux/macOS), and firefox u2f plugin.

So it can be sure there is some compatibility issue with FIDObooster.

I have written to them, and get a response that they are working on it.

Contributor

scateu commented Dec 2, 2016

It works for google, dropbox, fastmail, even for pam.d(linux/macOS), and firefox u2f plugin.

So it can be sure there is some compatibility issue with FIDObooster.

I have written to them, and get a response that they are working on it.

@crrodriguez

This comment has been minimized.

Show comment
Hide comment
@crrodriguez

crrodriguez Dec 5, 2016

@scateu maybe you are hitting #36 ? can you check if the key is full already ?

crrodriguez commented Dec 5, 2016

@scateu maybe you are hitting #36 ? can you check if the key is full already ?

@scateu

This comment has been minimized.

Show comment
Hide comment
@scateu

scateu Dec 6, 2016

Contributor

Actually, I tried after 'python client.py wipe' (and 5 press)...

  1. python client.py wipe
  2. Register a new key via FIDO Booster, it prompts: "please press the button on your key"
  3. U2F Zero: LED, Red
  4. me pressing U2F Zero button, LED turns Blue
  5. me releasing U2F Zero button, LED turns back to Red
  6. FIDO Booster still prompts "please press the button on your key"
  7. ...... after pressing button for 15 times, LED indicates that key is full
Contributor

scateu commented Dec 6, 2016

Actually, I tried after 'python client.py wipe' (and 5 press)...

  1. python client.py wipe
  2. Register a new key via FIDO Booster, it prompts: "please press the button on your key"
  3. U2F Zero: LED, Red
  4. me pressing U2F Zero button, LED turns Blue
  5. me releasing U2F Zero button, LED turns back to Red
  6. FIDO Booster still prompts "please press the button on your key"
  7. ...... after pressing button for 15 times, LED indicates that key is full
@conorpp

This comment has been minimized.

Show comment
Hide comment
@conorpp

conorpp Dec 6, 2016

Owner

@scateu to wipe you need to press button 5 consecutive times. The client tool will let you know if it worked.

Owner

conorpp commented Dec 6, 2016

@scateu to wipe you need to press button 5 consecutive times. The client tool will let you know if it worked.

@scateu

This comment has been minimized.

Show comment
Hide comment
@scateu

scateu Dec 6, 2016

Contributor

"Actually, I tried after 'python client.py wipe' (and 5 press)..."

and it did wipe.

$ python client.py wipe
opened  None
Press U2F button repeatedly until the LED is no longer red.
Wipe succeeded

Contributor

scateu commented Dec 6, 2016

"Actually, I tried after 'python client.py wipe' (and 5 press)..."

and it did wipe.

$ python client.py wipe
opened  None
Press U2F button repeatedly until the LED is no longer red.
Wipe succeeded

@conorpp

This comment has been minimized.

Show comment
Hide comment
@conorpp

conorpp Dec 6, 2016

Owner

I just checked the debugging output and registration seems fine. It's likely an issue with FIDO Booster not handling something right. For instance, when all 15 slots are use up, the u2f zero replies with a valid error response indicating there is no memory. Yet FIDO booster continues to send repeated registration requests.

The program probably has the typical try/except while loop. It probably runs into an error parsing the u2f zero registration certificate which is different from Yubico's cert, causing it to resend another registration. Yubico is probably what the FIDO Boost authors tested against.

Owner

conorpp commented Dec 6, 2016

I just checked the debugging output and registration seems fine. It's likely an issue with FIDO Booster not handling something right. For instance, when all 15 slots are use up, the u2f zero replies with a valid error response indicating there is no memory. Yet FIDO booster continues to send repeated registration requests.

The program probably has the typical try/except while loop. It probably runs into an error parsing the u2f zero registration certificate which is different from Yubico's cert, causing it to resend another registration. Yubico is probably what the FIDO Boost authors tested against.

@scateu

This comment has been minimized.

Show comment
Hide comment
@scateu

scateu Dec 6, 2016

Contributor
Contributor

scateu commented Dec 6, 2016

@conorpp

This comment has been minimized.

Show comment
Hide comment
@conorpp

conorpp Jan 28, 2017

Owner

Is this still being looked at or can I close?

Owner

conorpp commented Jan 28, 2017

Is this still being looked at or can I close?

@scateu

This comment has been minimized.

Show comment
Hide comment
@scateu

scateu Feb 4, 2017

Contributor

I am trying to program the latest firmware into U2F Zero. After that, I'll test it again.

Contributor

scateu commented Feb 4, 2017

I am trying to program the latest firmware into U2F Zero. After that, I'll test it again.

@conorpp

This comment has been minimized.

Show comment
Hide comment
@conorpp

conorpp Jan 4, 2018

Owner

Assuming I can close this, let me know if there are still issues.

Owner

conorpp commented Jan 4, 2018

Assuming I can close this, let me know if there are still issues.

@conorpp conorpp closed this Jan 4, 2018

@GitHubMad

This comment has been minimized.

Show comment
Hide comment
@GitHubMad

GitHubMad Mar 22, 2018

On Windows 10, I also didn't succeed using U2F-zero with FIDOboosterUno.
I bought my U2F-zero here around Xmas.
Tested in february.
So maybe issue should be re-open...

GitHubMad commented Mar 22, 2018

On Windows 10, I also didn't succeed using U2F-zero with FIDOboosterUno.
I bought my U2F-zero here around Xmas.
Tested in february.
So maybe issue should be re-open...

@conorpp

This comment has been minimized.

Show comment
Hide comment
@conorpp

conorpp Mar 22, 2018

Owner

There was a faulty batch shipped around Christmas that was fixed by early January. Email me your order ID and we can go from there

Owner

conorpp commented Mar 22, 2018

There was a faulty batch shipped around Christmas that was fixed by early January. Email me your order ID and we can go from there

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment