Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

build(deps): bump github.com/docker/docker from 20.10.12+incompatible to 20.10.13+incompatible #1489

Conversation

dependabot[bot]
Copy link
Contributor

@dependabot dependabot bot commented Mar 11, 2022

Bumps github.com/docker/docker from 20.10.12+incompatible to 20.10.13+incompatible.

Release notes

Sourced from github.com/docker/docker's releases.

v20.10.13

This release of Docker Engine contains some bug-fixes and packaging changes, updates to the docker scan and docker buildx commands, an updated version of the Go runtime, and new versions of the containerd.io runtime. Together with this release, we now also provide .deb and .rpm packages of Docker Compose V2, which can be installed using the (optional) docker-compose-plugin package.

Builder

  • Updated the bundled version of buildx to v0.8.0.

Daemon

  • Fix a race condition when updating the container's state moby/moby#43166.
  • Update the etcd dependency to prevent the daemon from incorrectly holding file locks moby/moby#43259
  • Fix detection of user-namespaces when configuring the default net.ipv4.ping_group_range sysctl moby/moby#43084.

Distribution

  • Retry downloading image-manifests if a connection failure happens during image pull moby/moby#43333.

Documentation

  • Various fixes in command-line reference and API documentation.

Logging

  • Prevent an OOM when using the "local" logging driver with containers that produce a large amount of log messages moby/moby#43165.
  • Updates the fluentd log driver to prevent a potential daemon crash, and prevent containers from hanging when using the fluentd-async-connect=true and the remote server is unreachable moby/moby#43147.

Packaging

  • Provide .deb and .rpm packages for Docker Compose V2. Docker Compose v2.3.3 can now be installed on Linux using the docker-compose-plugin packages, which provides the docker compose subcommand on the Docker CLI. The Docker Compose plugin can also be installed and run standalone to be used as a drop-in replacement for docker-compose (Docker Compose V1) docker/docker-ce-packaging#638. The compose-cli-plugin package can also be used on older version of the Docker CLI with support for CLI plugins (Docker CLI 18.09 and up).
  • Provide packages for the upcoming Ubuntu 22.04 "Jammy Jellyfish" LTS release docker/docker-ce-packaging#645, docker/containerd-packaging#271.
  • Update docker buildx to v0.8.0.
  • Update docker scan (docker-scan-plugin) to v0.17.0.
  • Update containerd (containerd.io package) to v1.5.10.
  • Update the bundled runc version to v1.0.3.
  • Update Golang runtime to Go 1.16.15.
Commits
  • 906f57f Merge pull request #43333 from pete-woods/20.10-backport-43291-schema-downloa...
  • ce3b6d1 distribution: retry downloading schema config on retryable error
  • c3dec60 Merge pull request #43329 from thaJeztah/20.10_backport_update_containerd_bin...
  • 180f3b9 update containerd binary to v1.5.10
  • 409d7ac Merge pull request #43326 from thaJeztah/20.10_bump_go_1.16.15
  • 0fa0d70 [20.10] update to go 1.16.15 to address CVE-2022-24921
  • c4f6167 Merge pull request #43259 from thaJeztah/20.10_backport_fix_lock
  • 9a57c5c Merge pull request #43260 from thaJeztah/20.10_backport_docs_fixes
  • 4679ffd docs: remove HostConfig.LxcConf field from API docs
  • fbbe1fc api: remove HostConfig.LxcConf field
  • Additional commits viewable in compare view

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


Dependabot commands and options

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot close will close this PR and stop Dependabot recreating it. You can achieve the same result by closing it manually
  • @dependabot ignore this major version will close this PR and stop Dependabot creating any more for this major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this minor version will close this PR and stop Dependabot creating any more for this minor version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)

Bumps [github.com/docker/docker](https://github.com/docker/docker) from 20.10.12+incompatible to 20.10.13+incompatible.
- [Release notes](https://github.com/docker/docker/releases)
- [Changelog](https://github.com/moby/moby/blob/master/CHANGELOG.md)
- [Commits](moby/moby@v20.10.12...v20.10.13)

---
updated-dependencies:
- dependency-name: github.com/docker/docker
  dependency-type: direct:production
  update-type: version-update:semver-patch
...

Signed-off-by: dependabot[bot] <support@github.com>
@dependabot dependabot bot added the dependencies label Mar 11, 2022
@rhatdan
Copy link
Member

@rhatdan rhatdan commented Mar 11, 2022

LGTM

@rhatdan rhatdan merged commit 73a7946 into main Mar 11, 2022
9 checks passed
@dependabot dependabot bot deleted the dependabot/go_modules/github.com/docker/docker-20.10.13incompatible branch Mar 11, 2022
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
dependencies
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

1 participant