This is the Contao Composer Client
PHP CSS Other

README.md

Version Stable Build Status Upstream Build Status License Downloads

Composer integration for Contao

Module which loads the Composer autoloader, creates initial composer.json and provides a back end client.

Back end module

Installation

Checkout repository

Checkout this repository and link it to system/modules (initial)

cd /path/to/my/project/documentroot
git clone git@github.com:contao-community-alliance/composer-client.git composer/vendor/contao-community-alliance/composer
cd system/modules
ln -s ../../composer/vendor/contao-community-alliance/composer/src/system/modules/\!composer .
cd ../..
Contao page request

Do a normal page request, this will prepare the folder structure and the default composer.json

Download Composer (the manual way)

Download Composer as explained here: http://getcomposer.org/doc/00-intro.md#downloading-the-composer-executable

cd composer
curl -sS https://getcomposer.org/installer | php
Download Composer (with back end client)

Just call the back end client from the menu, it will tell you that Composer is not installed and install it automatically.

Add some vendors (the manual way)

Open the composer/composer.json in your prefered editor and add some dependencies as explained here: http://getcomposer.org/doc/04-schema.md

{
    "require": {
        "bit3/contao-nested-menu": "dev-master"
    }
}
Add some vendors (with back end client)
Via integrated search

Type your keyword or package name into the search field and press the search button.

Package search

Select your package and click the "mark to install" button on the right. Select prefered version and version contraint to install.

Package details view

Via integrated editor

Advanced editor

Click on "advanced mode" in the back end client and add some dependencies as explained here: http://getcomposer.org/doc/04-schema.md

"require": {
    ...
   "bit3/contao-nested-menu": "dev-master" 
}
Install the vendors (the manual way)

Tell composer to download the configured vendors

php composer.phar install
Install the vendors (with back end client)

Click on "updated packages" and just wait until Composer finished installation.

Requirements

  • PHP 5.3.4 or higher
  • Contao 2.11.* or Contao 3.1.* or higher

Attribution

For developers

Compile SCSS

$ cd 'src/system/modules/!composer/assets/css'
$ scss --no-cache --update --style compressed backend.scss