Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

fix(deps): update dependency yargs to v15.3.1 #559

Merged
merged 1 commit into from May 6, 2020
Merged

Conversation

@renovate
Copy link
Contributor

@renovate renovate bot commented Mar 8, 2020

This PR contains the following updates:

Package Type Update Change
yargs (source) dependencies minor 15.1.0 -> 15.3.1

Release Notes

yargs/yargs

v15.3.1

Compare Source

v15.3.0

Compare Source

Features
Bug Fixes
  • address ambiguity between nargs of 1 and requiresArg (#​1572) (a5edc32)

v15.2.0

Compare Source

BREAKING CHANGES
  • deps: yargs-parser@17.0.0 no longer implicitly creates arrays out of boolean
    arguments when duplicates are provided
Features
Bug Fixes
  • help always displayed for the first command parsed having an async handler (#​1535) (d585b30)
  • deps: fix enumeration for normalized path arguments (#​1567) (0b5b1b0)
  • locales: only translate default option group name (acc16de)
  • locales: remove extra space in French for 'default' (#​1564) (ecfc2c4)
  • translations: add French translation for unknown command (#​1563) (18b0b75)
  • translations: fix pluralization in error messages. (#​1557) (94fa38c)
  • yargs: correct support of bundled electron apps (#​1554) (a0b61ac)

Renovate configuration

📅 Schedule: At any time (no schedule defined).

🚦 Automerge: Disabled by config. Please merge this manually once you are satisfied.

♻️ Rebasing: Whenever PR becomes conflicted, or you tick the rebase/retry checkbox.

🔕 Ignore: Close this PR and you won't be reminded about this update again.


  • If you want to rebase/retry this PR, check this box

This PR has been generated by WhiteSource Renovate. View repository job log here.

@coveralls
Copy link

@coveralls coveralls commented Mar 8, 2020

Coverage Status

Coverage remained the same at 99.429% when pulling 17b6775 on renovate/yargs-15.x into 2f04ac8 on master.

@coveralls
Copy link

@coveralls coveralls commented Mar 8, 2020

Coverage Status

Coverage remained the same at 99.429% when pulling b3ec81a on renovate/yargs-15.x into 2f04ac8 on master.

@renovate renovate bot changed the title fix(deps): update dependency yargs to v15.3.0 fix(deps): update dependency yargs to v15.3.1 Mar 16, 2020
@renovate renovate bot force-pushed the renovate/yargs-15.x branch from b3ec81a to 17b6775 Mar 16, 2020
@thollander
Copy link

@thollander thollander commented May 4, 2020

Would be interesting to fix https://www.npmjs.com/advisories/1500 !

@gbhasha
Copy link

@gbhasha gbhasha commented May 6, 2020

This can fix the security vulnerability issue reported here: #582

@bcoe bcoe merged commit d98cd46 into master May 6, 2020
2 checks passed
@bcoe bcoe deleted the renovate/yargs-15.x branch May 6, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

5 participants