Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Video playback failure #1189

Closed
contrapunctus-1 opened this issue Sep 8, 2018 · 7 comments

Comments

@contrapunctus-1
Copy link
Contributor

commented Sep 8, 2018

I uploaded a video via HTTP Upload from Gajim. In Gajim, I clicked the link, which opened the video in Firefox. Firefox was able to play it.

When I try to view the same video inline from inverse.chat, I get the "No video with supported format and MIME type found." error where the video should be.

Firefox 62.0 (32-bit), Debian GNU/Linux 9.5 (stretch)

@jcbrand

This comment has been minimized.

Copy link
Member

commented Sep 23, 2018

Can you give me the URL of the video so that I can test it myself?

@contrapunctus-1

This comment has been minimized.

jcbrand added a commit that referenced this issue Sep 24, 2018

Set max-height for embedded videos.
Also udpate markup to not use `<source>`.

updates #1189
@jcbrand

This comment has been minimized.

Copy link
Member

commented Sep 24, 2018

@contrapunctus-1 I took a look... at first the video didn't play and then after playing around with markup it started playing. But here's the crazy part, now it also plays with the original markup.

Looks to me like a Firefox bug. In any case, it started playing once I removed the <source> element. So I updated the code to not have that.

Can you test again?

@contrapunctus-1

This comment has been minimized.

Copy link
Contributor Author

commented Sep 25, 2018

(Again using inverse.chat) Sorry, no change. 🙁

@jcbrand

This comment has been minimized.

Copy link
Member

commented Sep 25, 2018

inverse.chat hasn't been updated yet (I thought you were self-hosting).

@contrapunctus-1

This comment has been minimized.

Copy link
Contributor Author

commented Sep 25, 2018

Tried it by hosting it locally. It's working! 🎊

@jcbrand jcbrand closed this Sep 26, 2018

@jcbrand

This comment has been minimized.

Copy link
Member

commented Sep 26, 2018

Super, thanks for checking.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.