Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Link encoding issue #1204

Closed
guusdk opened this issue Sep 14, 2018 · 1 comment

Comments

@guusdk
Copy link
Member

commented Sep 14, 2018

In 4.0.0, a message that contains this URL displays a link that, when clicked, returns to an incorrect page.

Link used: https://github.com/xsf/xeps/pulls?q=is%3Apr+is%3Aopen+label%3A%22Needs+Council%22
Page opened: https://github.com/xsf/xeps/pulls?q=is%253Apr+is%253Aopen+label%253A%22Needs+Council%22

Note that both link open a Github issue list, but one of them is empty (the filter used is different).

This problem reportedly does not occur in other client (Poezio) that receive the link. That makes it reasonable to assume that the problem lies within Converse's parsing/encoding routines.

@jcbrand jcbrand added the bug label Sep 14, 2018

@jcbrand jcbrand added this to the 4.0.2 milestone Sep 23, 2018

@jcbrand jcbrand modified the milestones: 4.0.2, 4.0.3 Oct 3, 2018

@jcbrand jcbrand closed this in b039398 Oct 7, 2018

@jcbrand

This comment has been minimized.

Copy link
Member

commented Oct 7, 2018

Fixed, thanks.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.