Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Notification audio doesn't (always) play #1257

Closed
guusdk opened this issue Oct 22, 2018 · 0 comments

Comments

@guusdk
Copy link
Member

commented Oct 22, 2018

When enabling notifications, the corresponding audio doesn't always play. From todays chatlog:

Guus 17:41
jcbrand: I'm not getting the sound notifications to work. Do I explicitly install the plugin (even though the webapp already downloads the .ogg file?)

Dele Olajide 17:45
I had an issue with sound in Pade as well. I assumed it was chrome extension issue

if (audio.canPlayType('audio/ogg') == "probably") {   // BAO

Dele Olajide 17:47
chrome returns "maybe" and does not play it

Link Mauve 17:49
You most likely need to use audio/ogg;codec=vorbis instead.
Or codec=opus if that’s what you are using.

Dele Olajide 17:56
The msg_received.ogg file in converse is not playable by my chrome browser. I needed it to fall-through an play the msg_received.mp3 instead

guusdk added a commit to guusdk/converse.js that referenced this issue Oct 22, 2018

guusdk added a commit to guusdk/converse.js that referenced this issue Oct 22, 2018

guusdk added a commit to guusdk/converse.js that referenced this issue Oct 23, 2018

jcbrand added a commit that referenced this issue Oct 23, 2018

Merge pull request #1258 from guusdk/1257_notifications-prefer-probab…
…ly-over-maybe

#1257: Prefer 'probably' over 'maybe' when evaluating Audio support.

@jcbrand jcbrand added this to the 4.1.0 milestone Oct 23, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.