Skip to content
Browse files

disable old Rails tests for Ruby 2.0.0

I doubt anybody would attempt to run ancient, unsupported versions
of Rails on the latest (unreleased, even) versions of Ruby...
  • Loading branch information...
1 parent 79ae711 commit c8abf6a06c0bd7eb1dfc8457ef1c31de31e7715b Eric Wong committed Jan 27, 2012
Showing with 4 additions and 1 deletion.
  1. +4 −1 test/rails/test_rails.rb
View
5 test/rails/test_rails.rb
@@ -45,7 +45,10 @@
ROR_V = UNICORN_RAILS_TEST_VERSION.split(/\./).map { |x| x.to_i }
RB_V = RUBY_VERSION.split(/\./).map { |x| x.to_i }
-if RB_V[0] >= 1 && RB_V[1] >= 9
+if RB_V[0] >= 2
+ warn "skipping Ruby 2.0+ test with Rails <3"
+ do_test = false
+elsif RB_V[0] >= 1 && RB_V[1] >= 9
if RB_V[2] >= 2
warn "Ruby 1.9.2+ is not compatible with Rails 2.x"
do_test = false

0 comments on commit c8abf6a

Please sign in to comment.
Something went wrong with that request. Please try again.