Make compatible with wxPython 3.0 #94

Merged
merged 3 commits into from Dec 17, 2016

Projects

None yet

2 participants

@bittner
Contributor
bittner commented Dec 17, 2016 edited

This PR adds compatibility code for running PythonTurtle on Ubuntu 16.04.1 Xenial with python-wxgtk3.0 and Python 2.7.12.

References

@cool-RR
Owner
cool-RR commented Dec 17, 2016

Awesome! Can you explicitly confirm that you agree to have your code licensed under the MIT license? Feel free to create an AUTHORS file with our names and add it to the PR.

@bittner
Contributor
bittner commented Dec 17, 2016

Sure, I agree to my code being licensed under MIT.

Please make sure the application still runs for you. I have not tested the changes under Windows and older versions of Ubuntu.

@cool-RR
Owner
cool-RR commented Dec 17, 2016
@bittner
Contributor
bittner commented Dec 17, 2016

I'm moderately sure the changes will retain the current behavior, hence not affect Windows. But you never know until you prove it.

Will you package a new version for download from the website?

@cool-RR cool-RR merged commit e90dbf1 into cool-RR:master Dec 17, 2016
@cool-RR
Owner
cool-RR commented Dec 17, 2016

I accepted the MR, but I won't create a package, sorry. I don't want to spend time doing that. (I've written PythonTurtle like 7 years ago and have little interest in it now.) If you create a package I'll be happy to post it on the website. If this project is to continue, what's really needed is to automate the process of creating installers for Windows and Mac, so if you or anyone else wishes to contribute, that'll be the best area to do so.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment