Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Tree: 0bf34685c1
Fetching contributors…

Cannot retrieve contributors at this time

42 lines (38 sloc) 2.51 kB
{
"providing": {
},
"platforms": {
"centos": [
],
"ubuntu": [
],
"redhat": [
]
},
"description": "Installs/Configures ruby-enterprise",
"attributes": {
},
"replacing": {
},
"dependencies": {
"build-essential": [
]
},
"version": "0.2.3",
"groupings": {
},
"long_description": "= DESCRIPTION:\n\nInstalls Ruby Enterprise Edition (REE) from Phusion.\n\n= REQUIREMENTS:\n\nOpscode's build-essential cookbook to get a compiler and associated files installed.\n\n= ATTRIBUTES: \n\n* ruby_enterprise[:install_path] - Location to install REE. Default /opt/ruby-enterprise\n* ruby_enterprise[:version] - Version-datestamp to use. Default 1.8.6-20090610. May lag behind latest REE release.\n* ruby_enterprise[:url] - URL to download. Default is from RubyForge, with the version specified. Note the download ID must be updated when there are new releases.\n\n= USAGE:\n\nInclude the ruby_enterprise recipe to install REE.\n\n include_recipe \"ruby_enterprise\"\n\nOr add it to your role, or directly to a node's recipes.\n\nInstall RubyGems under REE with the ree_gem definition.\n\n ree_gem \"rails\" do\n source \"http://gems.rubyforge.org\"\n version \"2.3.4\"\n end\n\nThe definition supports parameters for source and version, though they are optional.\n\n= LICENSE and AUTHOR:\n\nAuthor:: Joshua Timberman (<joshua@opscode.com>)\nAuthor:: Sean Cribbs (<seancribbs@gmail.com>)\nAuthor:: Michael Hale (<mikehale@gmail.com>)\n\nCopyright:: 2009-2010, Opscode, Inc.\nCopyright:: 2009, Sean Cribbs\nCopyright:: 2009, Michael Hale\n\nLicensed under the Apache License, Version 2.0 (the \"License\");\nyou may not use this file except in compliance with the License.\nYou may obtain a copy of the License at\n\n http://www.apache.org/licenses/LICENSE-2.0\n\nUnless required by applicable law or agreed to in writing, software\ndistributed under the License is distributed on an \"AS IS\" BASIS,\nWITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.\nSee the License for the specific language governing permissions and\nlimitations under the License.\n\n",
"recommendations": {
},
"maintainer": "Opscode, Inc.",
"suggestions": {
},
"license": "Apache 2.0",
"name": "ruby_enterprise",
"maintainer_email": "ops@opscode.com",
"recipes": {
"ruby_enterprise": "Installs Ruby Enterprise Edition"
},
"conflicting": {
}
}
Jump to Line
Something went wrong with that request. Please try again.