Permalink
Browse files

fixing install docu

  • Loading branch information...
1 parent a7c5e36 commit 4f58add86d7d38d4ec1b72926b6d062e7ba24f4b Alexander Bernauer committed Nov 5, 2011
Showing with 5 additions and 9 deletions.
  1. +5 −9 INSTALL.mkd
View
@@ -1,12 +1,11 @@
bitcoin-script-tools v.0.1
-=======================================================================
+==========================
This installation manual assumes you have already cloned the bitcoin
script tools from the github repository and that you have switched to
the installation directory of the package (.../bitcoin-script-tools).
-1. Prerequisites
------------------------------------------------------------------------
+## 1. Prerequisites
In order to use the bitcoin script tools, some Linux packages have to
be installed on the local machine. The following description assumes a
@@ -15,8 +14,7 @@ necessary commands to install the packages:
$ sudo aptitude install cabal-install ghc6
-2. Install build tools
------------------------------------------------------------------------
+## 2. Install build tools
First you should update the cabal-install package itself as it is
likely that the distribution package is no longer up-to-date; make sure
@@ -30,8 +28,7 @@ Next you use new cabal binary to install cabal-dev:
$ cabal install cabal-dev
-3. Build bitcoin script tools
------------------------------------------------------------------------
+## 3. Build bitcoin script tools
Now you can compile the bitcoin script tools:
@@ -40,7 +37,6 @@ Now you can compile the bitcoin script tools:
On its first invocation cabal-dev pulls all dependencencies from Hackage,
builds them and installs them inside the project directory.
-4. Run the bitcoin script tools
------------------------------------------------------------------------
+## 4. Run the bitcoin script tools
$ cabal-dev/bin/bitcoin-script-tools --help

0 comments on commit 4f58add

Please sign in to comment.