Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Reinstalling each time on update #455

Open
ionesculiviucristian opened this issue Dec 7, 2018 · 0 comments

Comments

@ionesculiviucristian
Copy link

commented Dec 7, 2018

Hi. Every time i run npm update the package always gets "updated":

npm WARN ajv-keywords@3.2.0 requires a peer of ajv@^6.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN img-loader@3.0.0 requires a peer of imagemin@^5.0.0 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.4 (node_modules/fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.4: wanted {"os":"darwin","arch":"any"} (current: {"os":"linux","arch":"x64"})

+ @coreui/coreui-free-bootstrap-admin-template@2.1.10
removed 1101 packages, updated 2 packages and audited 12648 packages in 19.608s
found 4 high severity vulnerabilities
  run `npm audit fix` to fix them, or `npm audit` for details

My package.json file:

{
  "private": true,
  "scripts": {
    "dev": "npm run development",
    "development": "cross-env NODE_ENV=development node_modules/webpack/bin/webpack.js --progress --hide-modules --config=node_modules/laravel-mix/setup/webpack.config.js",
    "watch": "npm run development -- --watch",
    "watch-poll": "npm run watch -- --watch-poll",
    "hot": "cross-env NODE_ENV=development node_modules/webpack-dev-server/bin/webpack-dev-server.js --inline --hot --config=node_modules/laravel-mix/setup/webpack.config.js",
    "prod": "npm run production",
    "production": "cross-env NODE_ENV=production node_modules/webpack/bin/webpack.js --no-progress --hide-modules --config=node_modules/laravel-mix/setup/webpack.config.js",
    "npm-minify": "cross-env NODE_ENV=production NPM_MINIFY=true node_modules/webpack/bin/webpack.js --progress --hide-modules --config=node_modules/laravel-mix/setup/webpack.config.js"
  },
  "dependencies": {
    "@coreui/coreui-free-bootstrap-admin-template": "git+https://github.com/coreui/coreui-free-bootstrap-admin-template.git#master",
    "@fancyapps/fancybox": "^3.5.2",
    "@fortawesome/fontawesome-free": "^5.5.0",
    "animate.css": "^3.7.0",
    "axios": "^0.18.0",
    "bootstrap": "^4.1.3",
    "bootswatch": "^4.1.3",
    "chart.js": "^2.7.3",
    "codemirror": "^5.42.0",
    "cross-env": "^5.2.0",
    "datatables.net-bs4": "^1.10.19",
    "datatables.net-buttons-bs4": "^1.5.4",
    "datatables.net-responsive-bs4": "^2.2a.3",
    "flag-icon-css": "^3.2.1",
    "flatpickr": "^4.5.2",
    "hideshowpassword": "^2.1.1",
    "jquery": "^3.3.1",
    "jquery-typeahead": "^2.10.6",
    "jquery-ui-dist": "^1.12.1",
    "jstree": "^3.3.7",
    "jszip": "^3.1.5",
    "latinize": "^0.4.0",
    "lodash": "^4.17.11",
    "mark.js": "^8.11.1",
    "moment": "^2.22.2",
    "moment-timezone": "^0.5.23",
    "noty": "^3.1.4",
    "pace-progress": "^1.0.2",
    "perfect-scrollbar": "^1.4.0",
    "popper.js": "^1.14.6",
    "select2": "^4.0.5",
    "simple-line-icons": "^2.4.1",
    "spectrum-colorpicker": "^1.8.0",
    "summernote": "^0.8.11",
    "sweetalert2": "^7.31.1",
    "titatoggle": "^2.1.2",
    "tui-calendar": "^1.8.0",
    "underscore": "^1.9.1",
    "vue": "^2.5.17",
    "yargs": "^12.0.5"
  },
  "devDependencies": {
    "vnu-jar": "^18.11.5",
    "node-sass": "^4.10.0",
    "laravel-mix": "^2.1.14"
  }
}

Also the found 4 high severity vulnerabilities always appears, but I don't know if it's related to this package.
Is there a fix for this?

@ionesculiviucristian ionesculiviucristian changed the title Reinstalling each time update Reinstalling each time on update Dec 7, 2018
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.