Python program for the luftdaten.info sensor network (e.g. usage with Raspberry-Pi)
Switch branches/tags
Nothing to show
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
bme280
contrib
sds011
.gitignore
LICENSE
README.md
config.yml.default
main.py

README.md

dusty-python

Python 3 program for the luftdaten.info sensor network.

Supported Hardware

Used libraries

Dependencies

apt install python3-numpy python3-requests python3-yaml python3-serial

You also need to install Adafruit_Python_BME280:

apt-get update
apt-get install build-essential python-pip python-dev python-smbus git
git clone https://github.com/adafruit/Adafruit_Python_GPIO.git
cd Adafruit_Python_GPIO
python3 setup.py install

Configuration

Copy the config.yml.default to config.yml and adjust the settings.

Running a systemd unit

Take a look at the dusty.unit.