Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Exposure check failed when opening the CWA Version 1.6.0 / 1.6.1 (ExposureDetectionIsAlreadyRunning) #1497

Closed
2 tasks done
tibor opened this issue Nov 11, 2020 · 29 comments
Closed
2 tasks done
Labels
bug Something isn't working mirrored-to-jira This item is also tracked internally in JIRA

Comments

@tibor
Copy link

tibor commented Nov 11, 2020

Avoid duplicates

  • Bug is not mentioned in the FAQ
  • Bug is not already reported in another issue

Describe the bug

When opening the app, I got an error message „Exposure check failed“ and „An error occured during exposure logging. Code: ExposureDetectionIsAlreadyRunning“.

Expected behaviour

It should work as normally with former versions of the app.

Steps to reproduce the issue

IMG_0161
IMG_0160

Technical details

  • iOS Version: 14.2
  • Device: iPhone 11 Pro
  • App Version: 1.6.0 (4)

Internal Tracking ID: EXPOSUREAPP-3683

@tibor tibor added the bug Something isn't working label Nov 11, 2020
@Ein-Tim
Copy link
Contributor

Ein-Tim commented Nov 11, 2020

@tibor Is this issue new in 1.6.0?

@tibor
Copy link
Author

tibor commented Nov 11, 2020

@Ein-Tim haven’t seen this behavior in any of the previous app versions, so at least for me it’s new.

@thomasaugsten
Copy link
Member

thomasaugsten commented Nov 11, 2020

@tibor Did you restart the app?

@dsarkar
Copy link
Member

dsarkar commented Nov 11, 2020

Dear @tibor, dear community,

Thanks for posting this issue.

After an update to app version 1.6.0, you might get the error "Exposure Check Failed", even though there was a successful check in the past 24 hours. We are working on a solution for this error. In the meantime, try restarting your app. This helps in most cases.

Nach einem Update auf Version 1.6.0 kann es vorkommen, dass Sie die Nachricht "Risiko-Überprüfung fehlgeschlagen" erhalten, obwohl die letzte Überprüfung noch keine 24 Stunden her ist. Wir arbeiten gerade an einer Behebung dieses Problems. Bis das Update zur Verfügung steht, können Sie das Problem in den meisten Fällen mit einem Neustart Ihrer App beheben.

FAQ webpage DE: https://www.coronawarn.app/de/faq/#expcheck_160
FAQ webpage EN: https://www.coronawarn.app/en/faq/#expcheck_160

Internal Tracking ID: EXPOSUREAPP-3683

Best wishes,
DS

Corona-Warn-App Open Source Team

@dsarkar dsarkar changed the title Exposure check failed when opening the app Exposure check failed when opening the CWA Version 1.6.0 Nov 11, 2020
@dsarkar dsarkar added the hot topic 🔥 Hot Topics from the view point of the Community label Nov 11, 2020
@ferreirafabio
Copy link

ferreirafabio commented Nov 11, 2020

I have the same error and the same setup as @tibor but on an iPhone 11.

@dsarkar dsarkar added the mirrored-to-jira This item is also tracked internally in JIRA label Nov 11, 2020
@thomasaugsten
Copy link
Member

Can you please try v1.6.1

@tibor
Copy link
Author

tibor commented Nov 11, 2020

@thomasaugsten works well so far. Thanks for the fast fix 🚀

@ferreirafabio
Copy link

Works well for me again now too. Appreciate the fast responses.

@tibor
Copy link
Author

tibor commented Nov 12, 2020

@thomasaugsten unfortunately, I got the same error again today in the morning with 1.6.1
IMG_0180
IMG_0179

@tibor
Copy link
Author

tibor commented Nov 12, 2020

Updated date == time when I opened the app

@dsarkar
Copy link
Member

dsarkar commented Nov 12, 2020

@tibor, each time when you open CWA version 1.6.1 it does an update, or so far only once in the morning? Can you close the CWA (swipe up to fully close) and reopen, please? Still time 8:38 or actual time? Thanks.

@tibor
Copy link
Author

tibor commented Nov 12, 2020

@dsarkar still 8:38, so the app updated the first time I opened the app.

@dsarkar
Copy link
Member

dsarkar commented Nov 12, 2020

@tibor thanks.

  1. So only one update of exposure logs per day probably. Let's observe for the next few days if you get more than one update per day.
  2. The error message on your screenshot appeared when you updated to v1.6.1 and opened for the first time the updated CWA or did it appear sometime later?

@thomasaugsten
Copy link
Member

@tibor You can ignore the alreadyRunning error this can happen when two exposure check started at almost the same time. We will improve the message in the future.

@Ein-Tim
Copy link
Contributor

Ein-Tim commented Nov 12, 2020

I can't reproduce this Error with 1.6.1 @tibor

Edit: I also sometimes experience this error, I think the root cause is #1505

@tibor tibor changed the title Exposure check failed when opening the CWA Version 1.6.0 Exposure check failed when opening the CWA Version 1.6.0 / 1.6.1 Nov 12, 2020
@tibor
Copy link
Author

tibor commented Nov 12, 2020

@thomasaugsten Thanks, I’m fine with that. Just wanted to let you know that the behavior is not (completely) fixed with 1.6.1

@Ein-Tim
Copy link
Contributor

Ein-Tim commented Nov 13, 2020

@tibor There is now a PR which fixes the Error (#1510)

@tibor
Copy link
Author

tibor commented Nov 13, 2020

@Ein-Tim great, thanks!

@Ein-Tim

This comment has been minimized.

@thomasaugsten thomasaugsten changed the title Exposure check failed when opening the CWA Version 1.6.0 / 1.6.1 Exposure check failed when opening the CWA Version 1.6.0 / 1.6.1 (ExposureDetectionIsAlreadyRunning) Nov 14, 2020
@FrankBuchholz
Copy link

FrankBuchholz commented Nov 22, 2020

Since few days I get the same error messages on
CWA 1.6.1
iPhone 8 with iOS 14.2

@cwa-bot cwa-bot bot moved this from Mirrored to Jira to ToDo in [CM] cwa-app-ios Nov 22, 2020
@Ein-Tim
Copy link
Contributor

Ein-Tim commented Nov 22, 2020

@FrankBuchholz This should be solved with the upcoming 1.7.0 release next week

@dsarkar dsarkar moved this from ToDo to Mirrored to Jira in [CM] cwa-app-ios Nov 23, 2020
@thomasaugsten
Copy link
Member

@tibor Can you please update manually on v1.7.1 and check again if this problem is fixed

@cwa-bot cwa-bot bot moved this from Mirrored to Jira to ToDo in [CM] cwa-app-ios Nov 25, 2020
@dsarkar dsarkar moved this from ToDo to In Progress in [CM] cwa-app-ios Nov 25, 2020
@Ein-Tim
Copy link
Contributor

Ein-Tim commented Nov 25, 2020

I can confirm that this Issue is not here anymore under 1.7.1 and the App also don't show this screen anymore 👍

@cwa-bot cwa-bot bot moved this from In Progress to ToDo in [CM] cwa-app-ios Nov 25, 2020
@dsarkar
Copy link
Member

dsarkar commented Nov 26, 2020

Dear community,

We would appreciate very much detailed feedback on this issue, now that CWA version 1.7 has been rolled out. Please monitor the behavior over the next few days. Thank you all very much for your contributions.

Best wishes,
DS


Corona-Warn-App Open Source Team

@dsarkar dsarkar moved this from ToDo to Waiting for Input in [CM] cwa-app-ios Nov 26, 2020
@Ein-Tim
Copy link
Contributor

Ein-Tim commented Nov 28, 2020

I did not experience this Issue anymore under 1.7.1 👍
@tibor What about you?

@cwa-bot cwa-bot bot moved this from Waiting for Input to ToDo in [CM] cwa-app-ios Nov 28, 2020
@dsarkar dsarkar moved this from ToDo to In Progress in [CM] cwa-app-ios Nov 28, 2020
@dsarkar
Copy link
Member

dsarkar commented Nov 30, 2020

@tibor, any feedback would be very much appreciated. Best wishes,
DS


Corona-Warn-App Open Source Team

@dsarkar dsarkar moved this from In Progress to Waiting for Input in [CM] cwa-app-ios Nov 30, 2020
@tibor
Copy link
Author

tibor commented Nov 30, 2020

@dsarkar so far, for the last days, I haven't seen the exposure check failed message no more. Seems like it's working fine now 🙂

@cwa-bot cwa-bot bot moved this from Waiting for Input to ToDo in [CM] cwa-app-ios Nov 30, 2020
@dsarkar
Copy link
Member

dsarkar commented Dec 1, 2020

Dear @tibor, dear community, thanks for the feedback! We close this issue now. Please re-open in case of new occurrences!

Best wishes,
DS


Corona-Warn-App Open Source Team

@dsarkar dsarkar closed this as completed Dec 1, 2020
@cwa-bot cwa-bot bot moved this from ToDo to Done in [CM] cwa-app-ios Dec 1, 2020
@Ein-Tim
Copy link
Contributor

Ein-Tim commented Dec 1, 2020

@dsarkar Could you maybe remove the "Hot Topic" Lable so this overview over all the Hot Topic Issues stays clean and only active Issues are shown there? Thanks!

@cwa-bot cwa-bot bot moved this from Done to ToDo in [CM] cwa-app-ios Dec 1, 2020
@dsarkar dsarkar removed the hot topic 🔥 Hot Topics from the view point of the Community label Dec 1, 2020
@dsarkar dsarkar moved this from ToDo to Done in [CM] cwa-app-ios Dec 1, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
bug Something isn't working mirrored-to-jira This item is also tracked internally in JIRA
Projects
Development

No branches or pull requests

6 participants