Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

After upgrade to iOS 13.6 the app is disabled and cannot be re-enabled because region is not supported #911

Closed
JThoennes opened this issue Jul 15, 2020 · 132 comments
Labels
bug Something isn't working mirrored-to-jira This item is also tracked internally in JIRA

Comments

@JThoennes
Copy link

JThoennes commented Jul 15, 2020

Avoid duplicates

  • [x ] Bug is not mentioned in the FAQ
  • [x ] Bug is not already reported in another issue

Describe the bug

Upgrade my iPhone 11 Pro with a now working app to iOS 13.6.
Now the exposure tracking cannot be enabled because the region is not supported.
The app starts in manual mode but cannot be enabled.

Expected behaviour

After the upgrade to iOS 13.6 the app should continue to be enabled and working.

Steps to reproduce the issue

  1. Go to Einstellungen / Datenschutz / Health
  2. COVID-19-Begegnungsaufzeichnungen: Aus
  3. Anschalten: Grau: In deiner Region nicht verfügbar

Technical details

  • iOS Version: 13.6
  • Device: iPhone 11 Pro

Possible Fix

EDITED BY ADMIN:
If you aren't able to turn on Exposure Notifications, follow these steps:

  1. Download this configuration profile.
    http://appldnld.apple.com/iOSProfiles/Reset_ExposureNotifications.mobileconfig

  2. Open the Settings->General->Profiles (Profile&Geräteverwaltung) and tap Profile Downloaded.

  3. Tap Install in the upper-right corner, then follow the
    on screen instructions.

  4. Reboot your iPhone to complete the installation.

  5. Turn on Exposure Logging in the Settings app.
    EDITED BY ADMIN

Additional context

This is really a show-stopper. The app stops working completely.


Internal Tracking ID: EXPOSUREAPP-1814

@JThoennes JThoennes added the bug Something isn't working label Jul 15, 2020
@Tho-Mat
Copy link

Tho-Mat commented Jul 16, 2020

After i read your message i did the following:

  1. Close CWA
  2. Disable "Bewegungsaufzeichnungen" in
    Einstellungen, Datenschutz, Health, COVID-19-Bewegungsaufzeichnungen
  3. Update to 13.6
  4. Enable "Bewegungsaufzeichnungen"
  5. Start CWA to check.
    => CWA running and aktiv
    (I had installed 1.0.7(0) )

@Heavy02011
Copy link

Heavy02011 commented Jul 16, 2020

I‘m having the same problem.
Further steps to fix:

  1. deleted app
  2. reinstallation
  3. „Risiko-Ermittlung“ can not be activated.
    The App is worthless in this state. The switch button can not be operated to active "Risikoermittlung"

@Heavy02011
Copy link

Heavy02011 commented Jul 16, 2020

D5BE447E-B532-4205-ABB8-4984BA38B457
2406EBD9-924C-4067-97EB-37EC5BD7104B

@rheid
Copy link

rheid commented Jul 16, 2020

I have the same behavior this morning on my iPhone after the update from 13.6.

screen-2020-07-16-83156

screen-2020-07-16-83153

@SebastianWolf-SAP
Copy link
Member

SebastianWolf-SAP commented Jul 16, 2020

Thanks for the report. We couldn't reproduce this issue so far on our devices with iOS 13.6, but this will definitely be investigated. We'll let you know once there is an update.

Mit freundlichen Grüßen/Best regards,
SW
Corona Warn-App Open Source Team

@androthan
Copy link

androthan commented Jul 16, 2020

Hello,
I'm facing the same issue as described here with my device after upgrading to iOS 13.6 today. Already called the hotline, they took notes but didn't know about the issue. Everything worked fine with iOS 13.5.

CWA version: 1.0.7
iOS version: 13.6 (17G68)
Device: iPhone XR (A2105)

My provider: Drillisch, o2-de -- real SIM, not an eSIM
Location: Passau, Germany
Default language: English before upgrading, switched to German as an attempt to fix it

Things I tried:

  • rebooted phone several times
  • reselected "Germany" as my region in settings
  • reinserted my SIM card (German number & contract)
  • background refresh is enabled
  • install the Italian app ("Immuni"), which is also unable to access the exposure API (I kept the CWA parallel)

IMG_1702

It renders the app/exposure notification framework useless.

Best regards

jg

@jwildeboer
Copy link

jwildeboer commented Jul 16, 2020

FTR - on both my iPhones (11 and SE 2016), both running wit English as default language, I had no problems with the App after updating to 13.6.

@Heavy02011
Copy link

Heavy02011 commented Jul 16, 2020

BBC4D608-C206-42B1-8469-8DBC1442A6C5

@JThoennes
Copy link
Author

JThoennes commented Jul 16, 2020

To all which upgraded to iOS 13.6.
Please report your mobile network provider and your location together with working / not working. And default language.

Maybe we can find a pattern.

My provider: Fonic / o2 Network
Location: Aachen
Default language: German
Not working after upgrade.

@seetiger2000
Copy link

seetiger2000 commented Jul 16, 2020

Same problem here since ios13.6
AD9BEABB-CD95-485F-AB1A-8C438A280309
E262809E-CA89-4079-AD0D-4581C5EE453B

Provider deutsche Telekom
Default language German

@m-arx
Copy link

m-arx commented Jul 16, 2020

My provider: Telekom.de
Location: Karlsruhe, Germany
Device: iPhone X
CWA: 1.0.7
Default language: English
Not working after upgrade.

@sebago2000
Copy link

sebago2000 commented Jul 16, 2020

My provider: 1&1, Network O2
Location: Weilheim i. OB, Germany
Device: iPhone SE 2Gen
CWA: 1.0.7
Default Language: German, changed to English as an attempt to fix it
Not working after upgrade

@Heavy02011
Copy link

Heavy02011 commented Jul 16, 2020

My provider: T-Mobile
Location: Stuttgart
Default language: German
Not working after upgrade.

@jwildeboer
Copy link

jwildeboer commented Jul 16, 2020

My provider: Telekom.de and Vodafone
Location: Munich, Germany
Device: iPhone 11 (Vodafone) and SE 1st gen (Telekom)
CWA: 1.0.7 on both.
Default language: English on both.
Everything working after upgrade.

@jwildeboer
Copy link

jwildeboer commented Jul 16, 2020

Steps I would take to try to reactivate tracking:

  • go into flight mode
  • force end CWA
  • leave flight mode (so force new booking into mobile network)
  • check settings to see if COVID-19 tracking becomes available.

If that doesn't work:

  • go into flight mode.
  • switch device off.
  • Power on again
  • deactivate flight mode
  • check settings to see if COVID-19 tracking becomes available

Final measures:

  • delete app
  • power cycle device
  • install app

@MarcelStu
Copy link

MarcelStu commented Jul 16, 2020

Same problem here:

My provider: Telekom.de (E-Sim/primary), Vodafone (physical Sim, deactivated since 2 weeks and during this issue)
Location: Frankfurt, Germany
Device: iPhone XS
CWA 1.0.7 (0)
Default language: German
Not working after upgrade

IMG_B4FF795AA178-1
IMG_897B0832495F-1

@haosap
Copy link
Member

haosap commented Jul 16, 2020

Hello,
I'm facing the same issue as described here with my device after upgrading to iOS 13.6 today. Already called the hotline, they took notes but didn't know about the issue. Everything worked fine with iOS 13.5.

CWA version: 1.0.7
iOS version: 13.6 (17G68)
Device: iPhone XR (A2105)

My provider: Drillisch, o2-de
Location: Passau, Germany
Default language: English before upgrading, switched to German as an attempt to fix it

Things I tried:

  • rebooted phone severeal time
  • reselected "Germany" as my region in settings
  • reinserted my SIM card (German number & contract)
  • background refresh is enabled
  • install the Italian app ("Immuni"), which is also unable to access the exposure API (I kept the CWA parallel)

IMG_1702

It renders the app/exposure notification framework useless.

Best regards

jg

Hi @androthan ,
Thanks for testing it. Could you please do us a favor? We cannot see the bug in our dev team, so please try to disable the location service and enable the location service again. Thanks.

@tocotronaut
Copy link

tocotronaut commented Jul 16, 2020

maybe it's a pattern: most affected people have 2 sim-cards in use - so it could be a problem with the integrated eSim.

Can the people only using only one provider tell if they are using an esim Profile?

@seetiger2000
Copy link

seetiger2000 commented Jul 16, 2020

maybe it's a pattern: most affected people have 2 sim-cards in use. It could be a problem with the integrated eSim.

Can the people only using one provider tell if they are using an esim Profile?

I use a eSim for the Apple Watch
iPhone 11
Provider Telekom

@sebago2000
Copy link

sebago2000 commented Jul 16, 2020

maybe it's a pattern: most affected people have 2 sim-cards in use. It could be a problem with the integrated eSim.

Can the people only using one provider tell if they are using an esim Profile?

I can confirm that I have an eSIM in my iPhone SE, which is deactivated, but could be the reason. The provider is Truphone.

@JThoennes
Copy link
Author

JThoennes commented Jul 16, 2020

maybe it's a pattern: most affected people have 2 sim-cards in use - so it could be a problem with the integrated eSim.

Can the people only using only one provider tell if they are using an esim Profile?

I am using a normal SIM though my phone supports eSIM.

@Tho-Mat
Copy link

Tho-Mat commented Jul 16, 2020

I'm using a normal Sim+esim (o2+telekom)
but i did [https://github.com//issues/911#issuecomment-659134174]
and have no problem

@thomasaugsten
Copy link
Member

thomasaugsten commented Jul 16, 2020

Thomas, I sent you a personal mail in order to support you with debugging information.
I didn't receive a mail from you

@JThoennes
Copy link
Author

JThoennes commented Jul 16, 2020

Thomas, I sent you a personal mail in order to support you with debugging information.
I didn't receive a mail from you

Thomas, sent the mail to the provided SAP address again. Grey listing?

@androthan
Copy link

androthan commented Jul 16, 2020

Hi @androthan ,
Thanks for testing it. Could you please do us a favor? We cannot see the bug in our dev team, so please try to disable the location service and enable the location service again. Thanks.

@haosap Tried that now several times, even with some restarts included. Nothing changed. Will send a sysdiagnose like mentioned above.

Addition: I'm not using an eSIM and never was.

@DenisMtfl
Copy link

DenisMtfl commented Jul 16, 2020

I have IOS 14.0 (beta) and CWA in germany ist not working. Only blank screen after app start.

@thomasaugsten
Copy link
Member

thomasaugsten commented Jul 16, 2020

did somebody received this message or can reproduce this message?
image

@JThoennes
Copy link
Author

JThoennes commented Jul 16, 2020

I have IOS 14.0 (beta) and CWA in germany ist not working. Only blank screen after app start.

For iOS 14 people, there is an own bug... ;-)
Pinned issue: #749
@DenisMtfl

@Atti1952
Copy link

Atti1952 commented Aug 5, 2020

Seems to works, we'll find out in the future. Therefore thanx for your effort, I feel safer now.
Unfortunately some serious questions remain:
How come that it took so long?
Why was this failure not shared with the public. Even Apple support wasn't aware of the problem when I called them yesterday and demonstrated the failure of activation? After internal reseach they got back to me and promised to take care of it with 13.6.1. even if not every Iphone with 13.6 was affected, there must be thousands more out there that didn't get any hint. How many of those were able to find this forum, and were able to do the installation process?
Shoudn't the news media and of course the government be aware of this slapstick? Finally it's about health, safety and last not least a substancial amount of money for a small app.

@thomasaugsten
Copy link
Member

thomasaugsten commented Aug 5, 2020

There will be soon a iOS Update available which will fix this state on all affected devices automatically via OTA Update.

@dwarsloeper
Copy link

dwarsloeper commented Aug 5, 2020

Does not work !!

Applied the profile, rebootet iPhone SE, Exposure Notifications can still not be enabled : "Covid-19-Bewegungsaufzeichnungen" -> "In deiner Region nicht verfügbar".
Removed CWA, re-installed again : same problem.

Provider normal SIM : Telekom
Location: Lüneburg, Germany
Region: Germany
Device: iPhone SE (1)
CWA: 1.1.2
IOS 13.6
Default Language: German
Trying to get CWA working since app was launched, but never got it running.
Gray button "Risiko Ermittlung" , could never be enabled, because of "Covid-19-Bewegungsaufzeichnungen" -> "In deiner Region nicht verfügbar".

@thomasaugsten
Copy link
Member

thomasaugsten commented Aug 5, 2020

@dwarsloeper Hi did you ensure to install the profile under Settings->General->Profiles and press install multiple times? Can you please remove the profile and try again?

@dwarsloeper
Copy link

dwarsloeper commented Aug 5, 2020

Hi, yes I did and removed / installed again. Same result .. doesn't work

grafik

When I started the app again , following error popped up :

grafik

Cannot reproduce. Following some screeshots ... which are probably very well known to you.

grafik

grafik

grafik

grafik

Enabled Button ist activated for a second...

grafik

.... the goes off immediately again

grafik

### AND NOW ??

@thomasaugsten
Copy link
Member

thomasaugsten commented Aug 5, 2020

Hi we need more details about the situation on your phone.
Can you contact me directly

@dwarsloeper
Copy link

dwarsloeper commented Aug 5, 2020

sure

@MarcelStu
Copy link

MarcelStu commented Aug 5, 2020

It works now. Thank you 😊

@JimmyBoy4711
Copy link

JimmyBoy4711 commented Aug 5, 2020

If you aren't able to turn on Exposure Notifications, follow these steps:

  1. Download this configuration profile.
    http://appldnld.apple.com/iOSProfiles/Reset_ExposureNotifications.mobileconfig
  2. Open the Settings->General->Profiles (Profile&Geräteverwaltung) and tap Profile Downloaded.
  3. Tap Install in the upper-right corner, then follow the
    on screen instructions.
  4. Reboot your iPhone to complete the installation.
  5. Turn on Exposure Logging in the Settings app.

Works, perfekt! Thx!!!

@J1ppY
Copy link

J1ppY commented Aug 5, 2020

The profile worked fine for me. But I had to re-install the app first to reactivate the tracking again!

However thanks for your effort!

@tiwdi
Copy link

tiwdi commented Aug 6, 2020

The profile worked! Thank you for your efforts!

@stecampe
Copy link

stecampe commented Aug 8, 2020

iPhone SE 1.G (iOS 13.6.,App Version 1.1.2)Riskidentification still doesn't work. The request: Activate risk identification! But it's already activated. Background-updates never worked!I always had to make the updates manually!The protocol shows the last entry when I updated manuallyimage

@thomasaugsten
Copy link
Member

thomasaugsten commented Aug 8, 2020

@stecampe the background app refresh is activated in your iOS?
Einstellungen->Allgemein->Hintergrundaktualisierung ?

@stecampe
Copy link

stecampe commented Aug 8, 2020

@stecampe
Copy link

stecampe commented Aug 8, 2020

@Thisi-3307
Copy link

Thisi-3307 commented Aug 12, 2020

Hi there - on the described preliminary fix- this dies not work on my iPhone (11 pro Max). I can’t even load the configuration profile. Any thoughts how to fix? Thx

@thomasaugsten
Copy link
Member

thomasaugsten commented Aug 13, 2020

Apple released 13.6.1 this release should solve the issue for all devices. Please try to upgrade your OS.

@Thisi-3307
Copy link

Thisi-3307 commented Aug 13, 2020

This update to iOS 13.6.1 on my iPhone fixed the issue. 😀
Thx

@stecampe
Copy link

stecampe commented Aug 13, 2020

@Beiden1984
Copy link

Beiden1984 commented Aug 15, 2020

With ios Update 13.6.1 the problem is solved.

@Alexcirlan
Copy link

Alexcirlan commented Aug 19, 2020

Problem and solution on iOS14 beta 5

After installing beta5 Corona-Warn-app stopped working with “not available in your region” error.

This was fixed by going on iPhone settings > exposure notification > set active region

There I selected Germany (you can add even more).

And then it works again.
224DA356-7A2B-47FD-BA51-F773F022BCCF
C6000221-BCA5-427F-BB11-43E72DAA59C9

@tkowark
Copy link
Member

tkowark commented Aug 19, 2020

This issues seems to now be reliably solved with iOS 13.6.1. Thank you all for your input and your patience while this was sorted out. In case it reappears on a different iOS Version (e.g., with the release of iOS 14 (the release version)), please open a new issue.

@yusri1094
Copy link

yusri1094 commented Oct 14, 2020

How i want to upgrade ios 12.4.8

@tocotronaut
Copy link

tocotronaut commented Oct 15, 2020

How i want to upgrade ios 12.4.8

if you have 12.4.8 your device is probabyl too Old to recieve iOS13.
So you may need a new device to use the Corona-Tracking Feature.

otherwise Try This:
Go to Settings > General > Software Update.
Tap Download and Install.

@stecampe
Copy link

stecampe commented Oct 15, 2020

@tocotronaut
Copy link

tocotronaut commented Oct 15, 2020

iOS 12 is generally not supported by Corona-Warn-App. You need! iOS 13 or later.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
bug Something isn't working mirrored-to-jira This item is also tracked internally in JIRA
Projects
None yet
Development

No branches or pull requests