Permalink
Find file
Fetching contributors…
Cannot retrieve contributors at this time
116 lines (109 sloc) 2.51 KB
--- !ruby/object:Gem::Specification
name: acts_as_current
version: !ruby/object:Gem::Version
hash: 23
prerelease: false
segments:
- 1
- 0
- 0
version: 1.0.0
platform: ruby
authors:
- Coroutine
- John Dugan
autorequire:
bindir: bin
cert_chain: []
date: 2010-10-10 00:00:00 -05:00
default_executable:
dependencies:
- !ruby/object:Gem::Dependency
name: activerecord
prerelease: false
requirement: &id001 !ruby/object:Gem::Requirement
none: false
requirements:
- - ">="
- !ruby/object:Gem::Version
hash: 3
segments:
- 0
version: "0"
type: :runtime
version_requirements: *id001
- !ruby/object:Gem::Dependency
name: activesupport
prerelease: false
requirement: &id002 !ruby/object:Gem::Requirement
none: false
requirements:
- - ">="
- !ruby/object:Gem::Version
hash: 3
segments:
- 0
version: "0"
type: :development
version_requirements: *id002
description: This acts_as extension modifies ActiveRecord classes so they can carry a reference to the instance defined as current for the given request. The library is particularly useful for providing the authenticated user object to models.
email: gem@coroutine.com
executables: []
extensions: []
extra_rdoc_files:
- README.rdoc
files:
- .gitignore
- .specification
- MIT-LICENSE
- README.rdoc
- Rakefile
- VERSION
- acts_as_current.gemspec
- init.rb
- lib/acts_as_current.rb
- lib/acts_as_current/base.rb
- lib/acts_as_current/class_methods.rb
- lib/acts_as_current/instance_methods.rb
- rails/init.rb
- test/acts_as_current/base_test.rb
- test/acts_as_current/simple_test.rb
- test/acts_as_current/sti_test.rb
- test/test_helper.rb
has_rdoc: true
homepage: http://github.com/coroutine/acts_as_current
licenses: []
post_install_message:
rdoc_options:
- --charset=UTF-8
require_paths:
- lib
required_ruby_version: !ruby/object:Gem::Requirement
none: false
requirements:
- - ">="
- !ruby/object:Gem::Version
hash: 3
segments:
- 0
version: "0"
required_rubygems_version: !ruby/object:Gem::Requirement
none: false
requirements:
- - ">="
- !ruby/object:Gem::Version
hash: 3
segments:
- 0
version: "0"
requirements: []
rubyforge_project:
rubygems_version: 1.3.7
signing_key:
specification_version: 3
summary: Gem version of acts_as_current Rails plugin.
test_files:
- test/acts_as_current/base_test.rb
- test/acts_as_current/simple_test.rb
- test/acts_as_current/sti_test.rb
- test/test_helper.rb