Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse code

Release 6.50

git-svn-id: http://svn.schwern.org/repos/CPAN/ExtUtils-MakeMaker/trunk@4375 8151f2b9-fde8-0310-94fd-f048d12aab9e
  • Loading branch information...
commit 6249953106ccceca1e80670534e44322d151159f 1 parent a6e4369
Michael G. Schwern schwern authored

Showing 29 changed files with 29 additions and 29 deletions. Show diff stats Hide diff stats

  1. +1 1  Changes
  2. +1 1  lib/ExtUtils/Command/MM.pm
  3. +1 1  lib/ExtUtils/Liblist.pm
  4. +1 1  lib/ExtUtils/Liblist/Kid.pm
  5. +1 1  lib/ExtUtils/MM.pm
  6. +1 1  lib/ExtUtils/MM_AIX.pm
  7. +1 1  lib/ExtUtils/MM_Any.pm
  8. +1 1  lib/ExtUtils/MM_BeOS.pm
  9. +1 1  lib/ExtUtils/MM_Cygwin.pm
  10. +1 1  lib/ExtUtils/MM_DOS.pm
  11. +1 1  lib/ExtUtils/MM_Darwin.pm
  12. +1 1  lib/ExtUtils/MM_MacOS.pm
  13. +1 1  lib/ExtUtils/MM_NW5.pm
  14. +1 1  lib/ExtUtils/MM_OS2.pm
  15. +1 1  lib/ExtUtils/MM_QNX.pm
  16. +1 1  lib/ExtUtils/MM_UWIN.pm
  17. +1 1  lib/ExtUtils/MM_Unix.pm
  18. +1 1  lib/ExtUtils/MM_VMS.pm
  19. +1 1  lib/ExtUtils/MM_VOS.pm
  20. +1 1  lib/ExtUtils/MM_Win32.pm
  21. +1 1  lib/ExtUtils/MM_Win95.pm
  22. +1 1  lib/ExtUtils/MY.pm
  23. +1 1  lib/ExtUtils/MakeMaker.pm
  24. +1 1  lib/ExtUtils/MakeMaker/Config.pm
  25. +1 1  lib/ExtUtils/MakeMaker/bytes.pm
  26. +1 1  lib/ExtUtils/MakeMaker/vmsish.pm
  27. +1 1  lib/ExtUtils/Mkbootstrap.pm
  28. +1 1  lib/ExtUtils/Mksymlists.pm
  29. +1 1  lib/ExtUtils/testlib.pm
2  Changes
... ... @@ -1,4 +1,4 @@
1   -6.49_02
  1 +6.50 Sun Mar 22 12:28:06 PDT 2009
2 2 Windows
3 3 * Remove the special checks for compilers that need a "manifest". Instead,
4 4 the code will just be a no-op if there's no manifest. Or something.
2  lib/ExtUtils/Command/MM.pm
@@ -10,7 +10,7 @@ our @ISA = qw(Exporter);
10 10
11 11 our @EXPORT = qw(test_harness pod2man perllocal_install uninstall
12 12 warn_if_old_packlist);
13   -our $VERSION = '6.49_01';
  13 +our $VERSION = '6.50';
14 14
15 15 my $Is_VMS = $^O eq 'VMS';
16 16
2  lib/ExtUtils/Liblist.pm
@@ -2,7 +2,7 @@ package ExtUtils::Liblist;
2 2
3 3 use strict;
4 4
5   -our $VERSION = '6.49_01';
  5 +our $VERSION = '6.50';
6 6
7 7 use File::Spec;
8 8 require ExtUtils::Liblist::Kid;
2  lib/ExtUtils/Liblist/Kid.pm
@@ -9,7 +9,7 @@ use 5.006;
9 9 # Broken out of MakeMaker from version 4.11
10 10
11 11 use strict;
12   -our $VERSION = 6.49_01;
  12 +our $VERSION = 6.50;
13 13
14 14 use Config;
15 15 use Cwd 'cwd';
2  lib/ExtUtils/MM.pm
@@ -3,7 +3,7 @@ package ExtUtils::MM;
3 3 use strict;
4 4 use ExtUtils::MakeMaker::Config;
5 5
6   -our $VERSION = '6.49_01';
  6 +our $VERSION = '6.50';
7 7
8 8 require ExtUtils::Liblist;
9 9 require ExtUtils::MakeMaker;
2  lib/ExtUtils/MM_AIX.pm
... ... @@ -1,7 +1,7 @@
1 1 package ExtUtils::MM_AIX;
2 2
3 3 use strict;
4   -our $VERSION = '6.49_01';
  4 +our $VERSION = '6.50';
5 5
6 6 require ExtUtils::MM_Unix;
7 7 our @ISA = qw(ExtUtils::MM_Unix);
2  lib/ExtUtils/MM_Any.pm
... ... @@ -1,7 +1,7 @@
1 1 package ExtUtils::MM_Any;
2 2
3 3 use strict;
4   -our $VERSION = '6.49_01';
  4 +our $VERSION = '6.50';
5 5
6 6 use Carp;
7 7 use File::Spec;
2  lib/ExtUtils/MM_BeOS.pm
@@ -26,7 +26,7 @@ require ExtUtils::MM_Any;
26 26 require ExtUtils::MM_Unix;
27 27
28 28 our @ISA = qw( ExtUtils::MM_Any ExtUtils::MM_Unix );
29   -our $VERSION = '6.49_01';
  29 +our $VERSION = '6.50';
30 30
31 31
32 32 =item os_flavor
2  lib/ExtUtils/MM_Cygwin.pm
@@ -9,7 +9,7 @@ require ExtUtils::MM_Any;
9 9 require ExtUtils::MM_Unix;
10 10 our @ISA = qw( ExtUtils::MM_Any ExtUtils::MM_Unix );
11 11
12   -our $VERSION = '6.49_01';
  12 +our $VERSION = '6.50';
13 13
14 14
15 15 =head1 NAME
2  lib/ExtUtils/MM_DOS.pm
@@ -2,7 +2,7 @@ package ExtUtils::MM_DOS;
2 2
3 3 use strict;
4 4
5   -our $VERSION = 6.49_01;
  5 +our $VERSION = 6.50;
6 6
7 7 require ExtUtils::MM_Any;
8 8 require ExtUtils::MM_Unix;
2  lib/ExtUtils/MM_Darwin.pm
@@ -7,7 +7,7 @@ BEGIN {
7 7 our @ISA = qw( ExtUtils::MM_Unix );
8 8 }
9 9
10   -our $VERSION = '6.49_01';
  10 +our $VERSION = '6.50';
11 11
12 12
13 13 =head1 NAME
2  lib/ExtUtils/MM_MacOS.pm
@@ -2,7 +2,7 @@ package ExtUtils::MM_MacOS;
2 2
3 3 use strict;
4 4
5   -our $VERSION = 6.49_01;
  5 +our $VERSION = 6.50;
6 6
7 7 sub new {
8 8 die <<'UNSUPPORTED';
2  lib/ExtUtils/MM_NW5.pm
@@ -22,7 +22,7 @@ use strict;
22 22 use ExtUtils::MakeMaker::Config;
23 23 use File::Basename;
24 24
25   -our $VERSION = '6.49_01';
  25 +our $VERSION = '6.50';
26 26
27 27 require ExtUtils::MM_Win32;
28 28 our @ISA = qw(ExtUtils::MM_Win32);
2  lib/ExtUtils/MM_OS2.pm
@@ -5,7 +5,7 @@ use strict;
5 5 use ExtUtils::MakeMaker qw(neatvalue);
6 6 use File::Spec;
7 7
8   -our $VERSION = '6.49_01';
  8 +our $VERSION = '6.50';
9 9
10 10 require ExtUtils::MM_Any;
11 11 require ExtUtils::MM_Unix;
2  lib/ExtUtils/MM_QNX.pm
... ... @@ -1,7 +1,7 @@
1 1 package ExtUtils::MM_QNX;
2 2
3 3 use strict;
4   -our $VERSION = '6.49_01';
  4 +our $VERSION = '6.50';
5 5
6 6 require ExtUtils::MM_Unix;
7 7 our @ISA = qw(ExtUtils::MM_Unix);
2  lib/ExtUtils/MM_UWIN.pm
... ... @@ -1,7 +1,7 @@
1 1 package ExtUtils::MM_UWIN;
2 2
3 3 use strict;
4   -our $VERSION = 6.49_01;
  4 +our $VERSION = 6.50;
5 5
6 6 require ExtUtils::MM_Unix;
7 7 our @ISA = qw(ExtUtils::MM_Unix);
2  lib/ExtUtils/MM_Unix.pm
@@ -15,7 +15,7 @@ use ExtUtils::MakeMaker qw($Verbose neatvalue);
15 15
16 16 # If we make $VERSION an our variable parse_version() breaks
17 17 use vars qw($VERSION);
18   -$VERSION = '6.49_01';
  18 +$VERSION = '6.50';
19 19
20 20 require ExtUtils::MM_Any;
21 21 our @ISA = qw(ExtUtils::MM_Any);
2  lib/ExtUtils/MM_VMS.pm
@@ -15,7 +15,7 @@ BEGIN {
15 15
16 16 use File::Basename;
17 17
18   -our $VERSION = '6.49_01';
  18 +our $VERSION = '6.50';
19 19
20 20 require ExtUtils::MM_Any;
21 21 require ExtUtils::MM_Unix;
2  lib/ExtUtils/MM_VOS.pm
... ... @@ -1,7 +1,7 @@
1 1 package ExtUtils::MM_VOS;
2 2
3 3 use strict;
4   -our $VERSION = '6.49_01';
  4 +our $VERSION = '6.50';
5 5
6 6 require ExtUtils::MM_Unix;
7 7 our @ISA = qw(ExtUtils::MM_Unix);
2  lib/ExtUtils/MM_Win32.pm
@@ -27,7 +27,7 @@ use ExtUtils::MakeMaker qw( neatvalue );
27 27 require ExtUtils::MM_Any;
28 28 require ExtUtils::MM_Unix;
29 29 our @ISA = qw( ExtUtils::MM_Any ExtUtils::MM_Unix );
30   -our $VERSION = '6.49_01';
  30 +our $VERSION = '6.50';
31 31
32 32 $ENV{EMXSHELL} = 'sh'; # to run `commands`
33 33
2  lib/ExtUtils/MM_Win95.pm
@@ -2,7 +2,7 @@ package ExtUtils::MM_Win95;
2 2
3 3 use strict;
4 4
5   -our $VERSION = '6.49_01';
  5 +our $VERSION = '6.50';
6 6
7 7 require ExtUtils::MM_Win32;
8 8 our @ISA = qw(ExtUtils::MM_Win32);
2  lib/ExtUtils/MY.pm
@@ -3,7 +3,7 @@ package ExtUtils::MY;
3 3 use strict;
4 4 require ExtUtils::MM;
5 5
6   -our $VERSION = 6.49_01;
  6 +our $VERSION = 6.50;
7 7 our @ISA = qw(ExtUtils::MM);
8 8
9 9 {
2  lib/ExtUtils/MakeMaker.pm
@@ -18,7 +18,7 @@ our @Overridable;
18 18 my @Prepend_parent;
19 19 my %Recognized_Att_Keys;
20 20
21   -our $VERSION = '6.49_01';
  21 +our $VERSION = '6.50';
22 22
23 23 # Emulate something resembling CVS $Revision$
24 24 (our $Revision = $VERSION) =~ s{_}{};
2  lib/ExtUtils/MakeMaker/Config.pm
@@ -2,7 +2,7 @@ package ExtUtils::MakeMaker::Config;
2 2
3 3 use strict;
4 4
5   -our $VERSION = '6.49_01';
  5 +our $VERSION = '6.50';
6 6
7 7 use Config ();
8 8
2  lib/ExtUtils/MakeMaker/bytes.pm
@@ -2,7 +2,7 @@ package ExtUtils::MakeMaker::bytes;
2 2
3 3 use strict;
4 4
5   -our $VERSION = 6.49_01;
  5 +our $VERSION = 6.50;
6 6
7 7 my $Have_Bytes = eval { require bytes; 1; };
8 8
2  lib/ExtUtils/MakeMaker/vmsish.pm
@@ -2,7 +2,7 @@ package ExtUtils::MakeMaker::vmsish;
2 2
3 3 use strict;
4 4
5   -our $VERSION = 6.49_01;
  5 +our $VERSION = 6.50;
6 6
7 7 my $IsVMS = $^O eq 'VMS';
8 8
2  lib/ExtUtils/Mkbootstrap.pm
@@ -3,7 +3,7 @@ package ExtUtils::Mkbootstrap;
3 3 # There's just too much Dynaloader incest here to turn on strict vars.
4 4 use strict 'refs';
5 5
6   -our $VERSION = '6.49_01';
  6 +our $VERSION = '6.50';
7 7
8 8 require Exporter;
9 9 our @ISA = ('Exporter');
2  lib/ExtUtils/Mksymlists.pm
@@ -10,7 +10,7 @@ use Config;
10 10
11 11 our @ISA = qw(Exporter);
12 12 our @EXPORT = qw(&Mksymlists);
13   -our $VERSION = '6.49_01';
  13 +our $VERSION = '6.50';
14 14
15 15 sub Mksymlists {
16 16 my(%spec) = @_;
2  lib/ExtUtils/testlib.pm
@@ -3,7 +3,7 @@ package ExtUtils::testlib;
3 3 use strict;
4 4 use warnings;
5 5
6   -our $VERSION = 6.49_01;
  6 +our $VERSION = 6.50;
7 7
8 8 use Cwd;
9 9 use File::Spec;

0 comments on commit 6249953

Please sign in to comment.
Something went wrong with that request. Please try again.