Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Update multi_json dependency so we can use any 1.x version. #85

merged 1 commit into from Jul 31, 2012


None yet
10 participants

dgraham commented Apr 24, 2012

The couchrest gem uses a stricter multi_json dependency than most other libraries. It only allows 1.0.x versions, while other users of multi_json (activesupport, execjs, uglifier, sprockets, etc.) allow any 1.x version.

This causes the following gem conflict when multiple versions of multi_json are installed:
Unable to activate couchrest-1.1.2, because multi_json-1.2.0 conflicts with multi_json (~> 1.0.0)

This is also causing this problem:

Can we update the dependency on multi_json so it plays nicely with other gems?

javierg commented May 7, 2012



langalex commented May 17, 2012



ghost commented May 23, 2012



rb2k commented Jun 7, 2012




swills commented Jul 23, 2012

Please, I beg you, update the dependency.


@samlown samlown added a commit that referenced this pull request Jul 31, 2012

@samlown samlown Merge pull request #85 from dgraham/update-json-dependency
Update multi_json dependency so we can use any 1.x version.

@samlown samlown merged commit 1f7001b into couchrest:master Jul 31, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment