Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Branch: master
Fetching contributors…

Cannot retrieve contributors at this time

364 lines (323 sloc) 11.408 kB
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
<modelVersion>4.0.0</modelVersion>
<groupId>org.codehaus.enunciate</groupId>
<artifactId>enunciate-parent</artifactId>
<packaging>pom</packaging>
<version>1.26-SNAPSHOT</version>
<name>Enunciate - Parent</name>
<modules>
<module>core-annotations</module>
<module>core-rt</module>
<module>core</module>
<module>maven-enunciate-slim-plugin</module>
<module>xml</module>
<module>jaxws-support</module>
<module>jaxws-ri-rt</module>
<module>jaxws-ri</module>
<module>jersey-rt</module>
<module>jersey</module>
<module>java-client</module>
<module>c</module>
<module>obj-c</module>
<module>csharp</module>
<module>ruby</module>
<module>docs</module>
<module>amf-rt</module>
<module>amf</module>
<module>gwt-rt</module>
<module>gwt</module>
<module>top-rt</module>
<module>top</module>
<module>spring-jaxws-rt</module>
<module>spring-app-rt</module>
<module>spring3-app-rt</module>
<module>spring-app</module>
<module>cxf-rt</module>
<module>cxf</module>
<module>jboss-rt</module>
<module>jboss</module>
<module>maven-enunciate-plugin</module>
<module>maven-enunciate-spring-plugin</module>
<module>maven-enunciate-cxf-plugin</module>
<module>maven-enunciate-jboss-plugin</module>
<module>enunciate-simple-archetype</module>
<module>integration-tests</module>
</modules>
<build>
<plugins>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-compiler-plugin</artifactId>
<configuration>
<source>1.5</source>
<target>1.5</target>
</configuration>
</plugin>
<plugin>
<artifactId>maven-idea-plugin</artifactId>
<version>2.3-atlassian-1</version>
<configuration>
<downloadSources>true</downloadSources>
<exclude>cargo-installs,target/tomcat5x,target/war</exclude>
</configuration>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-eclipse-plugin</artifactId>
<version>2.7</version>
<configuration>
<downloadJavadocs>true</downloadJavadocs>
<downloadSources>true</downloadSources>
<useProjectReferences>false</useProjectReferences>
<classpathContainers>
<classpathContainer>org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/J2SE-1.5</classpathContainer>
</classpathContainers>
<additionalConfig>
<file>
<name>.settings/org.eclipse.core.resources.prefs</name>
<content>
<![CDATA[eclipse.preferences.version=1${line.separator}encoding/<project>=${project.build.sourceEncoding}${line.separator}]]>
</content>
</file>
</additionalConfig>
</configuration>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-source-plugin</artifactId>
<executions>
<execution>
<id>attach-sources</id>
<phase>package</phase>
<goals>
<goal>jar</goal>
</goals>
</execution>
</executions>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-release-plugin</artifactId>
<configuration>
<tagBase>https://svn.codehaus.org/enunciate/tags/</tagBase>
</configuration>
</plugin>
<plugin>
<groupId>org.codehaus.mojo</groupId>
<artifactId>animal-sniffer-maven-plugin</artifactId>
<version>1.7</version>
<configuration>
<signature>
<groupId>org.codehaus.mojo.signature</groupId>
<artifactId>java15</artifactId>
<version>1.0</version>
</signature>
</configuration>
<executions>
<execution>
<id>enforce-java-5</id>
<phase>test</phase>
<goals>
<goal>check</goal>
</goals>
<configuration>
<ignores>
<!--allow references to JAXB, JAX-WS, etc. since they can be referenced as external dependencies for Java 5-->
<ignore>javax.xml.bind.*</ignore>
<ignore>javax.xml.ws.*</ignore>
<ignore>javax.xml.stream.*</ignore>
<ignore>javax.jws.*</ignore>
<ignore>javax.activation.*</ignore>
<!--allow dependencies on internal Sun APIs for now. Someday fix these: http://jira.codehaus.org/browse/ENUNCIATE-437. -->
<ignore>sun.misc.*</ignore>
<ignore>com.sun.org.apache.xalan.internal.xsltc.trax.*</ignore>
</ignores>
</configuration>
</execution>
</executions>
</plugin>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-enforcer-plugin</artifactId>
<executions>
<execution>
<id>require.mono.for.deploy</id>
<phase>deploy</phase>
<goals>
<goal>enforce</goal>
</goals>
<configuration>
<rules>
<requireProperty>
<property>gmcs.executable</property>
<message>In order to deploy Enunciate, you must have Mono installed.
First install Mono for your platform. (See http://mono-project.com/Start and note there's a Windows version of Mono, too.)
Then, define a profile in your settings.xml file that defines the path to your 'gmcs' executable in the property 'gmcs.executable'.
</message>
</requireProperty>
</rules>
</configuration>
</execution>
</executions>
</plugin>
</plugins>
<pluginManagement>
<plugins>
<plugin>
<groupId>org.codehaus.mojo</groupId>
<artifactId>build-helper-maven-plugin</artifactId>
<version>1.5</version>
</plugin>
</plugins>
</pluginManagement>
<extensions>
<!--see http://jira.codehaus.org/browse/MNG-4301
bug in maven 2.2: invalid checksums-->
<extension>
<groupId>org.apache.maven.wagon</groupId>
<artifactId>wagon-webdav</artifactId>
<version>1.0-beta-2</version>
</extension>
</extensions>
</build>
<reporting>
<plugins>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-surefire-report-plugin</artifactId>
</plugin>
</plugins>
</reporting>
<scm>
<connection>scm:git:git@github.com:stoicflame/enunciate.git</connection>
<url>scm:git:git@github.com:stoicflame/enunciate.git</url>
<developerConnection>scm:git:git@github.com:stoicflame/enunciate.git</developerConnection>
</scm>
<dependencies>
<dependency>
<groupId>org.easymock</groupId>
<artifactId>easymock</artifactId>
<version>2.2</version>
<scope>test</scope>
</dependency>
<dependency>
<groupId>junit</groupId>
<artifactId>junit</artifactId>
<version>3.8.1</version>
<scope>test</scope>
</dependency>
</dependencies>
<properties>
<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
<project.reporting.outputEncoding>UTF-8</project.reporting.outputEncoding>
<jersey.version>1.11</jersey.version>
<jackson.version>1.9.3</jackson.version>
<donations.url>https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&amp;hosted_button_id=HXSXBXUT63RCG</donations.url>
</properties>
<dependencyManagement>
<dependencies>
<dependency>
<groupId>cglib</groupId>
<artifactId>cglib-nodep</artifactId>
<version>2.2.2</version>
</dependency>
<dependency>
<groupId>com.sun.jersey</groupId>
<artifactId>jersey-server</artifactId>
<version>${jersey.version}</version>
</dependency>
<dependency>
<groupId>com.sun.xml.bind</groupId>
<artifactId>jaxb-impl</artifactId>
<version>2.2.3</version>
<exclusions>
<!--exclude jaxb-api because it ships with the jdk-->
<exclusion>
<groupId>javax.xml.bind</groupId>
<artifactId>jaxb-api</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>commons-logging</groupId>
<artifactId>commons-logging</artifactId>
<version>1.1.1</version>
</dependency>
<dependency>
<groupId>javax.annotation</groupId>
<artifactId>jsr250-api</artifactId>
<version>1.0</version>
</dependency>
<dependency>
<groupId>javax.mail</groupId>
<artifactId>mail</artifactId>
<version>1.4.4</version>
</dependency>
<dependency>
<groupId>javax.ws.rs</groupId>
<artifactId>jsr311-api</artifactId>
<version>1.1.1</version>
</dependency>
<dependency>
<groupId>javax.servlet</groupId>
<artifactId>servlet-api</artifactId>
<version>2.3</version>
</dependency>
<dependency>
<groupId>org.jdom</groupId>
<artifactId>jdom</artifactId>
<version>1.1.2</version>
<exclusions>
<exclusion>
<groupId>jaxen</groupId>
<artifactId>jaxen</artifactId>
</exclusion>
</exclusions>
</dependency>
<dependency>
<groupId>joda-time</groupId>
<artifactId>joda-time</artifactId>
<version>1.6.2</version>
</dependency>
<dependency>
<groupId>log4j</groupId>
<artifactId>log4j</artifactId>
<version>1.2.16</version>
</dependency>
<dependency>
<groupId>org.codehaus.jackson</groupId>
<artifactId>jackson-mapper-asl</artifactId>
<version>${jackson.version}</version>
</dependency>
<dependency>
<groupId>org.codehaus.jackson</groupId>
<artifactId>jackson-jaxrs</artifactId>
<version>${jackson.version}</version>
</dependency>
<dependency>
<groupId>org.codehaus.jackson</groupId>
<artifactId>jackson-xc</artifactId>
<version>${jackson.version}</version>
</dependency>
</dependencies>
</dependencyManagement>
<pluginRepositories>
<pluginRepository>
<id>atlassian</id>
<url>https://maven.atlassian.com/repository/public</url>
</pluginRepository>
</pluginRepositories>
<distributionManagement>
<repository>
<id>codehaus.org</id>
<name>Enunciate Central Repository</name>
<url>dav:https://dav.codehaus.org/repository/enunciate/</url>
</repository>
<snapshotRepository>
<id>codehaus.org</id>
<name>Enunciate Central Development Repository</name>
<url>dav:https://dav.codehaus.org/snapshots.repository/enunciate/</url>
</snapshotRepository>
</distributionManagement>
</project>
Jump to Line
Something went wrong with that request. Please try again.