Permalink
Browse files

add bundle support, add eventmachine to the dependency list.

  • Loading branch information...
1 parent 20d71b2 commit 5e745d710a37281bea66606df69254a111796d3b @cowboyd committed Nov 1, 2010
Showing with 47 additions and 4 deletions.
  1. +2 −0 .bundle/config
  2. +3 −0 Gemfile
  3. +32 −0 Gemfile.lock
  4. +3 −0 Rakefile
  5. +1 −1 lib/rednode.rb
  6. +6 −3 rednode.gemspec
View
@@ -0,0 +1,2 @@
+---
+BUNDLE_DISABLE_SHARED_GEMS: "1"
View
@@ -0,0 +1,3 @@
+source :rubygems
+
+gemspec
View
@@ -0,0 +1,32 @@
+PATH
+ remote: .
+ specs:
+ rednode (0.1.0)
+ eventmachine
+ therubyracer (~> 0.8.0.pre)
+
+GEM
+ remote: http://rubygems.org/
+ specs:
+ diff-lcs (1.1.2)
+ eventmachine (0.12.10)
+ rspec (2.0.1)
+ rspec-core (~> 2.0.1)
+ rspec-expectations (~> 2.0.1)
+ rspec-mocks (~> 2.0.1)
+ rspec-core (2.0.1)
+ rspec-expectations (2.0.1)
+ diff-lcs (>= 1.1.2)
+ rspec-mocks (2.0.1)
+ rspec-core (~> 2.0.1)
+ rspec-expectations (~> 2.0.1)
+ therubyracer (0.8.0.pre2)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ eventmachine
+ rednode!
+ rspec (~> 2.0.0)
+ therubyracer (~> 0.8.0.pre)
View
@@ -1,4 +1,6 @@
require 'rubygems'
+require 'bundler/setup'
+
$:.unshift('./lib')
require 'rednode'
@@ -11,6 +13,7 @@ $gem = Gem::Specification.new do |gem|
gem.homepage = "http://github.com/cowboyd/rednode"
gem.authors = ["Charles Lowell", "Aslak Hellesøy"]
gem.add_dependency "therubyracer", "~> 0.8.0.pre"
+ gem.add_dependency "eventmachine"
gem.add_development_dependency "rspec", "~> 2.0.0"
end
View
@@ -3,7 +3,7 @@
require 'v8'
module Rednode
- VERSION = '0.1.0'
+ VERSION = '0.1.1'
NODE_VERSION = '0.2.0'
NODE_HOME = File.expand_path(File.dirname(__FILE__) + '/../ext/node')
require 'rednode/node'
View

Large diffs are not rendered by default.

Oops, something went wrong.

0 comments on commit 5e745d7

Please sign in to comment.