libV8 breaks it all #221

Closed
deesx opened this Issue Dec 20, 2012 · 8 comments

Comments

Projects
None yet
6 participants

deesx commented Dec 20, 2012

Since when the rubyracer requires the libv8 gem to be included in the Gemfile ?

gem "therubyracer", :require => 'v8' breaks.

Then you're told ton add gem 'libv8', '~> 3.11.8' in the gemfile. The bundler takes a 30minutes something to complete, stuck on libv8 99% of the time.

deesx commented Dec 20, 2012

ok…
So I could have thought about it before.

From another deployment that worked very well, I took the version and specified it in the Gemfile :

gem "execjs", "1.4.0"
gem "therubyracer", "0.10.2"

Then, well, it works.

But otherwise, the latest version(s) of the rubyracer are very troublesome.

+1
libv8 is a show stopper.

I spent several hours fighting with therubyracer 0.11 and compiling libv8 on Ubuntu 12.04... Finally found this thread and tried:

gem "execjs", "1.4.0"
gem "therubyracer", "0.10.2"

Worked like a charm, thanks!

kurko commented Dec 31, 2012

Unfortunately, therubyracer 0.10 is segfaulting badly for me (stacktrace https://gist.github.com/4421218). Updating to 0.11 seems impossible due to libv8 (gem install libv8 just hangs)

Owner

cowboyd commented Jan 4, 2013

@kurko it is not hanging, it is compiling v8 which can take anywhere from 2-15 minutes depending on your CPU. I am working on binary version.

I can help compiling binary version, but will need access to your production enviroment.

cowboyd closed this Jan 4, 2013

deesx commented Jan 28, 2013

Issue closed… maybe it takes up to 15 minutes; but in the end it did not worked at all

Collaborator

ignisf commented Jan 28, 2013

@bbnnt which versions of therubyracer and libv8 have you specified in your Gemfile?

Owner

cowboyd commented Jan 28, 2013

Note that there are now binary gems for most popular development and deployment platforms including Linux, OSX and FreeBSD so it may very well be all you need to do is upgrade.

@antw antw added a commit to quintel/etflex that referenced this issue Dec 16, 2013

@antw antw It turns out therubyracer v0.11 is broken with V8. 2e06c7b

@antw antw added a commit to quintel/etflex that referenced this issue Dec 17, 2013

@antw antw It turns out therubyracer v0.11 is broken with V8. 872b2de

@antw antw added a commit to quintel/etflex that referenced this issue Feb 25, 2014

@antw antw It turns out therubyracer v0.11 is broken with V8. 8279782
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment