Since when the rubyracer requires the libv8 gem to be included in the Gemfile ?
gem "therubyracer", :require => 'v8' breaks.
Then you're told ton add gem 'libv8', '~> 3.11.8' in the gemfile. The bundler takes a 30minutes something to complete, stuck on libv8 99% of the time.
So I could have thought about it before.
From another deployment that worked very well, I took the version and specified it in the Gemfile :
gem "execjs", "1.4.0"
gem "therubyracer", "0.10.2"
Then, well, it works.
But otherwise, the latest version(s) of the rubyracer are very troublesome.
libv8 is a show stopper.
I spent several hours fighting with therubyracer 0.11 and compiling libv8 on Ubuntu 12.04... Finally found this thread and tried:
Worked like a charm, thanks!
Unfortunately, therubyracer 0.10 is segfaulting badly for me (stacktrace https://gist.github.com/4421218). Updating to 0.11 seems impossible due to libv8 (gem install libv8 just hangs)
@kurko it is not hanging, it is compiling v8 which can take anywhere from 2-15 minutes depending on your CPU. I am working on binary version.
I can help compiling binary version, but will need access to your production enviroment.
Issue closed… maybe it takes up to 15 minutes; but in the end it did not worked at all
@bbnnt which versions of therubyracer and libv8 have you specified in your Gemfile?
Note that there are now binary gems for most popular development and deployment platforms including Linux, OSX and FreeBSD so it may very well be all you need to do is upgrade.
It turns out therubyracer v0.11 is broken with V8.