0.9.4 Doc for default http::client tag is inconsistent with code #233

Closed
OttoDeLupe opened this Issue May 9, 2013 · 2 comments

Comments

Projects
None yet
2 participants
@OttoDeLupe

_sources/in-depth/http.txt says that:

The default typedef for the HTTP client that is provided uses the
http_default_8bit_udp_resolve tag, and implements HTTP 1.0. The exact
typedef is in the boost::network::http namespace as the following: yada yada yada

But, boost/network/protocol/http/client.hpp defines BOOST_NETWORK_HTTP_CLIENT_DEFAULT_TAG to be tags::http_async_8bit_udp_resolve

Sorry if this isn't enough info, or if I'm reading things incorrectly. This is the first time I've posted a (potential) bug on github.

@deanberris

This comment has been minimized.

Show comment
Hide comment
@deanberris

deanberris May 14, 2013

Member

Yes you are right, this is a bug in the documentation in that part. If you look at the reference documentation though this has been updated:

http://cpp-netlib.org/0.9.4/reference/http_client.html

Member

deanberris commented May 14, 2013

Yes you are right, this is a bug in the documentation in that part. If you look at the reference documentation though this has been updated:

http://cpp-netlib.org/0.9.4/reference/http_client.html

@ghost ghost assigned deanberris Jul 3, 2013

@deanberris

This comment has been minimized.

Show comment
Hide comment
@deanberris

deanberris Jul 3, 2013

Member

This should be updated for 0.10.1.

Member

deanberris commented Jul 3, 2013

This should be updated for 0.10.1.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment