Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Asset thumbnail generator doesn't skip image processing for GIF files (transformGifs) #3110

Closed
skoften opened this issue Jul 18, 2018 · 1 comment

Comments

Projects
None yet
3 participants
@skoften
Copy link

commented Jul 18, 2018

Config item "transformGifs" is ignored when thumbs are generated for an asset in the control/entry panel. So, when uploading a GIF, the processing always runs which causes server time outs.

Craft CMS 3.0.16
PHP 7.0.30

@skoften

This comment has been minimized.

Copy link
Author

commented Sep 13, 2018

Any chance on getting this fixed any time soon? Seems like a quick fix and it's causing lot's of time outs here.

In the meantime I did a fix myself that solves it, but I don't know if it's the right way (new to Craft).

But anyway, here it is;

File: /vendor/craftcms/cms/src/services/Assets.php
Function: getThumbUrl()

Added:

if ($asset->getMimeType() === 'image/gif' && !Craft::$app->getConfig()->getGeneral()->transformGifs) {
  return false;                
}

Cheers.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.