Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Craft doesn't return to active tab after saving content if the tab contains accented character(s) #3923

Closed
benface opened this issue Feb 27, 2019 · 1 comment

Comments

Projects
None yet
2 participants
@benface
Copy link
Contributor

commented Feb 27, 2019

Steps to reproduce

  1. In the field layout editor of any entry type, add 3 tabs with the following titles: "Contenu", "Description", and "Médias". Put at least a field in each tab.
  2. Go to an entry that uses this field layout. Enter some content in the second tab, then do "Save and continue editing". Notice the second tab (Description) is still active when the page is refreshed.
  3. Now move to the third tab (Médias), enter some content, and "Save and continue editing" again.

Expected result: The page is refreshed and the third tab is still active.
Actual result: The page is refreshed and the first tab is now active. It seems to do that for any tab that contains non-ASCII characters in its title.

Additional info

  • Craft version: 3.1.14
  • PHP version: 7.2.13
  • Database driver & version: MySQL 5.7.23
@brandonkelly

This comment has been minimized.

Copy link
Member

commented Feb 27, 2019

Fixed for the next release. Thanks for reporting!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.