Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Required Fields on Assets only are required in Quick Edit #4095

Open
jmcgaha opened this Issue Apr 3, 2019 · 1 comment

Comments

Projects
None yet
2 participants
@jmcgaha
Copy link

commented Apr 3, 2019

Description

I added an alt text field to an asset source and that alt text field is required.
I can upload new files from the assets area or from an entry itself and it never alerts me that the alt text field which is "required" is blank. The only time I can get the validation to occur is if I double click on the asset and get the Quick Edit modal.

So in a sense that field really isn't even required since the validation for it almost never occurs.

Steps to reproduce

  1. Create Asset Source
  2. Add custom field to the asset source and make it required.
  3. Upload new file to that asset source
  4. Confirm no validation was done on the required custom field.

Additional info

  • Craft version: 3.1.20.1
  • PHP version: 7.2
  • Database driver & version:
  • Plugins & versions:
@brandonkelly

This comment has been minimized.

Copy link
Member

commented Apr 5, 2019

Yeah, Craft should be immediately showing a batch-edit screen for each asset you upload, which must be submitted before the uploaded assets are actually saved into the volume.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.