Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Changing a field from Matrix to another fieldtype orphans the matrix table and elements #4736

Open
alexmglover opened this issue Aug 10, 2019 · 2 comments

Comments

@alexmglover
Copy link

commented Aug 10, 2019

Description

I switched a matrix field to a plaintext field (I was actually trying to switch the field because the matrix field wouldn't delete, but that's another story).

I ended up deleting the field as a plaintext field and the matrix table did not delete.

I tried re-creating the field as a matrix and deleting again and the table is still there.

Steps to reproduce

  1. Create a Matrix field.
  2. Switch the Matrix field to a Plaintext field.
  3. Check the database, the matrix table and elements still exist in the database.

Additional info

  • Craft version: 3.2.8
  • PHP version: 7.2
  • Database driver & version: Maria DB

@brandonkelly brandonkelly added this to the 4.0 milestone Aug 11, 2019

@brandonkelly

This comment has been minimized.

Copy link
Member

commented Aug 11, 2019

Yeah this is a known issue which we plan on fixing in Craft 4 alongside some other field refactoring.

@alexmglover

This comment has been minimized.

Copy link
Author

commented Aug 11, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.