Permalink
Browse files

Remove Ruby 1.9 restriction

  • Loading branch information...
1 parent 04da3e5 commit 99cec84709880f7bba55f93a94028c5014c8e902 @dcadenas dcadenas committed Sep 19, 2010
Showing with 4 additions and 7 deletions.
  1. +0 −1 README.rdoc
  2. +0 −1 Rakefile
  3. +4 −5 rankable_graph.gemspec
View
@@ -68,7 +68,6 @@ For more examples please refer to the tests.
== Requirements
-* Ruby 1.9
* {glib2}[http://library.gnome.org/devel/glib/2.22/] >= 2.22.2
== Note on Patches/Pull Requests
View
@@ -12,7 +12,6 @@ begin
gem.authors = ["Daniel Cadenas"]
gem.add_development_dependency "rspec", ">= 1.2.9"
gem.extensions = ["ext/extconf.rb"]
- gem.required_ruby_version = '>= 1.9'
gem.requirements << 'glib2, v2.22.2 or greater'
# gem is a Gem::Specification... see http://www.rubygems.org/read/chapter/20 for additional settings
end
View
@@ -5,11 +5,11 @@
Gem::Specification.new do |s|
s.name = %q{rankable_graph}
- s.version = "0.2.0"
+ s.version = "0.2.1"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Daniel Cadenas"]
- s.date = %q{2010-02-05}
+ s.date = %q{2010-09-19}
s.description = %q{A Ruby Pagerank implementation}
s.email = %q{dev@cuboxsa.com}
s.extensions = ["ext/extconf.rb"]
@@ -35,9 +35,8 @@ Gem::Specification.new do |s|
s.homepage = %q{http://github.com/cubox/rankable_graph}
s.rdoc_options = ["--charset=UTF-8"]
s.require_paths = ["lib"]
- s.required_ruby_version = Gem::Requirement.new(">= 1.9")
s.requirements = ["glib2, v2.22.2 or greater"]
- s.rubygems_version = %q{1.3.5}
+ s.rubygems_version = %q{1.3.7}
s.summary = %q{A Ruby Pagerank implementation}
s.test_files = [
"spec/rankable_graph_spec.rb",
@@ -48,7 +47,7 @@ Gem::Specification.new do |s|
current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 3
- if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
+ if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_development_dependency(%q<rspec>, [">= 1.2.9"])
else
s.add_dependency(%q<rspec>, [">= 1.2.9"])

0 comments on commit 99cec84

Please sign in to comment.