New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[studio] Folder cut and paste does not work (2.5) #1703

Closed
alhambrav opened this Issue Dec 15, 2017 · 4 comments

Comments

@alhambrav
Member

alhambrav commented Dec 15, 2017

Applies to Crafter 2.5.x

Expected behavior

User should be able to cut and paste folders with content

Actual behavior

Folder cut and paste does not work

Steps to reproduce the problem

  • Create a site using the empty bp
  • Create two folders under Home. Right click on Home, select New Folder, name the folder a. Right click on Home again, select New Folder, name the folder b
  • Create content under the two newly created folders, name the page under folder a as foo and name the page under folder b as bar, such that we have a/foo and b/bar

screen shot 2017-12-15 at 1 10 13 pm

  • Right click on folder a and select Cut
  • Right click on folder b and select Paste, notice that folder a has disappeared from the site tree, under the Home folder, but it's also not under folder b

screen shot 2017-12-15 at 1 11 41 pm

  • Refresh your browser. Notice that folder a is back under folder Home

screen shot 2017-12-15 at 1 13 36 pm

Look at the Tomcat log and notice the errors.

Log/stack trace (use https://gist.github.com)

https://gist.github.com/alhambrav/485391d409361565e8404617613d1d97

Specs: version, OS, browser, etc.

OS X, Chrome browser
Crafter CMS 2.5.12

@sumerjabri sumerjabri changed the title from [studio-ui] Folder cut and paste does not work (2.5) to [studio] Folder cut and paste does not work (2.5) Dec 15, 2017

@sumerjabri sumerjabri added this to the Crafter CMS v2.5.14 milestone Dec 15, 2017

@dejan-brkic dejan-brkic added this to In Progress in Crafter CMS v2.5.x Dec 15, 2017

@dejan-brkic

This comment has been minimized.

Show comment
Hide comment
@dejan-brkic
Member

dejan-brkic commented Dec 15, 2017

@dejan-brkic dejan-brkic assigned alhambrav and unassigned dejan-brkic Dec 15, 2017

@dejan-brkic dejan-brkic moved this from In Progress to Testing in Crafter CMS v2.5.x Dec 15, 2017

@alhambrav alhambrav assigned dejan-brkic and unassigned alhambrav Dec 18, 2017

@alhambrav

This comment has been minimized.

Show comment
Hide comment
@alhambrav

alhambrav Dec 18, 2017

Member

Hi! Cut and paste is working, but I see an error message in the Tomcat logs.
Here's the steps I did, which is the same as listed above:

Steps to reproduce

  • Create a site using the empty bp.
  • Under home, create two folders, g and h
  • Create content in each of the newly created folders
  • From the site tree, right click on folder g, then select Cut
  • From the site tree again, right click on folder h, then select Paste
  • The folder and its contents gets cut and pasted, but this error message is in the Tomcat log after cutting and pasting:

https://gist.github.com/alhambrav/2ab211322523a229734a9e4d19a32baa

Member

alhambrav commented Dec 18, 2017

Hi! Cut and paste is working, but I see an error message in the Tomcat logs.
Here's the steps I did, which is the same as listed above:

Steps to reproduce

  • Create a site using the empty bp.
  • Under home, create two folders, g and h
  • Create content in each of the newly created folders
  • From the site tree, right click on folder g, then select Cut
  • From the site tree again, right click on folder h, then select Paste
  • The folder and its contents gets cut and pasted, but this error message is in the Tomcat log after cutting and pasting:

https://gist.github.com/alhambrav/2ab211322523a229734a9e4d19a32baa

@alhambrav alhambrav moved this from Testing to Backlog/Scheduled in Crafter CMS v2.5.x Dec 18, 2017

@dejan-brkic

This comment has been minimized.

Show comment
Hide comment
@dejan-brkic
Member

dejan-brkic commented Dec 18, 2017

@dejan-brkic dejan-brkic moved this from Backlog/Scheduled to Testing in Crafter CMS v2.5.x Dec 18, 2017

@dejan-brkic dejan-brkic assigned alhambrav and unassigned dejan-brkic Dec 18, 2017

@alhambrav

This comment has been minimized.

Show comment
Hide comment
@alhambrav

alhambrav Dec 19, 2017

Member

Verified fixed.

Member

alhambrav commented Dec 19, 2017

Verified fixed.

@alhambrav alhambrav closed this Dec 19, 2017

@alhambrav alhambrav moved this from Testing to Completed in Crafter CMS v2.5.x Dec 22, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment