New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[craftercms] Add support for run test on Internet Explorer (gradlew test does not download the right webdriver.exe when we specify the crafter.testing.browser=ie) #1767

Closed
luishernandezmonge opened this Issue Jan 13, 2018 · 2 comments

Comments

@luishernandezmonge
Member

luishernandezmonge commented Jan 13, 2018

Expected behavior

The IEDriver server should de downloaded from the selenium official page (because MS only have web driver for edge)
http://www.seleniumhq.org/download/

Actual behavior

The test tries to download the web driver executable for the edge case in https://developer.microsoft.com/en-us/microsoft-edge/tools/webdriver/

Steps to reproduce the problem

  • Go to craftercms folder and run the next gradlew commands:
  1. gradlew.bat selfupdate
  2. gradlew.bat init
  3. gradlew.bat update
  4. gradlew.bat build deploy -P”authoring.studio.smtp.port=2525”
  • run the test using the crafter.testing parameter
  1. gradlew.bat test -P"crafter.testing.browser=ie"

Log/stack trace (use https://gist.github.com)

watch the next video (gradlew test): https://www.useloom.com/share/f031f400fc674fecaec21469e3d7e40f

Specs

Version

craftercms 3.0.x

OS

MS Windows 2012 server
MS Windows 10

Browser

IE 11

@sumerjabri sumerjabri added this to Backlog in Crafter CMS v3.0.x via automation Jan 15, 2018

@sumerjabri sumerjabri added this to the Crafter CMS v3.0.5 milestone Jan 15, 2018

@cortiz cortiz assigned luishernandezmonge and unassigned cortiz Feb 5, 2018

@cortiz

This comment has been minimized.

Show comment
Hide comment
@cortiz
Member

cortiz commented Feb 5, 2018

PR #1832

@cortiz cortiz moved this from Backlog to Completed in Crafter CMS v3.0.x Feb 5, 2018

@cortiz cortiz moved this from Completed to Test & Validate in Crafter CMS v3.0.x Feb 5, 2018

sumerjabri added a commit that referenced this issue Feb 5, 2018

@luishernandezmonge

This comment has been minimized.

Show comment
Hide comment
@luishernandezmonge

luishernandezmonge Feb 6, 2018

Member

Verified as resolved

Member

luishernandezmonge commented Feb 6, 2018

Verified as resolved

Crafter CMS v3.0.x automation moved this from Test & Validate to Completed Feb 6, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment