Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 171 lines (165 sloc) 6.442 kB
cc715f7 @nicolasblanco Adds gemspec
nicolasblanco authored
1 # Generated by jeweler
2 # DO NOT EDIT THIS FILE DIRECTLY
3 # Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
4 # -*- encoding: utf-8 -*-
5
6 Gem::Specification.new do |s|
14a5f25 @crafterm [NEW] 0.4.2 release
authored
7 s.name = %q{sprinkle}
8 s.version = "0.4.2"
cc715f7 @nicolasblanco Adds gemspec
nicolasblanco authored
9
10 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
cdc8295 @crafterm Updated gemspec
authored
11 s.authors = ["Marcus Crafter"]
14a5f25 @crafterm [NEW] 0.4.2 release
authored
12 s.date = %q{2011-10-04}
13 s.default_executable = %q{sprinkle}
14 s.description = %q{Ruby DSL based software provisioning tool}
15 s.email = %q{crafterm@redartisan.com}
cdc8295 @crafterm Updated gemspec
authored
16 s.executables = ["sprinkle"]
cc715f7 @nicolasblanco Adds gemspec
nicolasblanco authored
17 s.extra_rdoc_files = [
cdc8295 @crafterm Updated gemspec
authored
18 "README.markdown",
19 "TODO"
cc715f7 @nicolasblanco Adds gemspec
nicolasblanco authored
20 ]
21 s.files = [
22 "CREDITS",
23 "MIT-LICENSE",
24 "README.markdown",
25 "Rakefile",
26 "VERSION",
27 "bin/sprinkle",
28 "examples/packages/build_essential.rb",
29 "examples/packages/databases/mysql.rb",
30 "examples/packages/databases/sqlite3.rb",
31 "examples/packages/phusion.rb",
32 "examples/packages/ruby/rails.rb",
33 "examples/packages/ruby/ruby.rb",
34 "examples/packages/ruby/rubygems.rb",
35 "examples/packages/scm/git.rb",
36 "examples/packages/scm/subversion.rb",
37 "examples/packages/servers/apache.rb",
38 "examples/rails/README",
39 "examples/rails/deploy.rb",
40 "examples/rails/packages/database.rb",
41 "examples/rails/packages/essential.rb",
42 "examples/rails/packages/rails.rb",
43 "examples/rails/packages/scm.rb",
44 "examples/rails/packages/search.rb",
45 "examples/rails/packages/server.rb",
46 "examples/rails/rails.rb",
47 "examples/sprinkle/sprinkle.rb",
48 "lib/sprinkle.rb",
49 "lib/sprinkle/actors/actors.rb",
50 "lib/sprinkle/actors/capistrano.rb",
51 "lib/sprinkle/actors/local.rb",
52 "lib/sprinkle/actors/ssh.rb",
53 "lib/sprinkle/actors/vlad.rb",
54 "lib/sprinkle/configurable.rb",
55 "lib/sprinkle/deployment.rb",
56 "lib/sprinkle/extensions/arbitrary_options.rb",
57 "lib/sprinkle/extensions/array.rb",
58 "lib/sprinkle/extensions/blank_slate.rb",
59 "lib/sprinkle/extensions/dsl_accessor.rb",
60 "lib/sprinkle/extensions/string.rb",
61 "lib/sprinkle/extensions/symbol.rb",
62 "lib/sprinkle/installers/apt.rb",
63 "lib/sprinkle/installers/binary.rb",
14a5f25 @crafterm [NEW] 0.4.2 release
authored
64 "lib/sprinkle/installers/brew.rb",
cc715f7 @nicolasblanco Adds gemspec
nicolasblanco authored
65 "lib/sprinkle/installers/bsd_port.rb",
66 "lib/sprinkle/installers/deb.rb",
67 "lib/sprinkle/installers/freebsd_pkg.rb",
68 "lib/sprinkle/installers/freebsd_portinstall.rb",
69 "lib/sprinkle/installers/gem.rb",
e4fdd28 @crafterm [NEW] 0.4.0 release
authored
70 "lib/sprinkle/installers/group.rb",
cc715f7 @nicolasblanco Adds gemspec
nicolasblanco authored
71 "lib/sprinkle/installers/install_package.rb",
72 "lib/sprinkle/installers/installer.rb",
73 "lib/sprinkle/installers/mac_port.rb",
74 "lib/sprinkle/installers/openbsd_pkg.rb",
75 "lib/sprinkle/installers/opensolaris_pkg.rb",
76 "lib/sprinkle/installers/pacman.rb",
77 "lib/sprinkle/installers/push_text.rb",
78 "lib/sprinkle/installers/rake.rb",
79 "lib/sprinkle/installers/replace_text.rb",
80 "lib/sprinkle/installers/rpm.rb",
81 "lib/sprinkle/installers/runner.rb",
82 "lib/sprinkle/installers/smart.rb",
83 "lib/sprinkle/installers/source.rb",
693657a @crafterm [NEW] 0.3.6 gemspec
authored
84 "lib/sprinkle/installers/thor.rb",
cc715f7 @nicolasblanco Adds gemspec
nicolasblanco authored
85 "lib/sprinkle/installers/transfer.rb",
86 "lib/sprinkle/installers/user.rb",
87 "lib/sprinkle/installers/yum.rb",
88 "lib/sprinkle/installers/zypper.rb",
89 "lib/sprinkle/package.rb",
90 "lib/sprinkle/policy.rb",
91 "lib/sprinkle/script.rb",
92 "lib/sprinkle/verifiers/apt.rb",
14a5f25 @crafterm [NEW] 0.4.2 release
authored
93 "lib/sprinkle/verifiers/brew.rb",
cc715f7 @nicolasblanco Adds gemspec
nicolasblanco authored
94 "lib/sprinkle/verifiers/directory.rb",
95 "lib/sprinkle/verifiers/executable.rb",
96 "lib/sprinkle/verifiers/file.rb",
97 "lib/sprinkle/verifiers/package.rb",
98 "lib/sprinkle/verifiers/process.rb",
99 "lib/sprinkle/verifiers/rpm.rb",
100 "lib/sprinkle/verifiers/ruby.rb",
101 "lib/sprinkle/verifiers/symlink.rb",
e4fdd28 @crafterm [NEW] 0.4.0 release
authored
102 "lib/sprinkle/verifiers/users_groups.rb",
cc715f7 @nicolasblanco Adds gemspec
nicolasblanco authored
103 "lib/sprinkle/verify.rb",
104 "script/console",
105 "script/destroy",
106 "script/generate",
107 "spec/spec.opts",
108 "spec/spec_helper.rb",
109 "spec/sprinkle/actors/capistrano_spec.rb",
110 "spec/sprinkle/actors/local_spec.rb",
111 "spec/sprinkle/configurable_spec.rb",
112 "spec/sprinkle/deployment_spec.rb",
113 "spec/sprinkle/extensions/array_spec.rb",
114 "spec/sprinkle/extensions/string_spec.rb",
115 "spec/sprinkle/installers/apt_spec.rb",
116 "spec/sprinkle/installers/binary_spec.rb",
14a5f25 @crafterm [NEW] 0.4.2 release
authored
117 "spec/sprinkle/installers/brew_spec.rb",
cc715f7 @nicolasblanco Adds gemspec
nicolasblanco authored
118 "spec/sprinkle/installers/bsd_port_spec.rb",
119 "spec/sprinkle/installers/freebsd_pkg_spec.rb",
120 "spec/sprinkle/installers/freebsd_portinstall_spec.rb",
121 "spec/sprinkle/installers/gem_spec.rb",
122 "spec/sprinkle/installers/installer_spec.rb",
123 "spec/sprinkle/installers/mac_port_spec.rb",
124 "spec/sprinkle/installers/openbsd_pkg_spec.rb",
125 "spec/sprinkle/installers/opensolaris_pkg_spec.rb",
126 "spec/sprinkle/installers/push_text_spec.rb",
127 "spec/sprinkle/installers/rake_spec.rb",
128 "spec/sprinkle/installers/replace_text_spec.rb",
129 "spec/sprinkle/installers/rpm_spec.rb",
130 "spec/sprinkle/installers/runner_spec.rb",
131 "spec/sprinkle/installers/source_spec.rb",
693657a @crafterm [NEW] 0.3.6 gemspec
authored
132 "spec/sprinkle/installers/thor_spec.rb",
cc715f7 @nicolasblanco Adds gemspec
nicolasblanco authored
133 "spec/sprinkle/installers/transfer_spec.rb",
134 "spec/sprinkle/installers/yum_spec.rb",
135 "spec/sprinkle/installers/zypper_spec.rb",
136 "spec/sprinkle/package_spec.rb",
137 "spec/sprinkle/policy_spec.rb",
138 "spec/sprinkle/script_spec.rb",
139 "spec/sprinkle/sprinkle_spec.rb",
cdc8295 @crafterm Updated gemspec
authored
140 "spec/sprinkle/verify_spec.rb",
141 "sprinkle.gemspec"
cc715f7 @nicolasblanco Adds gemspec
nicolasblanco authored
142 ]
14a5f25 @crafterm [NEW] 0.4.2 release
authored
143 s.homepage = %q{http://github.com/crafterm/sprinkle}
cdc8295 @crafterm Updated gemspec
authored
144 s.require_paths = ["lib"]
14a5f25 @crafterm [NEW] 0.4.2 release
authored
145 s.rubyforge_project = %q{sprinkle}
146 s.rubygems_version = %q{1.4.2}
147 s.summary = %q{Ruby DSL based software provisioning tool}
cc715f7 @nicolasblanco Adds gemspec
nicolasblanco authored
148
149 if s.respond_to? :specification_version then
150 s.specification_version = 3
151
152 if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
153 s.add_development_dependency(%q<rspec>, [">= 2.5"])
154 s.add_runtime_dependency(%q<activesupport>, [">= 2.0.2"])
155 s.add_runtime_dependency(%q<highline>, [">= 1.4.0"])
156 s.add_runtime_dependency(%q<capistrano>, [">= 2.5.5"])
157 else
158 s.add_dependency(%q<rspec>, [">= 2.5"])
159 s.add_dependency(%q<activesupport>, [">= 2.0.2"])
160 s.add_dependency(%q<highline>, [">= 1.4.0"])
161 s.add_dependency(%q<capistrano>, [">= 2.5.5"])
162 end
163 else
164 s.add_dependency(%q<rspec>, [">= 2.5"])
165 s.add_dependency(%q<activesupport>, [">= 2.0.2"])
166 s.add_dependency(%q<highline>, [">= 1.4.0"])
167 s.add_dependency(%q<capistrano>, [">= 2.5.5"])
168 end
169 end
170
Something went wrong with that request. Please try again.