Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 165 lines (161 sloc) 6.267 kb
cc715f79 » nicolasblanco
2011-08-24 Adds gemspec
1 # Generated by jeweler
2 # DO NOT EDIT THIS FILE DIRECTLY
3 # Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
4 # -*- encoding: utf-8 -*-
5
6 Gem::Specification.new do |s|
cdc82950 »
2011-09-09 Updated gemspec
7 s.name = "sprinkle"
e4fdd285 »
2011-09-18 [NEW] 0.4.0 release
8 s.version = "0.4.0"
cc715f79 » nicolasblanco
2011-08-24 Adds gemspec
9
10 s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
cdc82950 »
2011-09-09 Updated gemspec
11 s.authors = ["Marcus Crafter"]
e4fdd285 »
2011-09-18 [NEW] 0.4.0 release
12 s.date = "2011-09-18"
cdc82950 »
2011-09-09 Updated gemspec
13 s.description = "Ruby DSL based software provisioning tool"
14 s.email = "crafterm@redartisan.com"
15 s.executables = ["sprinkle"]
cc715f79 » nicolasblanco
2011-08-24 Adds gemspec
16 s.extra_rdoc_files = [
cdc82950 »
2011-09-09 Updated gemspec
17 "README.markdown",
18 "TODO"
cc715f79 » nicolasblanco
2011-08-24 Adds gemspec
19 ]
20 s.files = [
21 "CREDITS",
22 "MIT-LICENSE",
23 "README.markdown",
24 "Rakefile",
25 "VERSION",
26 "bin/sprinkle",
27 "examples/packages/build_essential.rb",
28 "examples/packages/databases/mysql.rb",
29 "examples/packages/databases/sqlite3.rb",
30 "examples/packages/phusion.rb",
31 "examples/packages/ruby/rails.rb",
32 "examples/packages/ruby/ruby.rb",
33 "examples/packages/ruby/rubygems.rb",
34 "examples/packages/scm/git.rb",
35 "examples/packages/scm/subversion.rb",
36 "examples/packages/servers/apache.rb",
37 "examples/rails/README",
38 "examples/rails/deploy.rb",
39 "examples/rails/packages/database.rb",
40 "examples/rails/packages/essential.rb",
41 "examples/rails/packages/rails.rb",
42 "examples/rails/packages/scm.rb",
43 "examples/rails/packages/search.rb",
44 "examples/rails/packages/server.rb",
45 "examples/rails/rails.rb",
46 "examples/sprinkle/sprinkle.rb",
47 "lib/sprinkle.rb",
48 "lib/sprinkle/actors/actors.rb",
49 "lib/sprinkle/actors/capistrano.rb",
50 "lib/sprinkle/actors/local.rb",
51 "lib/sprinkle/actors/ssh.rb",
52 "lib/sprinkle/actors/vlad.rb",
53 "lib/sprinkle/configurable.rb",
54 "lib/sprinkle/deployment.rb",
55 "lib/sprinkle/extensions/arbitrary_options.rb",
56 "lib/sprinkle/extensions/array.rb",
57 "lib/sprinkle/extensions/blank_slate.rb",
58 "lib/sprinkle/extensions/dsl_accessor.rb",
59 "lib/sprinkle/extensions/string.rb",
60 "lib/sprinkle/extensions/symbol.rb",
61 "lib/sprinkle/installers/apt.rb",
62 "lib/sprinkle/installers/binary.rb",
63 "lib/sprinkle/installers/bsd_port.rb",
64 "lib/sprinkle/installers/deb.rb",
65 "lib/sprinkle/installers/freebsd_pkg.rb",
66 "lib/sprinkle/installers/freebsd_portinstall.rb",
67 "lib/sprinkle/installers/gem.rb",
e4fdd285 »
2011-09-18 [NEW] 0.4.0 release
68 "lib/sprinkle/installers/group.rb",
cc715f79 » nicolasblanco
2011-08-24 Adds gemspec
69 "lib/sprinkle/installers/install_package.rb",
70 "lib/sprinkle/installers/installer.rb",
71 "lib/sprinkle/installers/mac_port.rb",
72 "lib/sprinkle/installers/openbsd_pkg.rb",
73 "lib/sprinkle/installers/opensolaris_pkg.rb",
74 "lib/sprinkle/installers/pacman.rb",
75 "lib/sprinkle/installers/push_text.rb",
76 "lib/sprinkle/installers/rake.rb",
77 "lib/sprinkle/installers/replace_text.rb",
78 "lib/sprinkle/installers/rpm.rb",
79 "lib/sprinkle/installers/runner.rb",
80 "lib/sprinkle/installers/smart.rb",
81 "lib/sprinkle/installers/source.rb",
693657a4 »
2011-09-10 [NEW] 0.3.6 gemspec
82 "lib/sprinkle/installers/thor.rb",
cc715f79 » nicolasblanco
2011-08-24 Adds gemspec
83 "lib/sprinkle/installers/transfer.rb",
84 "lib/sprinkle/installers/user.rb",
85 "lib/sprinkle/installers/yum.rb",
86 "lib/sprinkle/installers/zypper.rb",
87 "lib/sprinkle/package.rb",
88 "lib/sprinkle/policy.rb",
89 "lib/sprinkle/script.rb",
90 "lib/sprinkle/verifiers/apt.rb",
91 "lib/sprinkle/verifiers/directory.rb",
92 "lib/sprinkle/verifiers/executable.rb",
93 "lib/sprinkle/verifiers/file.rb",
94 "lib/sprinkle/verifiers/package.rb",
95 "lib/sprinkle/verifiers/process.rb",
96 "lib/sprinkle/verifiers/rpm.rb",
97 "lib/sprinkle/verifiers/ruby.rb",
98 "lib/sprinkle/verifiers/symlink.rb",
e4fdd285 »
2011-09-18 [NEW] 0.4.0 release
99 "lib/sprinkle/verifiers/users_groups.rb",
cc715f79 » nicolasblanco
2011-08-24 Adds gemspec
100 "lib/sprinkle/verify.rb",
101 "script/console",
102 "script/destroy",
103 "script/generate",
104 "spec/spec.opts",
105 "spec/spec_helper.rb",
106 "spec/sprinkle/actors/capistrano_spec.rb",
107 "spec/sprinkle/actors/local_spec.rb",
108 "spec/sprinkle/configurable_spec.rb",
109 "spec/sprinkle/deployment_spec.rb",
110 "spec/sprinkle/extensions/array_spec.rb",
111 "spec/sprinkle/extensions/string_spec.rb",
112 "spec/sprinkle/installers/apt_spec.rb",
113 "spec/sprinkle/installers/binary_spec.rb",
114 "spec/sprinkle/installers/bsd_port_spec.rb",
115 "spec/sprinkle/installers/freebsd_pkg_spec.rb",
116 "spec/sprinkle/installers/freebsd_portinstall_spec.rb",
117 "spec/sprinkle/installers/gem_spec.rb",
118 "spec/sprinkle/installers/installer_spec.rb",
119 "spec/sprinkle/installers/mac_port_spec.rb",
120 "spec/sprinkle/installers/openbsd_pkg_spec.rb",
121 "spec/sprinkle/installers/opensolaris_pkg_spec.rb",
122 "spec/sprinkle/installers/push_text_spec.rb",
123 "spec/sprinkle/installers/rake_spec.rb",
124 "spec/sprinkle/installers/replace_text_spec.rb",
125 "spec/sprinkle/installers/rpm_spec.rb",
126 "spec/sprinkle/installers/runner_spec.rb",
127 "spec/sprinkle/installers/source_spec.rb",
693657a4 »
2011-09-10 [NEW] 0.3.6 gemspec
128 "spec/sprinkle/installers/thor_spec.rb",
cc715f79 » nicolasblanco
2011-08-24 Adds gemspec
129 "spec/sprinkle/installers/transfer_spec.rb",
130 "spec/sprinkle/installers/yum_spec.rb",
131 "spec/sprinkle/installers/zypper_spec.rb",
132 "spec/sprinkle/package_spec.rb",
133 "spec/sprinkle/policy_spec.rb",
134 "spec/sprinkle/script_spec.rb",
135 "spec/sprinkle/sprinkle_spec.rb",
cdc82950 »
2011-09-09 Updated gemspec
136 "spec/sprinkle/verify_spec.rb",
137 "sprinkle.gemspec"
cc715f79 » nicolasblanco
2011-08-24 Adds gemspec
138 ]
cdc82950 »
2011-09-09 Updated gemspec
139 s.homepage = "http://github.com/crafterm/sprinkle"
140 s.require_paths = ["lib"]
141 s.rubyforge_project = "sprinkle"
142 s.rubygems_version = "1.8.10"
143 s.summary = "Ruby DSL based software provisioning tool"
cc715f79 » nicolasblanco
2011-08-24 Adds gemspec
144
145 if s.respond_to? :specification_version then
146 s.specification_version = 3
147
148 if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
149 s.add_development_dependency(%q<rspec>, [">= 2.5"])
150 s.add_runtime_dependency(%q<activesupport>, [">= 2.0.2"])
151 s.add_runtime_dependency(%q<highline>, [">= 1.4.0"])
152 s.add_runtime_dependency(%q<capistrano>, [">= 2.5.5"])
153 else
154 s.add_dependency(%q<rspec>, [">= 2.5"])
155 s.add_dependency(%q<activesupport>, [">= 2.0.2"])
156 s.add_dependency(%q<highline>, [">= 1.4.0"])
157 s.add_dependency(%q<capistrano>, [">= 2.5.5"])
158 end
159 else
160 s.add_dependency(%q<rspec>, [">= 2.5"])
161 s.add_dependency(%q<activesupport>, [">= 2.0.2"])
162 s.add_dependency(%q<highline>, [">= 1.4.0"])
163 s.add_dependency(%q<capistrano>, [">= 2.5.5"])
164 end
165 end
166
Something went wrong with that request. Please try again.