Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Install 32 bit on MacOS #174

Closed
Jonovono opened this Issue · 6 comments

6 participants

@Jonovono

Hello. I am running macos 10.6.8 and would like to have a 32 bit version so that I can run appjs. I can't seem to get it working.

I want to install this node here: http://nodejs.org/dist/v0.8.15/node-v0.8.15-darwin-x86.tar.gz

How would I go about this? Thanks.

@dougnukem

I'm also interested in doing this, and not sure how to go about it.

I've tried the following but it resulted in an error:

ddaniels@ddaniels-mbp ~/nvm/bin$ nvm install 0.8.15-darwin-x86
######################################################################## 100.0%
Checksums do not match.
Binary download failed, trying source.
Additional options while compiling: 
nvm: install N/A failed!
@dougnukem

I was able to get it to work and register it to be recognized by nvm but it's kind of a hack.

$ curl http://nodejs.org/dist/v0.8.15/node-v0.8.15-darwin-x86.tar.gz | tar xvz
$ mv node-v0.8.15-darwin-x86 ~/nvm/v0.8.15-darwin-x86
$ nvm ls
    v0.6.8      v0.8.15-darwin-x86
   v0.8.15
current:    v0.8.15

$ nvm use v0.8.15-darwin-x86
Now using node v0.8.15-darwin-x86
$ ls -al `which node`
-rwxr-xr-x  1 ddaniels  staff  8767976 Nov 26 10:52 /Users/ddaniels/nvm/v0.8.15-darwin-x86/bin/node
@endel

+1, more specifically to use appjs

nvm shouldn't accept additional options, like --dest-cpu? I've tried using nvm install v0.8.6 --dest-cpu=ia32, but it still selects x64.

@mattsawyer77

+1, and what @endel said.

@ljharb
Collaborator

Please reopen if you still have a use case (or a computer left) that's 32-bit.

@ljharb ljharb closed this
@jlandrum

http://appjs.com/
Not sure if it's worth considering though - they do offer a package that I think includes 32-bit node.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.