Error: npm doesn't work with node v0.4.11 #91

Closed
edwardhotchkiss opened this Issue Dec 22, 2011 · 2 comments

Projects

None yet

3 participants

@edwardhotchkiss
$ npm install
Error: npm doesn't work with node v0.4.11
Required: node@0.6 || 0.7 || 0.8
    at /usr/local/lib/node_modules/npm/bin/npm-cli.js:60:23
    at Object.<anonymous> (/usr/local/lib/node_modules/npm/bin/npm-cli.js:80:2)
    at Module._compile (module.js:402:26)
    at Object..js (module.js:408:10)
    at Module.load (module.js:334:31)
    at Function._load (module.js:293:12)
    at Array.0 (module.js:421:10)
    at EventEmitter._tickCallback (node.js:126:26)
@samsm
samsm commented Jan 5, 2012

I ran into this, basically npm didn't get installed with v0.4.11. Usually nvm does install an appropriate npm.

Installing npm 'manually' (curl http://npmjs.org/install.sh | sh) rectified it for me, putting an appropriate npm in .nvm/v0.4.11/bin/npm

@ljharb
Collaborator
ljharb commented Jun 14, 2013

Node 0.4 is very very old. Please upgrade to 0.8 or 0.10 at your earliest convenience.

@ljharb ljharb closed this Jun 14, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment