Permalink
Browse files

Relax dependency on template-haskell, since it depends on the compile…

…r version
  • Loading branch information...
1 parent 1b87f03 commit 5106874701a403578ebd75ed96d84ed2160b8c28 Josh Hoyt committed Jul 11, 2011
Showing with 7 additions and 2 deletions.
  1. +1 −1 bin/runtests
  2. +6 −1 cabal-dev.cabal
View
@@ -1,2 +1,2 @@
#!/usr/bin/env bash
-runhaskell -isrc admin/bootstrap.hs --run-tests
+runhaskell -isrc admin/bootstrap.hs --run-tests "$@"
View
@@ -125,7 +125,12 @@ Executable cabal-dev
process >= 1.0 && < 1.1,
tar >= 0.3 && < 0.4,
zlib >= 0.5 && < 0.6,
- template-haskell == 2.5.*
+
+ -- Template haskell is special: the compiler will die if a
+ -- version other than the one that is shipped with the compiler
+ -- is used. Here, we don't constrain the version and hope that
+ -- there will be only one.
+ template-haskell
if os(windows)
build-depends: Win32 >= 2.1 && < 2.3

0 comments on commit 5106874

Please sign in to comment.