Permalink
Browse files

Merge pull request #46 from hvr/master-ghc741

Relax version constraints to support building with GHC-7.4.1 RC1
  • Loading branch information...
2 parents c912ca9 + 036cd8d commit d631dffa0864e07f266c70cca7beb8856cbf374b Jonathan Daugherty committed Jan 1, 2012
Showing with 8 additions and 8 deletions.
  1. +8 −8 cabal-dev.cabal
View
@@ -93,9 +93,9 @@ Executable cabal-dev
Build-depends:
bytestring >= 0.9 && < 0.10,
directory >= 1.0 && < 1.3,
- filepath >= 1.1 && < 1.3,
- Cabal >= 1.10.0.0 && < 1.13,
- HTTP >= 4000.0.9 && < 4000.2,
+ filepath >= 1.1 && < 1.4,
+ Cabal >= 1.10.0.0 && < 1.15,
+ HTTP >= 4000.0.9 && < 4000.3,
mtl >= 1.1 && < 2.1,
network >= 2.2 && < 2.4,
pretty >= 1.0 && < 1.2,
@@ -139,7 +139,7 @@ Executable ghc-pkg-6_8-compat
Main-is: GhcPkgCompat.hs
Build-Depends:
base < 5,
- Cabal >=1.2 && < 1.13
+ Cabal >=1.2 && < 1.15
GHC-Options: -Wall
HS-Source-Dirs: src
@@ -161,15 +161,15 @@ Executable cabal-dev-test
Build-depends:
MonadRandom >= 0.1 && < 0.2,
random >= 1 && < 1.1,
- test-framework >= 0.3 && < 0.4,
+ test-framework >= 0.3 && < 0.5,
test-framework-hunit >= 0.2,
HUnit >= 1.2 && <2,
-- These dependencies are needed for the cabal-install
-- code that is pulled in automatically by the userhooks
- containers >= 0.1 && < 0.4,
+ containers >= 0.1 && < 0.5,
network >= 1 && < 3,
- array >= 0.1 && < 0.4,
- pretty >= 1 && < 1.1
+ array >= 0.1 && < 0.5,
+ pretty >= 1 && < 1.2
if os(windows)
build-depends: Win32 >= 2.1 && < 2.3

0 comments on commit d631dff

Please sign in to comment.