Possible issue with shared libraries #7

Open
j3h opened this Issue Jan 24, 2011 · 1 comment

Comments

Projects
None yet
2 participants
Collaborator

j3h commented Jan 24, 2011

Henning Thielemann reported the following failure via e-mail:

Can cabal-dev cope with shared libraries?

$ cabal-dev install --enable-shared --constraint="QuickCheck>=2" non-negative
Resolving dependencies...
Configuring non-negative-0.1...
Preprocessing library non-negative-0.1...
Preprocessing executables for non-negative-0.1...
Building non-negative-0.1...
[1 of 4] Compiling Numeric.NonNegative.Class ( src/Numeric/NonNegative/Class.hs, dist/build/Numeric/NonNegative/Class.o )
[2 of 4] Compiling Numeric.NonNegative.Wrapper ( src/Numeric/NonNegative/Wrapper.hs, dist/build/Numeric/NonNegative/Wrapper.o )
[3 of 4] Compiling Numeric.NonNegative.ChunkyPrivate ( src/Numeric/NonNegative/ChunkyPrivate.hs, dist/build/Numeric/NonNegative/ChunkyPrivate.o )
[4 of 4] Compiling Numeric.NonNegative.Chunky ( src/Numeric/NonNegative/Chunky.hs, dist/build/Numeric/NonNegative/Chunky.o )
[1 of 4] Compiling Numeric.NonNegative.Class ( src/Numeric/NonNegative/Class.hs, dist/build/Numeric/NonNegative/Class.dyn_o )
[2 of 4] Compiling Numeric.NonNegative.Wrapper ( src/Numeric/NonNegative/Wrapper.hs, dist/build/Numeric/NonNegative/Wrapper.dyn_o )
[3 of 4] Compiling Numeric.NonNegative.ChunkyPrivate ( src/Numeric/NonNegative/ChunkyPrivate.hs, dist/build/Numeric/NonNegative/ChunkyPrivate.dyn_o )
[4 of 4] Compiling Numeric.NonNegative.Chunky ( src/Numeric/NonNegative/Chunky.hs, dist/build/Numeric/NonNegative/Chunky.dyn_o )
<command line>: cannot satisfy -package-id QuickCheck-2.4.0.1-d485bec543ae623a1e89f94a89fbec36
    (use -v for more information)
cabal: Error: some packages failed to install:
non-negative-0.1 failed during the building phase. The exception was:
ExitFailure 1

If I omit the --enable-shared flag, then the package can be built. I have installed QuickCheck with --enable-shared.

tene commented May 26, 2013

I just ran into this problem. From a clean install of haskell-platform, I ran:

cabal update
vim .cabal/config # enable shared
cabal install cabal-install
cabal install cabal-dev
mkdir test
cd test
cabal-dev install vty

This installed three dependencies (string-qq, utf8-string, and terminfo) and then failed at the end of building vty:

[18 of 18] Compiling Graphics.Vty ( src/Graphics/Vty.hs, dist/build/Graphics/Vty.dyn_o )
: cannot satisfy -package-id terminfo-0.3.2.5-4d1c81be8d263b97c08424418c50ad5a

If I install terminfo globally with 'cabal install' then it moves on to failing in the same way with utf8-string. Installing utf8-string globally, string-qq. Installing string-qq globally lets vty install successfully under cabal-dev. Adding this to the build dependencies in my .cabal file does not help this.

With shared disabled, everything builds and installs fine with cabal-dev.

This really is a clean install:

[sweeks@kweh ~]$ ghc-pkg list --user
/home/sweeks/.ghc/x86_64-linux-7.4.2/package.conf.d
Cabal-1.16.0.3
setenv-0.1.0
tar-0.4.0.1

Chatting with a few people on IRC, we didn't find any way to resolve this by changing anything's requirements.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment