New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Plugin Support #34

Open
cretz opened this Issue Sep 12, 2017 · 1 comment

Comments

2 participants
@cretz
Owner

cretz commented Sep 12, 2017

This issue is kinda a catch-all for plugins. Some quick thoughts:

  • Need a more stable ABI before exposing or we need to only expose certain pieces
  • Essentially a DLL that can use all the Qt it wants
  • There is no plugin store or plugin vetting process, if you use a plugin you are basically giving the plugin dev full rights over everything. We don't have the bandwidth to be the jury here.
  • Would of course need a plugin init that does version check and what not
  • Not to be confused with extensions

@cretz cretz added the enhancement label Sep 12, 2017

@tfont

This comment has been minimized.

Show comment
Hide comment
@tfont

tfont Sep 26, 2017

This is a huge enhancement and it's what separates the user from fully using Doogie over Chrome.

tfont commented Sep 26, 2017

This is a huge enhancement and it's what separates the user from fully using Doogie over Chrome.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment