Permalink
Browse files

reduce duplication for version, use bundler to ease development, clea…

…nup gemspec
  • Loading branch information...
1 parent 8c5ef06 commit dcc3dddf3fa6336b13871c66cce4cd4d1d2e59bc @ttilley ttilley committed Feb 6, 2011
Showing with 40 additions and 17 deletions.
  1. +11 −1 .gitignore
  2. +3 −0 Gemfile
  3. +3 −0 Rakefile
  4. +19 −14 braid.gemspec
  5. +1 −2 lib/braid.rb
  6. +3 −0 lib/braid/version.rb
View
@@ -1,2 +1,12 @@
-pkg
*.gem
+*.rbc
+*.sw?
+.DS_Store
+.bundle
+.idea
+Gemfile.lock
+coverage
+nbproject
+pkg
+pkg/*
+rdoc
View
@@ -0,0 +1,3 @@
+source "http://rubygems.org"
+
+gemspec
View
@@ -1,3 +1,6 @@
+require 'bundler'
+Bundler::GemHelper.install_tasks
+
require 'rake'
require 'rake/testtask'
View
@@ -1,24 +1,29 @@
+# -*- encoding: utf-8 -*-
+$:.push File.expand_path("../lib", __FILE__)
+require 'braid/version'
+
Gem::Specification.new do |s|
s.name = %q{braid}
- s.version = "0.6.2.1"
-
- s.specification_version = 2 if s.respond_to? :specification_version=
+ s.version = Braid::VERSION
+ s.platform = Gem::Platform::RUBY
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Cristi Balan", "Norbert Crombach"]
- s.date = %q{2010-07-19}
- s.default_executable = %q{braid}
- s.description = %q{A simple tool for tracking vendor branches in git.}
s.email = %q{evil@che.lu}
- s.executables = ["braid"]
- s.files = ["braid.gemspec", "LICENSE", "README.textile", "Rakefile"] + Dir["bin/*"] + Dir["lib/**/*.rb"] + Dir["test/**/*.rb"]
- s.has_rdoc = false
+
s.homepage = %q{http://evil.che.lu/projects/braid}
- s.rdoc_options = ["--line-numbers", "--inline-source", "--title", "braid", "--main"]
- s.require_paths = ["lib"]
- s.rubyforge_project = %q{braid}
- s.rubygems_version = %q{1.1.0}
s.summary = %q{A simple tool for tracking vendor branches in git.}
+ s.description = %q{A simple tool for tracking vendor branches in git.}
+
+ s.rubyforge_project = %q{braid}
+
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
+ s.executables = `git ls-files -- bin/*`.split("\n").map { |f| File.basename(f) }
+ s.default_executable = %q{braid}
+ s.require_paths = ["lib"]
+
+ s.has_rdoc = false
+ s.rdoc_options = ["--line-numbers", "--inline-source", "--title", "braid", "--main"]
s.add_dependency(%q<main>, [">= 4.2.0"])
s.add_dependency(%q<open4>, [">= 1.0.1"]) unless defined?(JRUBY_VERSION)
View
@@ -1,8 +1,7 @@
$:.unshift dirname = File.dirname(__FILE__)
+require 'braid/version'
module Braid
- VERSION = "0.6.2"
-
CONFIG_FILE = ".braids"
REQUIRED_GIT_VERSION = "1.6"
View
@@ -0,0 +1,3 @@
+module Braid
+ VERSION = "0.6.2.1"
+end

0 comments on commit dcc3ddd

Please sign in to comment.