Permalink
Browse files

I don't even want to know why psych is failing with errors like this …

…one:


```
`@vendor/rails' is not allowed as an instance variable name (NameError)
```
  • Loading branch information...
ttilley committed Sep 6, 2011
1 parent 0c16755 commit f08fac25570a1a56de8d6282f637d0604ef5e210
Showing with 5 additions and 0 deletions.
  1. +5 −0 lib/braid/config.rb
View
@@ -1,4 +1,9 @@
require 'yaml'
+
+# psych throws such wonderful errors as:
+# `@vendor/rails' is not allowed as an instance variable name (NameError)
+YAML::ENGINE.yamler = 'syck' if RUBY_VERSION >= '1.9.1'
+
require 'yaml/store'
module Braid

0 comments on commit f08fac2

Please sign in to comment.