New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Some of the tools are not Python 3.x compatible #2

Open
pavlix opened this Issue Sep 24, 2016 · 4 comments

Comments

Projects
None yet
1 participant
@pavlix
Member

pavlix commented Sep 24, 2016

Some of the tools are still not Python 3.x compatible. I'm trying to handle that at the respective upstreams.

@pavlix

This comment has been minimized.

Show comment
Hide comment
@pavlix

pavlix Oct 4, 2016

Member

We're now using a koji fork to support Python 3.x as upstream will not accept patches any time soon due to their support for Python 2.4.3.

Member

pavlix commented Oct 4, 2016

We're now using a koji fork to support Python 3.x as upstream will not accept patches any time soon due to their support for Python 2.4.3.

@pavlix

This comment has been minimized.

Show comment
Hide comment
@pavlix

pavlix Oct 4, 2016

Member

Done the same with rpkg because it's not yet ready to be merged either.

Member

pavlix commented Oct 4, 2016

Done the same with rpkg because it's not yet ready to be merged either.

@pavlix

This comment has been minimized.

Show comment
Hide comment
@pavlix

pavlix Oct 4, 2016

Member

Now let's keep this issue open for upstreaming the changes in forked packages.

Member

pavlix commented Oct 4, 2016

Now let's keep this issue open for upstreaming the changes in forked packages.

@pavlix

This comment has been minimized.

Show comment
Hide comment
@pavlix

pavlix Oct 20, 2016

Member

Other tools are currently only built for Python 2.7:

  • kobo-9999.ebuild
  • marshmallow-9999.ebuild
  • python-krbV-9999.ebuild now replaced with requests-gssapi ebuild
  • copr-9999.ebuild
  • offtrac-9999.ebuild
  • repoze-who-friendlyform-9999.ebuild
  • repoze-who-9999.ebuild
  • rpmlint-9999.ebuild
  • tito-9999.ebuild
  • bodhi-9999.ebuild
  • fedora-review-9999.ebuild
  • rebase-helper-9999.ebuild
  • copr-cli-9999.ebuild
Member

pavlix commented Oct 20, 2016

Other tools are currently only built for Python 2.7:

  • kobo-9999.ebuild
  • marshmallow-9999.ebuild
  • python-krbV-9999.ebuild now replaced with requests-gssapi ebuild
  • copr-9999.ebuild
  • offtrac-9999.ebuild
  • repoze-who-friendlyform-9999.ebuild
  • repoze-who-9999.ebuild
  • rpmlint-9999.ebuild
  • tito-9999.ebuild
  • bodhi-9999.ebuild
  • fedora-review-9999.ebuild
  • rebase-helper-9999.ebuild
  • copr-cli-9999.ebuild
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment