Skip to content
Permalink
Branch: master
Find file Copy path
Find file Copy path
Fetching contributors…
Cannot retrieve contributors at this time
50 lines (35 sloc) 1.35 KB

Installation

Required dependencies

Minimum dependency versions

pyscenarios adopts a rolling policy based on NEP-29 regarding the minimum supported version of its dependencies:

  • Python: 42 months (NEP-29)
  • numpy: 24 months (NEP-29)
  • pandas: 12 months
  • scipy: 12 months
  • all other libraries: 6 months

The above should be interpreted as the minor version (X.Y) initially published no more than N months ago. Patch versions (x.y.Z) are not pinned, and only the latest available at the moment of publishing the xarray release is guaranteed to work.

You can see the actual minimum tested versions in the anaconda requirements file.

Testing

To run the test suite after installing pyscenarios, first install (via pypi or conda)

  • py.test: Simple unit testing library

and run py.test.

You can’t perform that action at this time.